aboutsummaryrefslogtreecommitdiff
path: root/accessibility/dasher
diff options
context:
space:
mode:
Diffstat (limited to 'accessibility/dasher')
-rw-r--r--accessibility/dasher/Makefile21
-rw-r--r--accessibility/dasher/distinfo6
-rw-r--r--accessibility/dasher/files/patch-Src_DasherCore_BasicLog.cpp11
-rw-r--r--accessibility/dasher/files/patch-Src_DasherCore_FileLogger.cpp11
-rw-r--r--accessibility/dasher/files/patch-Src_DasherCore_SimpleTimer.cpp24
-rw-r--r--accessibility/dasher/files/patch-Src_DasherCore_TimeSpan.cpp20
-rw-r--r--accessibility/dasher/files/patch-Src_DasherCore_UserLog.cpp20
-rw-r--r--accessibility/dasher/pkg-plist409
8 files changed, 238 insertions, 284 deletions
diff --git a/accessibility/dasher/Makefile b/accessibility/dasher/Makefile
index 0d99cba434e4..23f7fdc45427 100644
--- a/accessibility/dasher/Makefile
+++ b/accessibility/dasher/Makefile
@@ -3,11 +3,11 @@
# Whom: lewiz <purple@lewiz.net>
#
# $FreeBSD$
-# $MCom: ports/accessibility/dasher/Makefile,v 1.50 2007/03/12 20:16:34 mezz Exp $
+# $MCom: ports/accessibility/dasher/Makefile,v 1.59 2007/10/15 22:05:41 mezz Exp $
#
PORTNAME= dasher
-PORTVERSION= 4.4.2
+PORTVERSION= 4.6.1
PORTEPOCH= 1
CATEGORIES= accessibility editors x11 gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
@@ -17,8 +17,8 @@ DIST_SUBDIR= gnome2
MAINTAINER= lewiz@compsoc.man.ac.uk
COMMENT= Information efficient text-entry interface
-BUILD_DEPENDS= scrollkeeper-config:${PORTSDIR}/textproc/scrollkeeper
-RUN_DEPENDS= scrollkeeper-config:${PORTSDIR}/textproc/scrollkeeper
+BUILD_DEPENDS= rarian-sk-config:${PORTSDIR}/textproc/rarian
+RUN_DEPENDS= rarian-sk-config:${PORTSDIR}/textproc/rarian
USE_BZIP2= yes
USE_GETTEXT= yes
@@ -39,14 +39,19 @@ MAN1= dasher.1
.include <bsd.port.pre.mk>
-.if ${HAVE_GNOME:Mgnomespeech}!=""
-USE_GNOME+= gnomespeech
-CONFIGURE_ARGS+=--enable-speech
-.endif
+#.if ${HAVE_GNOME:Mgnomespeech}!=""
+#USE_GNOME+= gnomespeech
+#CONFIGURE_ARGS+=--enable-speech
+#.endif
+CONFIGURE_ARGS+= --disable-speech
post-patch:
@${REINPLACE_CMD} -e 's|-O2||g' ${WRKSRC}/configure
@${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} -e \
's|-O2||g'
+.if ${OSVERSION} >= 700042
+ @${REINPLACE_CMD} -e 's|__gnu_cxx::lldiv|lldiv|' \
+ ${WRKSRC}/Src/DasherCore/DasherViewSquare.cpp
+.endif
.include <bsd.port.post.mk>
diff --git a/accessibility/dasher/distinfo b/accessibility/dasher/distinfo
index fb160165d4fd..98ee68b55eb7 100644
--- a/accessibility/dasher/distinfo
+++ b/accessibility/dasher/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnome2/dasher-4.4.2.tar.bz2) = ca50a357d5043e4e5f114ecda7cd1c73
-SHA256 (gnome2/dasher-4.4.2.tar.bz2) = 0ee0d5e7f867bd21f0ab13dcd72dd2dd7eb6bb0d7918c18971ece81d3c2a76ed
-SIZE (gnome2/dasher-4.4.2.tar.bz2) = 6880246
+MD5 (gnome2/dasher-4.6.1.tar.bz2) = 1457df5075477d757f7df5693947464d
+SHA256 (gnome2/dasher-4.6.1.tar.bz2) = 3f0ee0a37465f5262937e8d2746bf7710cc6505e704e80c318dc3e01806aebc8
+SIZE (gnome2/dasher-4.6.1.tar.bz2) = 6473483
diff --git a/accessibility/dasher/files/patch-Src_DasherCore_BasicLog.cpp b/accessibility/dasher/files/patch-Src_DasherCore_BasicLog.cpp
deleted file mode 100644
index baf470649d47..000000000000
--- a/accessibility/dasher/files/patch-Src_DasherCore_BasicLog.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- Src/DasherCore/BasicLog.cpp.orig Tue Dec 5 22:01:38 2006
-+++ Src/DasherCore/BasicLog.cpp Tue Dec 5 22:02:14 2006
-@@ -87,7 +87,7 @@ std::string CBasicLog::GetDateStamp() {
- szTimeLine = ctime(&(sTimeBuffer.time));
- #else
- gettimeofday(&sTimeBuffer, &sTimezoneBuffer);
-- szTimeLine = ctime(&(sTimeBuffer.tv_sec));
-+ szTimeLine = ctime((const time_t *)&(sTimeBuffer.tv_sec));
- #endif
-
- return std::string(szTimeLine).substr(0, 24);
diff --git a/accessibility/dasher/files/patch-Src_DasherCore_FileLogger.cpp b/accessibility/dasher/files/patch-Src_DasherCore_FileLogger.cpp
deleted file mode 100644
index ec71875602fd..000000000000
--- a/accessibility/dasher/files/patch-Src_DasherCore_FileLogger.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- Src/DasherCore/FileLogger.cpp.orig Sun Dec 3 09:50:34 2006
-+++ Src/DasherCore/FileLogger.cpp Sun Dec 3 18:45:55 2006
-@@ -511,7 +511,7 @@ std::string CFileLogger::GetTimeDateStam
- szTimeLine = ctime(&(sTimeBuffer.time));
- #else
- gettimeofday(&sTimeBuffer, &sTimezoneBuffer);
-- szTimeLine = ctime(&(sTimeBuffer.tv_sec));
-+ szTimeLine = ctime((const time_t *)&(sTimeBuffer.tv_sec));
- #endif
-
- // Format is:
diff --git a/accessibility/dasher/files/patch-Src_DasherCore_SimpleTimer.cpp b/accessibility/dasher/files/patch-Src_DasherCore_SimpleTimer.cpp
deleted file mode 100644
index 745c41f85a5e..000000000000
--- a/accessibility/dasher/files/patch-Src_DasherCore_SimpleTimer.cpp
+++ /dev/null
@@ -1,24 +0,0 @@
---- Src/DasherCore/SimpleTimer.cpp.orig Wed May 31 00:14:12 2006
-+++ Src/DasherCore/SimpleTimer.cpp Wed May 31 00:14:23 2006
-@@ -34,8 +34,8 @@ CSimpleTimer::CSimpleTimer()
- m_iStartSecond = sTimeBuffer.time;
- #else
- gettimeofday(&sTimeBuffer, &sTimezoneBuffer);
-- m_iStartMs = sTimeBuffer.tv_usec / 1000;
-- m_iStartSecond = sTimeBuffer.tv_sec;
-+ m_iStartMs = (int) sTimeBuffer.tv_usec / 1000;
-+ m_iStartSecond = (int) sTimeBuffer.tv_sec;
- #endif
-
- }
-@@ -59,8 +59,8 @@ double CSimpleTimer::GetElapsed()
- int iEndSecond = sTimeBuffer.time;
- #else
- gettimeofday(&sTimeBuffer, &sTimezoneBuffer);
-- int iEndMs = sTimeBuffer.tv_usec / 1000;
-- int iEndSecond = sTimeBuffer.tv_sec;
-+ int iEndMs = (int) sTimeBuffer.tv_usec / 1000;
-+ int iEndSecond = (int) sTimeBuffer.tv_sec;
- #endif
-
-
diff --git a/accessibility/dasher/files/patch-Src_DasherCore_TimeSpan.cpp b/accessibility/dasher/files/patch-Src_DasherCore_TimeSpan.cpp
deleted file mode 100644
index c10219ff4f4f..000000000000
--- a/accessibility/dasher/files/patch-Src_DasherCore_TimeSpan.cpp
+++ /dev/null
@@ -1,20 +0,0 @@
---- Src/DasherCore/TimeSpan.cpp.orig Sun Dec 3 09:50:34 2006
-+++ Src/DasherCore/TimeSpan.cpp Sun Dec 3 18:47:02 2006
-@@ -122,7 +122,7 @@ string CTimeSpan::GetTimeStamp()
- szTimeLine = ctime(&(sTimeBuffer.time));
- #else
- gettimeofday(&sTimeBuffer, &sTimezoneBuffer);
-- szTimeLine = ctime(&(sTimeBuffer.tv_sec));
-+ szTimeLine = ctime((const time_t *)&(sTimeBuffer.tv_sec));
- #endif
-
- if ((szTimeLine != NULL) && (strlen(szTimeLine) > 18))
-@@ -196,7 +196,7 @@ string CTimeSpan::GetDateStamp()
- szTimeLine = ctime(&(sTimeBuffer.time));
- #else
- gettimeofday(&sTimeBuffer, &sTimezoneBuffer);
-- szTimeLine = ctime(&(sTimeBuffer.tv_sec));
-+ szTimeLine = ctime((const time_t *)&(sTimeBuffer.tv_sec));
- #endif
-
-
diff --git a/accessibility/dasher/files/patch-Src_DasherCore_UserLog.cpp b/accessibility/dasher/files/patch-Src_DasherCore_UserLog.cpp
deleted file mode 100644
index 663e5426ef34..000000000000
--- a/accessibility/dasher/files/patch-Src_DasherCore_UserLog.cpp
+++ /dev/null
@@ -1,20 +0,0 @@
---- Src/DasherCore/UserLog.cpp.orig Fri Apr 21 17:41:02 2006
-+++ Src/DasherCore/UserLog.cpp Sun Jun 11 10:43:33 2006
-@@ -668,7 +668,7 @@
- szTimeLine = ctime(&(sTimeBuffer.time));
- #else
- gettimeofday(&sTimeBuffer, &sTimezoneBuffer);
-- szTimeLine = ctime(&(sTimeBuffer.tv_sec));
-+ szTimeLine = ctime((const time_t *)&(sTimeBuffer.tv_sec));
- #endif
-
- if ((szTimeLine != NULL) && (strlen(szTimeLine) > 18))
-@@ -881,7 +881,7 @@
- double dTime = (sTimeBuffer.time * 1000.0) + sTimeBuffer.millitm;
- #else
- gettimeofday(&sTimeBuffer, &sTimezoneBuffer);
-- double dTime = (sTimeBuffer.tv_sec * 1000.0) + sTimeBuffer.tv_usec / 1000;
-+ double dTime = (sTimeBuffer.tv_sec * 1000.0) + (int) (sTimeBuffer.tv_usec / 1000);
- #endif
-
-
diff --git a/accessibility/dasher/pkg-plist b/accessibility/dasher/pkg-plist
index ef7a17014da2..6e65094162d8 100644
--- a/accessibility/dasher/pkg-plist
+++ b/accessibility/dasher/pkg-plist
@@ -1,185 +1,188 @@
bin/dasher
-share/gnome/applications/dasher.desktop
-share/gnome/dasher/alphabet.AfaanOromo.xml
-share/gnome/dasher/alphabet.Armenian.xml
-share/gnome/dasher/alphabet.Assamese.xml
-share/gnome/dasher/alphabet.Azerbaijani.xml
-share/gnome/dasher/alphabet.Belarusian.xml
-share/gnome/dasher/alphabet.Bulgarian.xml
-share/gnome/dasher/alphabet.Esperanto.xml
-share/gnome/dasher/alphabet.Estonian.xml
-share/gnome/dasher/alphabet.Filipino.xml
-share/gnome/dasher/alphabet.Greek.xml
-share/gnome/dasher/alphabet.Gujarati.xml
-share/gnome/dasher/alphabet.Hawaiian.xml
-share/gnome/dasher/alphabet.Hebrew.xml
-share/gnome/dasher/alphabet.Hindi.xml
-share/gnome/dasher/alphabet.Icelandic.xml
-share/gnome/dasher/alphabet.Igbo.xml
-share/gnome/dasher/alphabet.Indonesian.xml
-share/gnome/dasher/alphabet.IrishGaelic.xml
-share/gnome/dasher/alphabet.Kannada.xml
-share/gnome/dasher/alphabet.Katakana.xml
-share/gnome/dasher/alphabet.Malay.xml
-share/gnome/dasher/alphabet.Malayalam.xml
-share/gnome/dasher/alphabet.Marathi.xml
-share/gnome/dasher/alphabet.Moldavian.xml
-share/gnome/dasher/alphabet.Ndebele.xml
-share/gnome/dasher/alphabet.Oriya.xml
-share/gnome/dasher/alphabet.Punjabi.xml
-share/gnome/dasher/alphabet.Romanian.xml
-share/gnome/dasher/alphabet.Sami.xml
-share/gnome/dasher/alphabet.ScotsGaelic.xml
-share/gnome/dasher/alphabet.Sepedi.xml
-share/gnome/dasher/alphabet.Sesotho.xml
-share/gnome/dasher/alphabet.Sinhala.xml
-share/gnome/dasher/alphabet.Slovak.xml
-share/gnome/dasher/alphabet.Slovenian.xml
-share/gnome/dasher/alphabet.Swati.xml
-share/gnome/dasher/alphabet.Tajik.xml
-share/gnome/dasher/alphabet.Tamil.xml
-share/gnome/dasher/alphabet.Telugu.xml
-share/gnome/dasher/alphabet.Thai.xml
-share/gnome/dasher/alphabet.Thai2.xml
-share/gnome/dasher/alphabet.Tsonga.xml
-share/gnome/dasher/alphabet.Tswana.xml
-share/gnome/dasher/alphabet.Turkish.xml
-share/gnome/dasher/alphabet.Urdu.xml
-share/gnome/dasher/alphabet.Vietnamese.xml
-share/gnome/dasher/alphabet.Xhosa.xml
-share/gnome/dasher/alphabet.Yoruba.xml
-share/gnome/dasher/alphabet.Zulu.xml
-share/gnome/dasher/alphabet.abc.xml
-share/gnome/dasher/alphabet.adangbe.xml
-share/gnome/dasher/alphabet.afrikaans.xml
-share/gnome/dasher/alphabet.akan.xml
-share/gnome/dasher/alphabet.albanian.xml
-share/gnome/dasher/alphabet.amharic.xml
-share/gnome/dasher/alphabet.arabic.xml
-share/gnome/dasher/alphabet.basque.xml
-share/gnome/dasher/alphabet.bengali.xml
-share/gnome/dasher/alphabet.bopomofo.xml
-share/gnome/dasher/alphabet.bosnian.xml
-share/gnome/dasher/alphabet.breton.xml
-share/gnome/dasher/alphabet.catalan.xml
-share/gnome/dasher/alphabet.cherokee.xml
-share/gnome/dasher/alphabet.chinese.xml
-share/gnome/dasher/alphabet.chineseRuby.xml
-share/gnome/dasher/alphabet.corsican.xml
-share/gnome/dasher/alphabet.croatian.xml
-share/gnome/dasher/alphabet.czech.xml
-share/gnome/dasher/alphabet.danish.xml
-share/gnome/dasher/alphabet.dtd
-share/gnome/dasher/alphabet.dutch.xml
-share/gnome/dasher/alphabet.english.xml
-share/gnome/dasher/alphabet.englishC.xml
-share/gnome/dasher/alphabet.ethiopic.xml
-share/gnome/dasher/alphabet.ewe.xml
-share/gnome/dasher/alphabet.faroese.xml
-share/gnome/dasher/alphabet.finnish.xml
-share/gnome/dasher/alphabet.finnish2.xml
-share/gnome/dasher/alphabet.french.xml
-share/gnome/dasher/alphabet.ga.xml
-share/gnome/dasher/alphabet.galician.xml
-share/gnome/dasher/alphabet.georgian.xml
-share/gnome/dasher/alphabet.german.xml
-share/gnome/dasher/alphabet.hausa.xml
-share/gnome/dasher/alphabet.hiragana.xml
-share/gnome/dasher/alphabet.hiragana2.xml
-share/gnome/dasher/alphabet.hungarian.xml
-share/gnome/dasher/alphabet.ipa.xml
-share/gnome/dasher/alphabet.italian.xml
-share/gnome/dasher/alphabet.japanese.canna.xml
-share/gnome/dasher/alphabet.kazakh.xml
-share/gnome/dasher/alphabet.kirghiz.xml
-share/gnome/dasher/alphabet.kirundi.xml
-share/gnome/dasher/alphabet.klingon.xml
-share/gnome/dasher/alphabet.korean.xml
-share/gnome/dasher/alphabet.koreanNested.xml
-share/gnome/dasher/alphabet.kurdish.xml
-share/gnome/dasher/alphabet.lao.xml
-share/gnome/dasher/alphabet.latex.xml
-share/gnome/dasher/alphabet.latin.xml
-share/gnome/dasher/alphabet.latvian.xml
-share/gnome/dasher/alphabet.lithuanian.xml
-share/gnome/dasher/alphabet.luxembourgish.xml
-share/gnome/dasher/alphabet.macedonian.xml
-share/gnome/dasher/alphabet.malagasy.xml
-share/gnome/dasher/alphabet.maltese.xml
-share/gnome/dasher/alphabet.mongolian.xml
-share/gnome/dasher/alphabet.myanmar.xml
-share/gnome/dasher/alphabet.nepali.xml
-share/gnome/dasher/alphabet.norwegian.xml
-share/gnome/dasher/alphabet.occitan.xml
-share/gnome/dasher/alphabet.ogham.xml
-share/gnome/dasher/alphabet.pashto.xml
-share/gnome/dasher/alphabet.persian.xml
-share/gnome/dasher/alphabet.pinyin.xml
-share/gnome/dasher/alphabet.polish.xml
-share/gnome/dasher/alphabet.portuguese.xml
-share/gnome/dasher/alphabet.romansch.xml
-share/gnome/dasher/alphabet.runic.xml
-share/gnome/dasher/alphabet.russian.xml
-share/gnome/dasher/alphabet.sanskrit.xml
-share/gnome/dasher/alphabet.serbian.xml
-share/gnome/dasher/alphabet.somali.xml
-share/gnome/dasher/alphabet.spanish.xml
-share/gnome/dasher/alphabet.swahili.xml
-share/gnome/dasher/alphabet.swedish.xml
-share/gnome/dasher/alphabet.thaana.xml
-share/gnome/dasher/alphabet.tigrinya.xml
-share/gnome/dasher/alphabet.turkmen.xml
-share/gnome/dasher/alphabet.ukrainian.xml
-share/gnome/dasher/alphabet.uzbek.xml
-share/gnome/dasher/alphabet.venda.xml
-share/gnome/dasher/alphabet.welsh.xml
-share/gnome/dasher/alphabet.xsl
-share/gnome/dasher/colour.blue.xml
-share/gnome/dasher/colour.dtd
-share/gnome/dasher/colour.euroasian.xml
-share/gnome/dasher/colour.euroasian2.xml
-share/gnome/dasher/colour.euroasian3.xml
-share/gnome/dasher/colour.jamie.xml
-share/gnome/dasher/colour.rainbow.xml
-share/gnome/dasher/colour.thai.xml
-share/gnome/dasher/colour.vowels.xml
-share/gnome/dasher/colour.vowels2.xml
-share/gnome/dasher/colour.xml
-share/gnome/dasher/controllabels.dtd
-share/gnome/dasher/controllabels.xml
-share/gnome/dasher/dasher.compose.glade
-share/gnome/dasher/dasher.direct.glade
-share/gnome/dasher/dasher.fullscreen.glade
-share/gnome/dasher/dasher.traditional.glade
-share/gnome/dasher/dashermaemo.glade
-share/gnome/dasher/dashermaemofullscreen.glade
-share/gnome/dasher/training_albanian_SQ.txt
-share/gnome/dasher/training_basque_EU.txt
-share/gnome/dasher/training_bengali_BD.txt
-share/gnome/dasher/training_canna_JP.txt
-share/gnome/dasher/training_czech_CS.txt
-share/gnome/dasher/training_danish_DK.txt
-share/gnome/dasher/training_dutch_NL.txt
-share/gnome/dasher/training_english_GB.txt
-share/gnome/dasher/training_finnish_FI.txt
-share/gnome/dasher/training_french_FR.txt
-share/gnome/dasher/training_german_DE.txt
-share/gnome/dasher/training_greek_GR.txt
-share/gnome/dasher/training_hebrew_IL.txt
-share/gnome/dasher/training_hiragana60_JP.txt
-share/gnome/dasher/training_hiragana83_JP.txt
-share/gnome/dasher/training_hungarian_HU.txt
-share/gnome/dasher/training_italian_IT.txt
-share/gnome/dasher/training_mongolian_MN.txt
-share/gnome/dasher/training_persian_IR.txt
-share/gnome/dasher/training_polish_PL.txt
-share/gnome/dasher/training_portuguese_BR.txt
-share/gnome/dasher/training_russian_RU.txt
-share/gnome/dasher/training_spanish_ES.txt
-share/gnome/dasher/training_swahili_KE.txt
-share/gnome/dasher/training_swedish_SE.txt
-share/gnome/dasher/training_turkish_TR.txt
-share/gnome/dasher/training_welsh_GB.txt
+share/applications/dasher.desktop
+%%DATADIR%%/alphabet.AfaanOromo.xml
+%%DATADIR%%/alphabet.Armenian.xml
+%%DATADIR%%/alphabet.Assamese.xml
+%%DATADIR%%/alphabet.Austen.xml
+%%DATADIR%%/alphabet.Azerbaijani.xml
+%%DATADIR%%/alphabet.Belarusian.xml
+%%DATADIR%%/alphabet.Bulgarian.xml
+%%DATADIR%%/alphabet.Esperanto.xml
+%%DATADIR%%/alphabet.Estonian.xml
+%%DATADIR%%/alphabet.Filipino.xml
+%%DATADIR%%/alphabet.Greek.xml
+%%DATADIR%%/alphabet.Gujarati.xml
+%%DATADIR%%/alphabet.Hawaiian.xml
+%%DATADIR%%/alphabet.Hebrew.xml
+%%DATADIR%%/alphabet.Hindi.xml
+%%DATADIR%%/alphabet.Icelandic.xml
+%%DATADIR%%/alphabet.Igbo.xml
+%%DATADIR%%/alphabet.Indonesian.xml
+%%DATADIR%%/alphabet.IrishGaelic.xml
+%%DATADIR%%/alphabet.Kannada.xml
+%%DATADIR%%/alphabet.Katakana.xml
+%%DATADIR%%/alphabet.Malay.xml
+%%DATADIR%%/alphabet.Malayalam.xml
+%%DATADIR%%/alphabet.Marathi.xml
+%%DATADIR%%/alphabet.Moldavian.xml
+%%DATADIR%%/alphabet.Ndebele.xml
+%%DATADIR%%/alphabet.Oriya.xml
+%%DATADIR%%/alphabet.Punjabi.xml
+%%DATADIR%%/alphabet.Romanian.xml
+%%DATADIR%%/alphabet.Sami.xml
+%%DATADIR%%/alphabet.ScotsGaelic.xml
+%%DATADIR%%/alphabet.Sepedi.xml
+%%DATADIR%%/alphabet.Sesotho.xml
+%%DATADIR%%/alphabet.Sinhala.xml
+%%DATADIR%%/alphabet.Slovak.xml
+%%DATADIR%%/alphabet.Slovenian.xml
+%%DATADIR%%/alphabet.Swati.xml
+%%DATADIR%%/alphabet.Tajik.xml
+%%DATADIR%%/alphabet.Tamil.xml
+%%DATADIR%%/alphabet.Telugu.xml
+%%DATADIR%%/alphabet.Thai.xml
+%%DATADIR%%/alphabet.Thai2.xml
+%%DATADIR%%/alphabet.Tsonga.xml
+%%DATADIR%%/alphabet.Tswana.xml
+%%DATADIR%%/alphabet.Turkish.xml
+%%DATADIR%%/alphabet.Urdu.xml
+%%DATADIR%%/alphabet.Vietnamese.xml
+%%DATADIR%%/alphabet.Xhosa.xml
+%%DATADIR%%/alphabet.Yoruba.xml
+%%DATADIR%%/alphabet.Zulu.xml
+%%DATADIR%%/alphabet.abc.xml
+%%DATADIR%%/alphabet.adangbe.xml
+%%DATADIR%%/alphabet.afrikaans.xml
+%%DATADIR%%/alphabet.akan.xml
+%%DATADIR%%/alphabet.albanian.xml
+%%DATADIR%%/alphabet.amharic.xml
+%%DATADIR%%/alphabet.arabic.xml
+%%DATADIR%%/alphabet.basque.xml
+%%DATADIR%%/alphabet.bengali.xml
+%%DATADIR%%/alphabet.bopomofo.xml
+%%DATADIR%%/alphabet.bosnian.xml
+%%DATADIR%%/alphabet.breton.xml
+%%DATADIR%%/alphabet.catalan.xml
+%%DATADIR%%/alphabet.cherokee.xml
+%%DATADIR%%/alphabet.chinese.xml
+%%DATADIR%%/alphabet.chineseRuby.xml
+%%DATADIR%%/alphabet.corsican.xml
+%%DATADIR%%/alphabet.croatian.xml
+%%DATADIR%%/alphabet.czech.xml
+%%DATADIR%%/alphabet.danish.xml
+%%DATADIR%%/alphabet.dtd
+%%DATADIR%%/alphabet.dutch.xml
+%%DATADIR%%/alphabet.english.xml
+%%DATADIR%%/alphabet.englishC.xml
+%%DATADIR%%/alphabet.ethiopic.xml
+%%DATADIR%%/alphabet.ewe.xml
+%%DATADIR%%/alphabet.faroese.xml
+%%DATADIR%%/alphabet.finnish.xml
+%%DATADIR%%/alphabet.finnish2.xml
+%%DATADIR%%/alphabet.french.xml
+%%DATADIR%%/alphabet.ga.xml
+%%DATADIR%%/alphabet.galician.xml
+%%DATADIR%%/alphabet.georgian.xml
+%%DATADIR%%/alphabet.german.xml
+%%DATADIR%%/alphabet.hausa.xml
+%%DATADIR%%/alphabet.hiragana.xml
+%%DATADIR%%/alphabet.hiragana2.xml
+%%DATADIR%%/alphabet.hungarian.xml
+%%DATADIR%%/alphabet.ipa.xml
+%%DATADIR%%/alphabet.italian.xml
+%%DATADIR%%/alphabet.japanese.canna.xml
+%%DATADIR%%/alphabet.kazakh.xml
+%%DATADIR%%/alphabet.kirghiz.xml
+%%DATADIR%%/alphabet.kirundi.xml
+%%DATADIR%%/alphabet.klingon.xml
+%%DATADIR%%/alphabet.korean.xml
+%%DATADIR%%/alphabet.koreanNested.xml
+%%DATADIR%%/alphabet.kurdish.xml
+%%DATADIR%%/alphabet.lao.xml
+%%DATADIR%%/alphabet.latex.xml
+%%DATADIR%%/alphabet.latin.xml
+%%DATADIR%%/alphabet.latvian.xml
+%%DATADIR%%/alphabet.lithuanian.xml
+%%DATADIR%%/alphabet.luxembourgish.xml
+%%DATADIR%%/alphabet.macedonian.xml
+%%DATADIR%%/alphabet.maltese.xml
+%%DATADIR%%/alphabet.mongolian.xml
+%%DATADIR%%/alphabet.myanmar.xml
+%%DATADIR%%/alphabet.nepali.xml
+%%DATADIR%%/alphabet.norwegian.xml
+%%DATADIR%%/alphabet.occitan.xml
+%%DATADIR%%/alphabet.ogham.xml
+%%DATADIR%%/alphabet.pashto.xml
+%%DATADIR%%/alphabet.perl.xml
+%%DATADIR%%/alphabet.persian.xml
+%%DATADIR%%/alphabet.pinyin.xml
+%%DATADIR%%/alphabet.pinyin2.xml
+%%DATADIR%%/alphabet.polish.xml
+%%DATADIR%%/alphabet.portuguese.xml
+%%DATADIR%%/alphabet.romansch.xml
+%%DATADIR%%/alphabet.runic.xml
+%%DATADIR%%/alphabet.russian.xml
+%%DATADIR%%/alphabet.sanskrit.xml
+%%DATADIR%%/alphabet.serbian.xml
+%%DATADIR%%/alphabet.somali.xml
+%%DATADIR%%/alphabet.spanish.xml
+%%DATADIR%%/alphabet.swahili.xml
+%%DATADIR%%/alphabet.swedish.xml
+%%DATADIR%%/alphabet.thaana.xml
+%%DATADIR%%/alphabet.tigrinya.xml
+%%DATADIR%%/alphabet.turkmen.xml
+%%DATADIR%%/alphabet.ukrainian.xml
+%%DATADIR%%/alphabet.uzbek.xml
+%%DATADIR%%/alphabet.venda.xml
+%%DATADIR%%/alphabet.welsh.xml
+%%DATADIR%%/alphabet.xsl
+%%DATADIR%%/colour.blue.xml
+%%DATADIR%%/colour.dtd
+%%DATADIR%%/colour.euroasian.xml
+%%DATADIR%%/colour.euroasian2.xml
+%%DATADIR%%/colour.euroasian3.xml
+%%DATADIR%%/colour.jamie.xml
+%%DATADIR%%/colour.rainbow.xml
+%%DATADIR%%/colour.thai.xml
+%%DATADIR%%/colour.vowels.xml
+%%DATADIR%%/colour.vowels2.xml
+%%DATADIR%%/colour.xml
+%%DATADIR%%/controllabels.dtd
+%%DATADIR%%/controllabels.xml
+%%DATADIR%%/dasher.compose.glade
+%%DATADIR%%/dasher.direct.glade
+%%DATADIR%%/dasher.fullscreen.glade
+%%DATADIR%%/dasher.traditional.glade
+%%DATADIR%%/dashermaemo.glade
+%%DATADIR%%/dashermaemofullscreen.glade
+%%DATADIR%%/training_albanian_SQ.txt
+%%DATADIR%%/training_basque_EU.txt
+%%DATADIR%%/training_bengali_BD.txt
+%%DATADIR%%/training_bengali_bn.txt
+%%DATADIR%%/training_canna_JP.txt
+%%DATADIR%%/training_czech_CS.txt
+%%DATADIR%%/training_danish_DK.txt
+%%DATADIR%%/training_dutch_NL.txt
+%%DATADIR%%/training_english_GB.txt
+%%DATADIR%%/training_finnish_FI.txt
+%%DATADIR%%/training_french_FR.txt
+%%DATADIR%%/training_german_DE.txt
+%%DATADIR%%/training_greek_GR.txt
+%%DATADIR%%/training_hebrew_IL.txt
+%%DATADIR%%/training_hiragana60_JP.txt
+%%DATADIR%%/training_hiragana83_JP.txt
+%%DATADIR%%/training_hungarian_HU.txt
+%%DATADIR%%/training_italian_IT.txt
+%%DATADIR%%/training_mongolian_MN.txt
+%%DATADIR%%/training_persian_IR.txt
+%%DATADIR%%/training_polish_PL.txt
+%%DATADIR%%/training_portuguese_BR.txt
+%%DATADIR%%/training_russian_RU.txt
+%%DATADIR%%/training_spanish_ES.txt
+%%DATADIR%%/training_swahili_KE.txt
+%%DATADIR%%/training_swedish_SE.txt
+%%DATADIR%%/training_turkish_TR.txt
+%%DATADIR%%/training_welsh_GB.txt
share/gnome/help/dasher/C/dasher.xml
share/gnome/help/dasher/C/figures/a-z.gif
share/gnome/help/dasher/C/figures/aa-az.gif
@@ -228,6 +231,22 @@ share/gnome/help/dasher/fr/figures/prefs2.png
share/gnome/help/dasher/fr/figures/prefs3.png
share/gnome/help/dasher/fr/figures/prefs4.png
share/gnome/help/dasher/fr/figures/prefs5.png
+share/gnome/help/dasher/ru/dasher.xml
+share/gnome/help/dasher/ru/figures/a-z.gif
+share/gnome/help/dasher/ru/figures/aa-az.gif
+share/gnome/help/dasher/ru/figures/ala-alz.gif
+share/gnome/help/dasher/ru/figures/exampleHad2.png
+share/gnome/help/dasher/ru/figures/exampleHad2a.png
+share/gnome/help/dasher/ru/figures/exampleHad3a.png
+share/gnome/help/dasher/ru/figures/exampleHad4.png
+share/gnome/help/dasher/ru/figures/figure2.png
+share/gnome/help/dasher/ru/figures/main.png
+share/gnome/help/dasher/ru/figures/object.gif
+share/gnome/help/dasher/ru/figures/prefs1.png
+share/gnome/help/dasher/ru/figures/prefs2.png
+share/gnome/help/dasher/ru/figures/prefs3.png
+share/gnome/help/dasher/ru/figures/prefs4.png
+share/gnome/help/dasher/ru/figures/prefs5.png
share/gnome/help/dasher/sv/dasher.xml
share/gnome/help/dasher/sv/figures/a-z.gif
share/gnome/help/dasher/sv/figures/aa-az.gif
@@ -244,15 +263,12 @@ share/gnome/help/dasher/sv/figures/prefs2.png
share/gnome/help/dasher/sv/figures/prefs3.png
share/gnome/help/dasher/sv/figures/prefs4.png
share/gnome/help/dasher/sv/figures/prefs5.png
-share/gnome/omf/dasher/dasher-C.omf
-share/gnome/omf/dasher/dasher-es.omf
-share/gnome/omf/dasher/dasher-fr.omf
-share/gnome/omf/dasher/dasher-sv.omf
share/icons/hicolor/48x48/apps/dasher.png
share/icons/hicolor/scalable/apps/dasher.svg
share/locale/ar/LC_MESSAGES/dasher.mo
share/locale/az/LC_MESSAGES/dasher.mo
share/locale/be/LC_MESSAGES/dasher.mo
+share/locale/be@latin/LC_MESSAGES/dasher.mo
share/locale/bg/LC_MESSAGES/dasher.mo
share/locale/bn/LC_MESSAGES/dasher.mo
share/locale/bn_IN/LC_MESSAGES/dasher.mo
@@ -298,6 +314,7 @@ share/locale/nb/LC_MESSAGES/dasher.mo
share/locale/ne/LC_MESSAGES/dasher.mo
share/locale/nl/LC_MESSAGES/dasher.mo
share/locale/nn/LC_MESSAGES/dasher.mo
+share/locale/oc/LC_MESSAGES/dasher.mo
share/locale/or/LC_MESSAGES/dasher.mo
share/locale/pa/LC_MESSAGES/dasher.mo
share/locale/pl/LC_MESSAGES/dasher.mo
@@ -306,6 +323,7 @@ share/locale/pt_BR/LC_MESSAGES/dasher.mo
share/locale/ro/LC_MESSAGES/dasher.mo
share/locale/ru/LC_MESSAGES/dasher.mo
share/locale/rw/LC_MESSAGES/dasher.mo
+share/locale/si/LC_MESSAGES/dasher.mo
share/locale/sk/LC_MESSAGES/dasher.mo
share/locale/sl/LC_MESSAGES/dasher.mo
share/locale/sq/LC_MESSAGES/dasher.mo
@@ -318,13 +336,21 @@ share/locale/tk/LC_MESSAGES/dasher.mo
share/locale/tr/LC_MESSAGES/dasher.mo
share/locale/ug/LC_MESSAGES/dasher.mo
share/locale/uk/LC_MESSAGES/dasher.mo
+share/locale/uz@cyrillic/LC_MESSAGES/dasher.mo
share/locale/vi/LC_MESSAGES/dasher.mo
share/locale/zh_CN/LC_MESSAGES/dasher.mo
share/locale/zh_HK/LC_MESSAGES/dasher.mo
share/locale/zh_TW/LC_MESSAGES/dasher.mo
-@dirrm share/gnome/omf/dasher
+share/omf/dasher/dasher-C.omf
+share/omf/dasher/dasher-es.omf
+share/omf/dasher/dasher-fr.omf
+share/omf/dasher/dasher-ru.omf
+share/omf/dasher/dasher-sv.omf
+@dirrm share/omf/dasher
@dirrm share/gnome/help/dasher/sv/figures
@dirrm share/gnome/help/dasher/sv
+@dirrm share/gnome/help/dasher/ru/figures
+@dirrm share/gnome/help/dasher/ru
@dirrm share/gnome/help/dasher/fr/figures
@dirrm share/gnome/help/dasher/fr
@dirrm share/gnome/help/dasher/es/figures
@@ -332,13 +358,19 @@ share/locale/zh_TW/LC_MESSAGES/dasher.mo
@dirrm share/gnome/help/dasher/C/figures
@dirrm share/gnome/help/dasher/C
@dirrm share/gnome/help/dasher
-@dirrm share/gnome/dasher
+@dirrm %%DATADIR%%
@dirrmtry share/locale/zh_HK/LC_MESSAGES
@dirrmtry share/locale/zh_HK
+@dirrmtry share/locale/uz@cyrillic/LC_MESSAGES
+@dirrmtry share/locale/uz@cyrillic
@dirrmtry share/locale/ug/LC_MESSAGES
@dirrmtry share/locale/ug
+@dirrmtry share/locale/si/LC_MESSAGES
+@dirrmtry share/locale/si
@dirrmtry share/locale/rw/LC_MESSAGES
@dirrmtry share/locale/rw
+@dirrmtry share/locale/oc/LC_MESSAGES
+@dirrmtry share/locale/oc
@dirrmtry share/locale/mr/LC_MESSAGES
@dirrmtry share/locale/mr
@dirrmtry share/locale/mg/LC_MESSAGES
@@ -351,3 +383,6 @@ share/locale/zh_TW/LC_MESSAGES/dasher.mo
@dirrmtry share/locale/dz
@dirrmtry share/locale/bn_IN/LC_MESSAGES
@dirrmtry share/locale/bn_IN
+@dirrmtry share/locale/be@latin/LC_MESSAGES
+@dirrmtry share/locale/be@latin
+@dirrmtry share/applications