aboutsummaryrefslogtreecommitdiff
path: root/accessibility/kmouth/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'accessibility/kmouth/Makefile')
-rw-r--r--accessibility/kmouth/Makefile46
1 files changed, 0 insertions, 46 deletions
diff --git a/accessibility/kmouth/Makefile b/accessibility/kmouth/Makefile
deleted file mode 100644
index 49e9d76d98fc..000000000000
--- a/accessibility/kmouth/Makefile
+++ /dev/null
@@ -1,46 +0,0 @@
-# New ports collection Makefile for: kdeaccessibility
-# Date created: 2008-01-31
-# Whom: Martin Wilke <miwi@FreeBSD.org>
-#
-# $FreeBSD$
-
-PORTNAME= kdeaccessibility
-PORTVERSION= ${KDE4_VERSION}
-CATEGORIES= accessibility kde
-MASTER_SITES= ${MASTER_SITE_KDE}
-MASTER_SITE_SUBDIR= ${KDE4_BRANCH}/${PORTVERSION}/src
-DIST_SUBDIR= KDE
-
-MAINTAINER= kde@FreeBSD.org
-COMMENT= Accessibility applications for KDE4
-
-BUILD_DEPENDS= ${LOCALBASE}/share/xml/docbook/4.2/docbookx.dtd:${PORTSDIR}/textproc/docbook-xml
-
-LATEST_LINK= ${PORTNAME}4
-
-USE_BZIP2= yes
-USE_KDE4= kdelibs kdeprefix kdehier automoc4
-KDE4_BUILDENV= yes
-USE_QT_VER= 4
-QT_COMPONENTS= opengl gui qmake_build moc_build rcc_build uic_build
-MAKE_JOBS_SAFE= yes
-
-MAN1= kmag.1 \
- kmousetool.1 \
- kmouth.1
-
-OPTIONS= KTTS "Enable KTTS speech service" off
-
-.include <bsd.port.options.mk>
-
-.if defined(WITH_KTTS)
-RUN_DEPENDS+= ${KDE4_PREFIX}/bin/jovie:${PORTSDIR}/accessibility/ktts
-.endif
-
-post-patch:
- ${REINPLACE_CMD} -e '/macro_optional_add_subdirectory.*jovie/d' \
- ${PATCH_WRKSRC}/CMakeLists.txt
- ${REINPLACE_CMD} -e '/add_subdirectory.*jovie/d' \
- ${PATCH_WRKSRC}/doc/CMakeLists.txt
-
-.include <bsd.port.mk>