aboutsummaryrefslogtreecommitdiff
path: root/archivers/dpkg
diff options
context:
space:
mode:
Diffstat (limited to 'archivers/dpkg')
-rw-r--r--archivers/dpkg/Makefile16
-rw-r--r--archivers/dpkg/files/patch-configure15
2 files changed, 5 insertions, 26 deletions
diff --git a/archivers/dpkg/Makefile b/archivers/dpkg/Makefile
index e3bb916d34e5..0e4a918c0cdc 100644
--- a/archivers/dpkg/Makefile
+++ b/archivers/dpkg/Makefile
@@ -3,6 +3,7 @@
PORTNAME= dpkg
PORTVERSION= 1.18.0
+PORTREVISION= 1
CATEGORIES= archivers sysutils
MASTER_SITES= DEBIAN_POOL
DISTNAME= dpkg_${PORTVERSION}
@@ -14,8 +15,7 @@ LICENSE= GPLv2
BUILD_DEPENDS= po4a:${PORTSDIR}/textproc/po4a
RUN_DEPENDS= gtar:${PORTSDIR}/archivers/gtar \
- gpatch:${PORTSDIR}/devel/patch \
- gmd5sum:${PORTSDIR}/sysutils/coreutils
+ gpatch:${PORTSDIR}/devel/patch
GNU_CONFIGURE= yes
USES= cpe gmake iconv libtool perl5 pkgconfig tar:xz
@@ -30,7 +30,7 @@ SUB_LIST+= DPKGDIR=${DPKGDIR}
CONFIGURE_ARGS+=--with-admindir=${DPKGDIR} --libdir=${PREFIX}/libexec \
--program-transform-name="" --with-libintl-prefix=${LOCALBASE} \
- --disable-compiler-warnings --with-logdir=/var/log
+ --with-logdir=/var/log
CONFIGURE_ENV+= PERL_LIBDIR="${PREFIX}/${SITE_PERL_REL}"
OPTIONS_DEFINE= NLS
@@ -40,14 +40,8 @@ NLS_CONFIGURE_ENABLE= nls
NLS_USES= gettext
post-patch:
- @${REINPLACE_CMD} 's|-t$$host|-t${ARCH}-freebsd|g' \
- ${WRKSRC}/configure
- @${REINPLACE_CMD} -E 's/(md5|sha1|sha256)sum/g&/g' \
- ${WRKSRC}/scripts/Dpkg/Checksums.pm
- @${REINPLACE_CMD} -e 's/cp -p $$(DEST/mv $$(DEST/g; s/rm $$(/rm -f $$(/g' \
- ${WRKSRC}/scripts/mk/Makefile.in \
- ${WRKSRC}/scripts/Makefile.in
- @${REINPLACE_CMD} 's/{^MATCH}/\&/' ${WRKSRC}/dselect/mkcurkeys.pl
+ @${REINPLACE_CMD} '/^LDFLAGS/ s|$$| -lmd|' \
+ ${WRKSRC}/lib/dpkg/Makefile.in
post-install:
(cd ${STAGEDIR}${DPKGDIR} && ${MKDIR} available diversions \
diff --git a/archivers/dpkg/files/patch-configure b/archivers/dpkg/files/patch-configure
deleted file mode 100644
index e4ab16a634ed..000000000000
--- a/archivers/dpkg/files/patch-configure
+++ /dev/null
@@ -1,15 +0,0 @@
---- configure.orig 2013-05-08 20:39:56.000000000 +0200
-+++ configure 2013-05-08 20:41:01.000000000 +0200
-@@ -8271,12 +8271,6 @@
- if test "$PERL" = "no" || test ! -x "$PERL"; then
- as_fn_error $? "cannot find the Perl interpreter" "$LINENO" 5
- fi
--# Let the user override the variable.
--if test -z "$PERL_LIBDIR"; then
--PERL_LIBDIR=$($PERL -MConfig -e 'my $r = $Config{vendorlibexp};
-- $r =~ s/$Config{vendorprefixexp}/\$(prefix)/;
-- print $r')
--fi
-
-
- for ac_prog in pod2man