aboutsummaryrefslogtreecommitdiff
path: root/archivers
diff options
context:
space:
mode:
Diffstat (limited to 'archivers')
-rw-r--r--archivers/deco/Makefile2
-rw-r--r--archivers/minizip/Makefile6
-rw-r--r--archivers/unmakeself/Makefile2
-rw-r--r--archivers/zipper/Makefile2
4 files changed, 6 insertions, 6 deletions
diff --git a/archivers/deco/Makefile b/archivers/deco/Makefile
index f39477639b3c..111d1a28de3c 100644
--- a/archivers/deco/Makefile
+++ b/archivers/deco/Makefile
@@ -41,7 +41,7 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/deco ${STAGEDIR}${PREFIX}/bin
@${MKDIR} ${STAGEDIR}${DATADIR}
.for i in LICENSE Makefile NEWS README config.mk
- ${RM} -rf ${WRKSRC}/../${PORTNAME}-archive-1.7/${i}
+ ${RM} -r ${WRKSRC}/../${PORTNAME}-archive-1.7/${i}
.endfor
@cd ${WRKDIR}/${PORTNAME}-archive-1.7/x/ && ${COPYTREE_SHARE} . ${STAGEDIR}${DATADIR}
@${FIND} ${STAGEDIR}${DATADIR} -type f -exec ${CHMOD} +x {} \;
diff --git a/archivers/minizip/Makefile b/archivers/minizip/Makefile
index 76678a4da93a..1072965194bd 100644
--- a/archivers/minizip/Makefile
+++ b/archivers/minizip/Makefile
@@ -27,12 +27,12 @@ post-install:
${INSTALL_MAN} ${WRKSRC}/*.1 ${STAGEDIR}${PREFIX}/man/man1
regression-test:
- ${RM} -rf ${WRKDIR}/regression-test1
+ ${RM} -r ${WRKDIR}/regression-test1
${MKDIR} ${WRKDIR}/regression-test1
${MV} ${WRKSRC}/*.[cho] ${WRKDIR}/regression-test1
- ${RM} -f ${WRKDIR}/test.zip
+ ${RM} ${WRKDIR}/test.zip
(cd ${WRKDIR}/regression-test1 && ${WRKSRC}/minizip ${WRKDIR}/test.zip *)
- ${RM} -rf ${WRKDIR}/regression-test2
+ ${RM} -r ${WRKDIR}/regression-test2
${MKDIR} ${WRKDIR}/regression-test2
${WRKSRC}/miniunzip ${WRKDIR}/test.zip -d ${WRKDIR}/regression-test2
${DIFF} -ur ${WRKDIR}/regression-test1 ${WRKDIR}/regression-test2 > /dev/null
diff --git a/archivers/unmakeself/Makefile b/archivers/unmakeself/Makefile
index f06ad9e72474..12896ccf949a 100644
--- a/archivers/unmakeself/Makefile
+++ b/archivers/unmakeself/Makefile
@@ -17,7 +17,7 @@ NO_WRKSUBDIR= yes
PLIST_FILES= bin/unmakeself
do-configure:
- @${RM} -f ${WRKSRC}/config.h
+ @${RM} ${WRKSRC}/config.h
@if ${GREP} -q memmem /usr/include/string.h; then \
${ECHO_CMD} "#define HAS_MEMMEM" > ${WRKSRC}/config.h; \
else \
diff --git a/archivers/zipper/Makefile b/archivers/zipper/Makefile
index 4b7b7bea22b4..f23c487f65e7 100644
--- a/archivers/zipper/Makefile
+++ b/archivers/zipper/Makefile
@@ -15,6 +15,6 @@ USES= gnustep
USE_GNUSTEP= back build
post-patch:
- cd ${WRKSRC} && ${FIND} . -name "*#*" -exec ${RM} -f -v "{}" ";"
+ cd ${WRKSRC} && ${FIND} . -name "*#*" -exec ${RM} -v "{}" ";"
.include <bsd.port.mk>