aboutsummaryrefslogtreecommitdiff
path: root/astro/celestia/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'astro/celestia/Makefile')
-rw-r--r--astro/celestia/Makefile11
1 files changed, 5 insertions, 6 deletions
diff --git a/astro/celestia/Makefile b/astro/celestia/Makefile
index 693cda07c1ce..0d726cc3f30b 100644
--- a/astro/celestia/Makefile
+++ b/astro/celestia/Makefile
@@ -7,10 +7,9 @@
PORTNAME= celestia
PORTVERSION= 1.4.1
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= astro
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= celestia
+MASTER_SITES= SF
PKGNAMESUFFIX= -${CELESTIA_UI}
MAINTAINER= jylefort@FreeBSD.org
@@ -21,14 +20,14 @@ LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
USE_AUTOTOOLS= libtool:15
USE_GMAKE= yes
-USE_GL= yes
+USE_GL= gl
USE_GETTEXT= yes
WANT_GNOME= yes
CONFIGURE_ARGS= --program-prefix=""
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
-CPPFLAGS= -I${X11BASE}/include -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
-LDFLAGS= -L${X11BASE}/lib -L${LOCALBASE}/lib -lm ${PTHREAD_LIBS}
+CPPFLAGS= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
+LDFLAGS= -L${LOCALBASE}/lib -lm ${PTHREAD_LIBS}
UI_LIST= glut gtk gnome
CELESTIA_UI?= glut