aboutsummaryrefslogtreecommitdiff
path: root/astro/stellarium/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'astro/stellarium/Makefile')
-rw-r--r--astro/stellarium/Makefile12
1 files changed, 10 insertions, 2 deletions
diff --git a/astro/stellarium/Makefile b/astro/stellarium/Makefile
index 45dce670ceae..4147c50787d5 100644
--- a/astro/stellarium/Makefile
+++ b/astro/stellarium/Makefile
@@ -42,7 +42,7 @@ PLIST_SUB+= MORE_STARS="@comment "
.if ${PORT_OPTIONS:MHR_TEXTURES}
MASTER_SITES+= SF/${PORTNAME}/textures:gfx
-DISTFILES+= textures-1K.zip:gfx milkyway.zip:gfx # yes, in this order
+DISTFILES+= textures-1K.zip:gfx
.endif
.if ${PORT_OPTIONS:MMULTIMEDIA}
@@ -60,7 +60,15 @@ post-install:
${STAGEDIR}${DATADIR}/stars/default
.endif
.if ${PORT_OPTIONS:MHR_TEXTURES}
- ${INSTALL_DATA} ${WRKDIR}/*.png ${STAGEDIR}${DATADIR}/textures
+ (cd ${WRKDIR} && for f in *.png; do \
+ new=`${STAT} -f '%z' $$f` ; \
+ existing=`${STAT} -f '%z' \
+ ${STAGEDIR}${DATADIR}/textures/$$f` ; \
+ ${TEST} $$new -gt $$existing && \
+ ${ECHO_CMD} "-- Replacing texture: $$f\
+ (has larger file size)" ; \
+ ${INSTALL_DATA} $$f ${STAGEDIR}${DATADIR}/textures ; \
+ done)
.endif
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}