aboutsummaryrefslogtreecommitdiff
path: root/audio/cmp3/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'audio/cmp3/Makefile')
-rw-r--r--audio/cmp3/Makefile16
1 files changed, 12 insertions, 4 deletions
diff --git a/audio/cmp3/Makefile b/audio/cmp3/Makefile
index 809edad3c476..a89820fd8644 100644
--- a/audio/cmp3/Makefile
+++ b/audio/cmp3/Makefile
@@ -6,10 +6,10 @@
#
PORTNAME= cmp3
-PORTVERSION= 2.0.p5
-PORTREVISION= 2
+PORTVERSION= 2.0.p6
CATEGORIES= audio
-MASTER_SITES= ${MASTER_SITE_NETBSD}
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
DISTNAME= ${PORTNAME}-${PORTVERSION:S/.p/pre/}
MAINTAINER= ports@FreeBSD.org
@@ -17,9 +17,17 @@ COMMENT= An ncurses based frontend to mpg123
RUN_DEPENDS= mpg123:${PORTSDIR}/audio/mpg123
-WRKSRC= ${WRKDIR}/${PORTNAME}
+WRKSRC= ${WRKDIR}/${PORTNAME}-kenrevs/
USE_GMAKE= yes
+GNU_CONFIGURE= yes
+
+PORTDOCS= README sample.cmp3rc
+PLIST_FILES= bin/cmp3 bin/rnmp3
+
+.if !defined(WITHOUT_VORBIS)
+RUN_DEPENDS+= ogg123:${PORTSDIR}/audio/vorbis-tools
+.endif
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/cmp3 ${PREFIX}/bin