aboutsummaryrefslogtreecommitdiff
path: root/audio/dumb/files/patch-Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'audio/dumb/files/patch-Makefile')
-rw-r--r--audio/dumb/files/patch-Makefile42
1 files changed, 38 insertions, 4 deletions
diff --git a/audio/dumb/files/patch-Makefile b/audio/dumb/files/patch-Makefile
index 4691d4dbf98d..623e96378a90 100644
--- a/audio/dumb/files/patch-Makefile
+++ b/audio/dumb/files/patch-Makefile
@@ -1,5 +1,5 @@
---- Makefile.orig Mon Aug 8 02:18:41 2005
-+++ Makefile Tue Aug 23 02:21:13 2005
+--- ./Makefile.orig Mon Aug 8 02:18:41 2005
++++ ./Makefile Sun Jun 10 12:13:59 2007
@@ -22,7 +22,7 @@
# (Note that this is unable to delete the dumbask
# executable if the configuration is absent.)
@@ -9,7 +9,42 @@
.PHONY: all install uninstall clean veryclean distclean config config-if-necessary make-outdirs
-@@ -231,10 +231,10 @@
+@@ -36,12 +36,12 @@
+ COMMA := ,
+
+ ifdef USE_ICC
+-CC := icc
++CC ?= icc
+ else
+ ifdef USE_SGICC
+-CC := cc
++CC ?= cc
+ else
+-CC := gcc
++CC ?= gcc
+ endif
+ endif
+ AR := ar
+@@ -215,24 +215,21 @@
+ ifdef USE_ICC
+ WFLAGS := -Wall -DDUMB_DECLARE_DEPRECATED
+ WFLAGS_ALLEGRO :=
+-OFLAGS := -O2
+-DBGFLAGS := -DDEBUGMODE=1
++OFLAGS=$(CFLAGS)
+ else
+ ifdef USE_SGICC
+ WFLAGS := -fullwarn -DDUMB_DECLARE_DEPRECATED
+ WFLAGS_ALLEGRO :=
+-OFLAGS := -n32 -O2 -use_readonly_const
+-DBGFLAGS := -n32 -g3 -DDEBUGMODE=1
++OFLAGS=$(CFLAGS)
+ else
+ WFLAGS := -Wall -W -Wwrite-strings -Wstrict-prototypes -Wmissing-declarations -DDUMB_DECLARE_DEPRECATED
+ WFLAGS_ALLEGRO := -Wno-missing-declarations
+-OFLAGS := -O2 -ffast-math -fomit-frame-pointer
+-DBGFLAGS := -DDEBUGMODE=1 -g3
++OFLAGS=$(CFLAGS)
endif
endif
@@ -20,4 +55,3 @@
LDFLAGS := -s
-