aboutsummaryrefslogtreecommitdiff
path: root/audio/faad/files/patch-configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'audio/faad/files/patch-configure.in')
-rw-r--r--audio/faad/files/patch-configure.in43
1 files changed, 43 insertions, 0 deletions
diff --git a/audio/faad/files/patch-configure.in b/audio/faad/files/patch-configure.in
new file mode 100644
index 000000000000..700ac59cedce
--- /dev/null
+++ b/audio/faad/files/patch-configure.in
@@ -0,0 +1,43 @@
+--- configure.in.orig Fri Feb 6 17:04:39 2004
++++ configure.in Wed Jan 19 01:44:24 2005
+@@ -49,6 +49,43 @@
+ fi
+ ])
+
++dnl @synopsis AC_C99_FUNC_LRINTF
++dnl
++dnl Check whether C99's lrintf function is available.
++dnl @version 1.3 Feb 12 2002
++dnl @author Erik de Castro Lopo <erikd AT mega-nerd DOT com>
++dnl
++dnl Permission to use, copy, modify, distribute, and sell this file for any
++dnl purpose is hereby granted without fee, provided that the above copyright
++dnl and this permission notice appear in all copies. No representations are
++dnl made about the suitability of this software for any purpose. It is
++dnl provided "as is" without express or implied warranty.
++dnl
++AC_DEFUN([AC_C99_FUNC_LRINTF],
++[AC_CACHE_CHECK(for lrintf,
++ ac_cv_c99_lrintf,
++[
++lrintf_save_CFLAGS=$CFLAGS
++CFLAGS="-O -lm"
++AC_TRY_LINK([
++#define _ISOC9X_SOURCE 1
++#define _ISOC99_SOURCE 1
++#define __USE_ISOC99 1
++#define __USE_ISOC9X 1
++
++#include <math.h>
++], if (!lrintf(3.14159)) lrintf(2.7183);, ac_cv_c99_lrintf=yes, ac_cv_c99_lrintf=no)
++
++CFLAGS=$lrintf_save_CFLAGS
++
++])
++
++if test "$ac_cv_c99_lrintf" = yes; then
++ AC_DEFINE(HAVE_LRINTF, 1,
++ [Define if you have C99's lrintf function.])
++fi
++])# AC_C99_FUNC_LRINTF
++AC_C99_FUNC_LRINTF