aboutsummaryrefslogtreecommitdiff
path: root/audio/festival+OGI/files
diff options
context:
space:
mode:
Diffstat (limited to 'audio/festival+OGI/files')
-rw-r--r--audio/festival+OGI/files/FreeBSD.mak15
-rw-r--r--audio/festival+OGI/files/extra-patch-aa13
-rw-r--r--audio/festival+OGI/files/extra-patch-aa-ogi20
-rw-r--r--audio/festival+OGI/files/festival.sh5
-rw-r--r--audio/festival+OGI/files/festival_client.sh4
-rw-r--r--audio/festival+OGI/files/patch-ab25
-rw-r--r--audio/festival+OGI/files/patch-ac24
-rw-r--r--audio/festival+OGI/files/patch-ad33
-rw-r--r--audio/festival+OGI/files/patch-ae12
-rw-r--r--audio/festival+OGI/files/patch-af15
-rw-r--r--audio/festival+OGI/files/patch-ag12
-rw-r--r--audio/festival+OGI/files/patch-ah12
-rw-r--r--audio/festival+OGI/files/patch-ai17
-rw-r--r--audio/festival+OGI/files/patch-al16
-rw-r--r--audio/festival+OGI/files/patch-am13
-rw-r--r--audio/festival+OGI/files/patch-an13
-rw-r--r--audio/festival+OGI/files/patch-ao13
-rw-r--r--audio/festival+OGI/files/patch-ap12
-rw-r--r--audio/festival+OGI/files/patch-aq10
-rw-r--r--audio/festival+OGI/files/sitevars.scm2
-rw-r--r--audio/festival+OGI/files/top-Makefile3
21 files changed, 0 insertions, 289 deletions
diff --git a/audio/festival+OGI/files/FreeBSD.mak b/audio/festival+OGI/files/FreeBSD.mak
deleted file mode 100644
index 26854d2f3cbf..000000000000
--- a/audio/festival+OGI/files/FreeBSD.mak
+++ /dev/null
@@ -1,15 +0,0 @@
-include $(EST)/config/systems/default.mak
-
-## echo -n doesn't work (well only sometimes ?)
-ECHO_N = /usr/bin/printf "%s"
-
-NAWK=awk
-
-NAS_LIB=$(PKG_X11BASE)/lib
-NAS_INCLUDE=$(PKG_X11BASE)/include
-
-X11_LIB=$(PKG_X11BASE)/lib
-X11_INCLUDE=$(PKG_X11BASE)/include
-
-OS_INCLUDES+=-I$(PKG_PREFIX)/include
-OS_LIBS+=-L$(PKG_PREFIX)/lib
diff --git a/audio/festival+OGI/files/extra-patch-aa b/audio/festival+OGI/files/extra-patch-aa
deleted file mode 100644
index e6072304c475..000000000000
--- a/audio/festival+OGI/files/extra-patch-aa
+++ /dev/null
@@ -1,13 +0,0 @@
-$NetBSD: patch-aa,v 1.2 1999/10/11 14:13:49 proff Exp $
-
---- festival/config/config Mon Oct 11 07:48:44 1999
-+++ festival/config/config Mon Oct 11 05:48:33 1999
-@@ -20,7 +20,7 @@
- ## You may need to set this explicitly if automounter or NFS
- ## side effects cause problems
-
--FESTIVAL_HOME := $(shell (cd $(TOP); pwd))
-+FESTIVAL_HOME := $(PKG_FESTIVAL_HOME)
-
- ###########################################################################
- ## Feature selection.
diff --git a/audio/festival+OGI/files/extra-patch-aa-ogi b/audio/festival+OGI/files/extra-patch-aa-ogi
deleted file mode 100644
index 5bd4cb84e40d..000000000000
--- a/audio/festival+OGI/files/extra-patch-aa-ogi
+++ /dev/null
@@ -1,20 +0,0 @@
-$NetBSD: patch-aa,v 1.2 1999/10/11 14:13:49 proff Exp $
-
---- festival/config/config Mon Oct 11 07:48:44 1999
-+++ festival/config/config Mon Oct 11 05:48:33 1999
-@@ -20,7 +20,7 @@
- ## You may need to set this explicitly if automounter or NFS
- ## side effects cause problems
-
--FESTIVAL_HOME := $(shell (cd $(TOP); pwd))
-+FESTIVAL_HOME := $(PKG_FESTIVAL_HOME)
-
- ###########################################################################
- ## Feature selection.
-@@ -70,3 +70,6 @@
- ## in config/configs/default.mak.
-
-
-+ALSO_INCLUDE += OGIcommon
-+ALSO_INCLUDE += OGIdbase
-+ALSO_INCLUDE += OGIresLPC
diff --git a/audio/festival+OGI/files/festival.sh b/audio/festival+OGI/files/festival.sh
deleted file mode 100644
index 6d606b8a44ee..000000000000
--- a/audio/festival+OGI/files/festival.sh
+++ /dev/null
@@ -1,5 +0,0 @@
-#!/bin/sh
-# path for audsp
-PATH=@PKG_PREFIX@/libexec:$PATH
-export PATH
-exec festival.naked --libdir @PKG_FESTIVAL_LOCATION@/lib $*
diff --git a/audio/festival+OGI/files/festival_client.sh b/audio/festival+OGI/files/festival_client.sh
deleted file mode 100644
index fc4ba4c944b7..000000000000
--- a/audio/festival+OGI/files/festival_client.sh
+++ /dev/null
@@ -1,4 +0,0 @@
-#!/bin/sh
-PATH=@PKG_PREFIX@/libexec:$PATH
-export PATH
-exec festival_client.naked @PKG_FESTIVAL_LOCATION@/lib $*
diff --git a/audio/festival+OGI/files/patch-ab b/audio/festival+OGI/files/patch-ab
deleted file mode 100644
index e8e939e1f994..000000000000
--- a/audio/festival+OGI/files/patch-ab
+++ /dev/null
@@ -1,25 +0,0 @@
-$NetBSD: patch-ab,v 1.2 1999/10/11 14:13:49 proff Exp $
-
---- festival/doc/Makefile Thu Jun 17 20:29:54 1999
-+++ festival/doc/Makefile Mon Oct 11 06:06:35 1999
-@@ -44,7 +44,7 @@
-
- EXAMPLE_TO_DOCUMENT=
-
--FESTIVAL=$(TOP)/bin/festival --libdir $(TOP)/lib
-+FESTIVAL=$(TOP)/src/main/festival --libdir $(TOP)/lib
-
- # Include some of EST documentation.
- DOCXX_EXTRA_FILES =
-@@ -72,9 +72,9 @@
- %.1 : %.head %.options %.tail
- cat $^ >$@
- %.options : $(TOP)/src/main/%
-- $(TOP)/bin/$* -man_options >$@
-+ $(FESTIVAL)$* -man_options >$@
- %.options : $(TOP)/src/main/%.exe
-- $(TOP)/bin/$* -man_options >$@
-+ $(FESTIVAL)$* -man_options >$@
-
- festival.info: festival.texi festfunc.texi festvars.texi festfeat.texi
- @ if [ ! -d info ] ; \
diff --git a/audio/festival+OGI/files/patch-ac b/audio/festival+OGI/files/patch-ac
deleted file mode 100644
index 628ef33f0d22..000000000000
--- a/audio/festival+OGI/files/patch-ac
+++ /dev/null
@@ -1,24 +0,0 @@
-$NetBSD: patch-ac,v 1.2 1999/10/11 14:13:49 proff Exp $
-
---- festival/examples/benchmark Thu Feb 27 00:47:45 1997
-+++ festival/examples/benchmark Mon Oct 11 05:41:14 1999
-@@ -1,6 +1,6 @@
- #!/bin/sh
-
--default_libdir="/projects/festival/lib"
-+default_libdir="$FESTIVAL_HOME/lib"
-
- while true
- do
-@@ -15,9 +15,9 @@
- esac
- done
-
--text=${1-"$HOME/projects/festival/examples/benchmark.text"}
-+text=${1-"$FESTIVAL_HOME/examples/benchmark.text"}
-
--for i in . src/main ../src/main $HOME/projects/festival/src/main /cstr/bin
-+for i in . src/main ../src/main $FESTIVAL_HOME/src/main
- do
- if [ -n "$festival" ]
- then
diff --git a/audio/festival+OGI/files/patch-ad b/audio/festival+OGI/files/patch-ad
deleted file mode 100644
index 31e40bb6e906..000000000000
--- a/audio/festival+OGI/files/patch-ad
+++ /dev/null
@@ -1,33 +0,0 @@
---- speech_tools/config/config.orig Thu Nov 18 19:10:29 1999
-+++ speech_tools/config/config Fri Jun 16 17:03:16 2000
-@@ -15,7 +15,7 @@
- ## You may need to set this explicitly if automounter or NFS
- ## side effects cause problems
-
--EST_HOME := $(shell (cd $(EST); pwd))
-+EST_HOME := $(PKG_EST_HOME)
-
- ###########################################################################
- ## System type.
-@@ -77,10 +77,10 @@
- ## specify a program to play files in a desired format.
-
- ## NCD's network audio system, This is recommended.
--# INCLUDE_MODULES += NAS_AUDIO
-+INCLUDE_MODULES += NAS_AUDIO
-
- ## Elightenment Sound Demon, for KDE etc.
--# INCLUDE_MODULES += ESD_AUDIO
-+INCLUDE_MODULES += ESD_AUDIO
-
- ## Native audio for your platform (sun, linux, freebsd, irix, windows)
- INCLUDE_MODULES += NATIVE_AUDIO
-@@ -95,7 +95,7 @@
- INCLUDE_MODULES += EDITLINE
-
- # speech recognition
--#INCLUDE_MODULES += ASR
-+INCLUDE_MODULES += ASR
-
-
- ## Scheme
diff --git a/audio/festival+OGI/files/patch-ae b/audio/festival+OGI/files/patch-ae
deleted file mode 100644
index ac4d747da708..000000000000
--- a/audio/festival+OGI/files/patch-ae
+++ /dev/null
@@ -1,12 +0,0 @@
-$NetBSD: patch-ae,v 1.2 1999/10/11 14:13:49 proff Exp $
-
---- speech_tools/include/EST_unix.h Sun May 30 20:53:04 1999
-+++ speech_tools/include/EST_unix.h Mon Oct 11 05:40:15 1999
-@@ -53,6 +53,7 @@
- # include <sys/wait.h>
- # include <sys/resource.h>
- # include <dirent.h>
-+# define unix 1
- #elif defined(SYSTEM_IS_WIN32)
- # include <io.h>
- # include "win32/EST_unix_win32.h"
diff --git a/audio/festival+OGI/files/patch-af b/audio/festival+OGI/files/patch-af
deleted file mode 100644
index 63a2742d378d..000000000000
--- a/audio/festival+OGI/files/patch-af
+++ /dev/null
@@ -1,15 +0,0 @@
-$NetBSD: patch-af,v 1.1 1999/10/11 14:13:49 proff Exp $
-
---- festival/config/project.mak-dist Mon Oct 11 21:41:08 1999
-+++ festival/config/project.mak Mon Oct 11 22:27:37 1999
-@@ -70,8 +70,8 @@
-
- # Place where programs are compiled
-
--PROJECT_MAIN_DIR=$(FESTIVAL_HOME)/src/main
--PROJECT_SCRIPTS_DIR=$(FESTIVAL_HOME)/src/scripts
-+PROJECT_MAIN_DIR=$(PKG_FESTIVAL_BUILD_HOME)/src/main
-+PROJECT_SCRIPTS_DIR=$(PKG_FESTIVAL_BUILD_HOME)/src/scripts
-
- # Where the main RCS tree is, probably only used within CSTR
-
diff --git a/audio/festival+OGI/files/patch-ag b/audio/festival+OGI/files/patch-ag
deleted file mode 100644
index 528356470d10..000000000000
--- a/audio/festival+OGI/files/patch-ag
+++ /dev/null
@@ -1,12 +0,0 @@
-$NetBSD: patch-ag,v 1.1 2000/05/05 20:54:57 hubertf Exp $
-
---- speech_tools/config/modules/nas_audio.mak.orig Fri May 5 20:55:15 2000
-+++ speech_tools/config/modules/nas_audio.mak Fri May 5 20:58:07 2000
-@@ -45,6 +45,6 @@
- AUDIO_DEFINES += -DSUPPORT_NAS
- AUDIO_INCLUDES += -I$(NAS_INCLUDE)
- MODULE_LIBS += -L$(NAS_LIB) -laudio
--MODULE_EXTRA_LIBS += -L$(X11_LIB) -lX11 -lXt
-+MODULE_EXTRA_LIBS += -L$(X11_LIB) -Wl,-R $(X11_LIB) -lX11 -lXt
-
-
diff --git a/audio/festival+OGI/files/patch-ah b/audio/festival+OGI/files/patch-ah
deleted file mode 100644
index 090c337db539..000000000000
--- a/audio/festival+OGI/files/patch-ah
+++ /dev/null
@@ -1,12 +0,0 @@
-$NetBSD: patch-ah,v 1.1 2000/05/05 20:54:57 hubertf Exp $
-
---- festival/config/modules/nas_audio.mak.orig Fri May 5 21:07:15 2000
-+++ festival/config/modules/nas_audio.mak Fri May 5 21:07:29 2000
-@@ -44,6 +44,6 @@
-
- AUDIO_DEFINES += -DSUPPORT_NAS
- AUDIO_INCLUDES += -I$(NAS_INCLUDE)
--MODULE_LIBS += -L$(NAS_LIB) -laudio -L$(X11_LIB) -lX11 -lXt
-+MODULE_LIBS += -L$(NAS_LIB) -laudio -L$(X11_LIB) -Wl,-R$(X11_LIB) -lX11 -lXt
-
-
diff --git a/audio/festival+OGI/files/patch-ai b/audio/festival+OGI/files/patch-ai
deleted file mode 100644
index a20edf01ef03..000000000000
--- a/audio/festival+OGI/files/patch-ai
+++ /dev/null
@@ -1,17 +0,0 @@
-$NetBSD: patch-ai,v 1.2 2000/05/31 14:51:16 dmcmahill Exp $
-
-work around pmax compiler bug
-
---- speech_tools/grammar/ngram/Makefile.orig Sun May 30 06:59:41 1999
-+++ speech_tools/grammar/ngram/Makefile Tue May 30 12:41:32 2000
-@@ -49,3 +49,10 @@
- include $(TOP)/config/common_make_rules
-
-+ifeq ($(MACHINETYPE),pmax)
-+
-+ngrammar_io.o: ngrammar_io.cc
-+ ${CXX} -c -fno-implicit-templates -fguiding-decls -Wall -I../../include ${OS_INCLUDES} ngrammar_io.cc
-+
-+endif
-+
-
diff --git a/audio/festival+OGI/files/patch-al b/audio/festival+OGI/files/patch-al
deleted file mode 100644
index 40bc2e8906ab..000000000000
--- a/audio/festival+OGI/files/patch-al
+++ /dev/null
@@ -1,16 +0,0 @@
-$NetBSD: patch-al,v 1.1 2000/05/31 14:51:17 dmcmahill Exp $
-
-work around pmax compiler bug
-
---- festival/src/modules/Duration/Makefile.orig Sun May 30 08:07:31 1999
-+++ festival/src/modules/Duration/Makefile Wed May 31 09:22:01 2000
-@@ -51,3 +51,9 @@
- include $(TOP)/config/common_make_rules
-
-+ifeq ($(MACHINETYPE),pmax)
-+
-+duration.o:duration.cc
-+ ${CXX} -c -fno-implicit-templates -fguiding-decls -Wall -I../include -I../../../src/include -I../../../../speech_tools/include ${OS_INCLUDES} duration.cc
-+
-+endif
-
diff --git a/audio/festival+OGI/files/patch-am b/audio/festival+OGI/files/patch-am
deleted file mode 100644
index 3cd79202f9d1..000000000000
--- a/audio/festival+OGI/files/patch-am
+++ /dev/null
@@ -1,13 +0,0 @@
-passing `int *' as argument 3 of `accept(int, sockaddr *, socklen_t *)' changes signedness
-
---- speech_tools/utils/EST_Server.cc.orig Thu Nov 18 23:14:51 1999
-+++ speech_tools/utils/EST_Server.cc Sun Jun 11 17:27:17 2000
-@@ -647,7 +647,7 @@
-
- while (connected() &&
- (csocket = accept(p_socket, (struct sockaddr *) &sin,
-- SOCKLEN_CAST &sin_size))>=0)
-+ (socklen_t *) &sin_size))>=0)
- {
- if (p_trace)
- *p_trace << "connection " << csocket << "\n";
diff --git a/audio/festival+OGI/files/patch-an b/audio/festival+OGI/files/patch-an
deleted file mode 100644
index 405e46cffbff..000000000000
--- a/audio/festival+OGI/files/patch-an
+++ /dev/null
@@ -1,13 +0,0 @@
-passing `int *' as argument 3 of `getsockname(int, sockaddr *, socklen_t *)' changes signedness
-
---- speech_tools/utils/EST_ServiceTable.cc.orig Thu Nov 18 23:15:21 1999
-+++ speech_tools/utils/EST_ServiceTable.cc Sun Jun 11 17:28:29 2000
-@@ -296,7 +296,7 @@
-
- // This only gets the port number
-
-- if (getsockname(socket, (struct sockaddr *)&sin, SOCKLEN_CAST &size) != 0)
-+ if (getsockname(socket, (struct sockaddr *)&sin, (socklen_t *) &size) != 0)
- EST_sys_error("Can't find my address");
-
-
diff --git a/audio/festival+OGI/files/patch-ao b/audio/festival+OGI/files/patch-ao
deleted file mode 100644
index 73b77083ebf9..000000000000
--- a/audio/festival+OGI/files/patch-ao
+++ /dev/null
@@ -1,13 +0,0 @@
-passing `int *' as argument 3 of `getpeername(int, sockaddr *, socklen_t *)' changes signedness
-
---- ./festival/src/arch/festival/server.cc.orig Thu Nov 18 23:46:47 1999
-+++ ./festival/src/arch/festival/server.cc Sun Jun 11 17:48:45 2000
-@@ -206,7 +206,7 @@
- const char *client_hostnum;
- const char *reason = "";
-
-- getpeername(fd,(struct sockaddr *)&peer,SOCKLEN_CAST &addrlen);
-+ getpeername(fd,(struct sockaddr *)&peer, (socklen_t *) &addrlen);
- clienthost = gethostbyaddr((char *)&peer.sin_addr,
- sizeof(peer.sin_addr),AF_INET);
- client_hostnum = inet_ntoa(peer.sin_addr);
diff --git a/audio/festival+OGI/files/patch-ap b/audio/festival+OGI/files/patch-ap
deleted file mode 100644
index 0794c74870f9..000000000000
--- a/audio/festival+OGI/files/patch-ap
+++ /dev/null
@@ -1,12 +0,0 @@
---- speech_tools/audio/nas.cc.orig Thu Oct 14 16:26:29 1999
-+++ speech_tools/audio/nas.cc Fri Jun 16 17:24:25 2000
-@@ -57,7 +57,8 @@
-
- int nas_supported = TRUE;
-
--int endian_int = 1;
-+extern int endian_int;
-+int endian_int = 1;
- #define NAS_BIG_ENDIAN (((char *)&endian_int)[0] == 0)
-
- static void na_sync_play_cb(AuServer *aud, AuEventHandlerRec *handler,
diff --git a/audio/festival+OGI/files/patch-aq b/audio/festival+OGI/files/patch-aq
deleted file mode 100644
index 012bfe0c9817..000000000000
--- a/audio/festival+OGI/files/patch-aq
+++ /dev/null
@@ -1,10 +0,0 @@
---- speech_tools/audio/esd.cc.orig Mon Oct 4 15:39:01 1999
-+++ speech_tools/audio/esd.cc Fri Jun 16 17:49:10 2000
-@@ -66,7 +66,6 @@
-
- bool esd_supported = TRUE;
-
--int endian_int = 1;
- #define ESD_BIG_ENDIAN (((char *)&endian_int)[0] == 0)
-
- EST_String server;
diff --git a/audio/festival+OGI/files/sitevars.scm b/audio/festival+OGI/files/sitevars.scm
deleted file mode 100644
index e80dbfa1c73c..000000000000
--- a/audio/festival+OGI/files/sitevars.scm
+++ /dev/null
@@ -1,2 +0,0 @@
-(set! system-voice-path '("@PKG_FESTIVAL_LOCATION@/lib/voices"))
-(set! sgml_parse_progname "nsgmls")
diff --git a/audio/festival+OGI/files/top-Makefile b/audio/festival+OGI/files/top-Makefile
deleted file mode 100644
index ee190c4fe49e..000000000000
--- a/audio/festival+OGI/files/top-Makefile
+++ /dev/null
@@ -1,3 +0,0 @@
-all:
- cd speech_tools && $(MAKE)
- cd festival && $(MAKE)