aboutsummaryrefslogtreecommitdiff
path: root/audio/gnump3d
diff options
context:
space:
mode:
Diffstat (limited to 'audio/gnump3d')
-rw-r--r--audio/gnump3d/Makefile23
-rw-r--r--audio/gnump3d/distinfo2
-rw-r--r--audio/gnump3d/files/patch-config::ltmain.sh10
-rw-r--r--audio/gnump3d/files/patch-src::threads.cc10
-rw-r--r--audio/gnump3d/pkg-plist24
5 files changed, 53 insertions, 16 deletions
diff --git a/audio/gnump3d/Makefile b/audio/gnump3d/Makefile
index 48128bea63dc..39cd50713e97 100644
--- a/audio/gnump3d/Makefile
+++ b/audio/gnump3d/Makefile
@@ -7,21 +7,25 @@
#
PORTNAME= gnump3d
-PORTVERSION= 0.9.9.9.1
+PORTVERSION= 0.9.9.9.2
CATEGORIES= audio
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
+BUILD_DEPENDS= autoconf:${PORTSDIR}/devel/autoconf
+
USE_BZIP2= yes
USE_PERL5= yes
USE_REINPLACE= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
- LIBS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+CONFIGURE_ARGS= --libdir=${PREFIX}/lib/gnump3d
+INSTALLS_SHLIB= yes
MAN1= gnump3d.1 gnump3d.conf.1 gnump3d-config.1 gnump3d-top.1
@@ -38,13 +42,14 @@ pre-everything::
.endif
post-patch:
- @${REINPLACE_CMD} -e \
- 's|=aclocal|=${TRUE}|g ; \
- s|=autoconf|=${TRUE}|g ; \
- s|=automake|=${TRUE}|g ; \
- s|=autoheader|=${TRUE}|g ; \
- s|-pthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|-D_THREAD_SAFE|${PTHREAD_CFLAGS}|g ; \
+ s|-pthread|${PTHREAD_LIBS}|g' ${WRKSRC}/aclocal.m4
@${REINPLACE_CMD} -e \
's|#undef socklen_t||g' ${WRKSRC}/src/config.h.in
+pre-configure:
+.for dir in . mplib libltdl
+ @cd ${WRKSRC}/${dir} && ${LOCALBASE}/bin/autoconf
+.endfor
+
.include <bsd.port.mk>
diff --git a/audio/gnump3d/distinfo b/audio/gnump3d/distinfo
index 844cbba22a21..1ea011054759 100644
--- a/audio/gnump3d/distinfo
+++ b/audio/gnump3d/distinfo
@@ -1 +1 @@
-MD5 (gnump3d-0.9.9.9.1.tar.bz2) = 10048c53ec1a1382fe8092dd181dbe00
+MD5 (gnump3d-0.9.9.9.2.tar.bz2) = 1e8c72e5dec7ab9c98f2d9e5795cfca3
diff --git a/audio/gnump3d/files/patch-config::ltmain.sh b/audio/gnump3d/files/patch-config::ltmain.sh
new file mode 100644
index 000000000000..d8d418253953
--- /dev/null
+++ b/audio/gnump3d/files/patch-config::ltmain.sh
@@ -0,0 +1,10 @@
+--- config/ltmain.sh.orig Sun Jul 14 08:53:50 2002
++++ config/ltmain.sh Tue Jul 16 00:38:55 2002
+@@ -967,6 +967,7 @@
+ ;;
+
+ -avoid-version)
++ build_old_libs=no
+ avoid_version=yes
+ continue
+ ;;
diff --git a/audio/gnump3d/files/patch-src::threads.cc b/audio/gnump3d/files/patch-src::threads.cc
new file mode 100644
index 000000000000..e3df3f0b3c49
--- /dev/null
+++ b/audio/gnump3d/files/patch-src::threads.cc
@@ -0,0 +1,10 @@
+--- src/threads.cc.orig Sun Jul 14 08:53:50 2002
++++ src/threads.cc Tue Jul 16 00:01:18 2002
+@@ -39,6 +39,7 @@
+ #include <errno.h>
+ #include <algorithm>
+ #include <fstream.h> /* Portability fix: used to be <fstream> */
++#include <sys/types.h>
+ #include <netinet/in.h>
+ #include <sys/socket.h>
+ #include <netdb.h>
diff --git a/audio/gnump3d/pkg-plist b/audio/gnump3d/pkg-plist
index 5883503b8fee..620facfeb5ce 100644
--- a/audio/gnump3d/pkg-plist
+++ b/audio/gnump3d/pkg-plist
@@ -1,31 +1,43 @@
bin/gnump3d
+bin/gnump3d-config
bin/gnump3d-top
-etc/gnump3d/gnump3d.conf
etc/gnump3d/default/error.html
etc/gnump3d/default/index.html
+etc/gnump3d/default/plugin.html
etc/gnump3d/default/results.html
etc/gnump3d/default/search.html
etc/gnump3d/default/stats.html
etc/gnump3d/default/style.css
+etc/gnump3d/gnump3d.conf
etc/gnump3d/nausicaa/error.html
etc/gnump3d/nausicaa/index.html
+etc/gnump3d/nausicaa/plugin.html
etc/gnump3d/nausicaa/results.html
etc/gnump3d/nausicaa/search.html
etc/gnump3d/nausicaa/stats.html
+etc/gnump3d/nausicaa/style.css
etc/gnump3d/simple/config.ini
etc/gnump3d/simple/error.html
etc/gnump3d/simple/index.html
+etc/gnump3d/simple/plugin.html
etc/gnump3d/simple/results.html
etc/gnump3d/simple/search.html
etc/gnump3d/simple/stats.html
etc/gnump3d/split/config.ini
etc/gnump3d/split/error.html
etc/gnump3d/split/index.html
+etc/gnump3d/split/plugin.html
etc/gnump3d/split/results.html
etc/gnump3d/split/search.html
etc/gnump3d/split/stats.html
-@dirrm etc/gnump3d/split
-@dirrm etc/gnump3d/simple
-@dirrm etc/gnump3d/nausicaa
-@dirrm etc/gnump3d/default
-@dirrm etc/gnump3d
+lib/gnump3d/last20.la
+lib/gnump3d/last20.so
+lib/gnump3d/search.la
+lib/gnump3d/search.so
+lib/gnump3d/stats.la
+lib/gnump3d/stats.so
+lib/gnump3d/theme.la
+lib/gnump3d/theme.so
+lib/gnump3d/version.la
+lib/gnump3d/version.so
+@dirrm lib/gnump3d