aboutsummaryrefslogtreecommitdiff
path: root/audio/gstreamer-plugins-mp3/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'audio/gstreamer-plugins-mp3/Makefile')
-rw-r--r--audio/gstreamer-plugins-mp3/Makefile40
1 files changed, 40 insertions, 0 deletions
diff --git a/audio/gstreamer-plugins-mp3/Makefile b/audio/gstreamer-plugins-mp3/Makefile
new file mode 100644
index 000000000000..7202aec9fb14
--- /dev/null
+++ b/audio/gstreamer-plugins-mp3/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: gstreamer-plugins-mp3
+# Date created: 2007-06-07
+# Whom: Michael Johnson <ahze@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gstreamer-plugins
+PORTVERSION= 0.10.0
+CATEGORIES= audio
+MASTER_SITES= # empty
+PKGNAMESUFFIX= -mp3
+DISTFILES= # empty
+EXTRACT_ONLY= # empty
+
+MAINTAINER= multimedia@FreeBSD.org
+COMMENT= Gstreamer Plugins Mp3 decoder meta-port
+
+NO_BUILD= yes
+WANT_GSTREAMER= yes
+OPTIONS= MAD "Use MAD Mp3" On \
+ FLUENDO "Use Fluendo Mp3" Off
+
+.include <bsd.port.pre.mk>
+
+.if !defined(WITH_MAD) && !defined(WITH_FLUENDO)
+WITH_MAD= yes
+.endif
+
+.if defined(WITH_MAD)
+USE_GSTREAMER+= mad
+.endif
+
+.if defined(WITH_FLUENDO)
+USE_GSTREAMER+= fluendo-mp3
+.endif
+
+do-install:
+
+.include <bsd.port.post.mk>