aboutsummaryrefslogtreecommitdiff
path: root/audio/liba52-devel
diff options
context:
space:
mode:
Diffstat (limited to 'audio/liba52-devel')
-rw-r--r--audio/liba52-devel/Makefile73
-rw-r--r--audio/liba52-devel/distinfo2
-rw-r--r--audio/liba52-devel/pkg-descr24
-rw-r--r--audio/liba52-devel/pkg-plist14
4 files changed, 0 insertions, 113 deletions
diff --git a/audio/liba52-devel/Makefile b/audio/liba52-devel/Makefile
deleted file mode 100644
index 2bf124e8cb99..000000000000
--- a/audio/liba52-devel/Makefile
+++ /dev/null
@@ -1,73 +0,0 @@
-# New ports collection makefile for: liba52
-# Date created: Tue Oct 16 10:43:56 BRST 2001
-# Whom: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
-#
-# $FreeBSD$
-#
-
-PORTNAME= liba52
-PORTVERSION= 0.7.4
-PORTREVISION= 1
-CATEGORIES= audio
-MASTER_SITES= http://liba52.sourceforge.net/files/
-DISTNAME= a52dec-${PORTVERSION:S/.b/b/}
-
-MAINTAINER= lioux@FreeBSD.org
-COMMENT= A free library for decoding ATSC A/52 streams, aka AC-3
-
-USE_GMAKE= yes
-USE_REINPLACE= yes
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --disable-oss --enable-shared
-USE_LIBTOOL_VER= 13
-INSTALLS_SHLIB= yes
-
-.if !defined(WITHOUT_DJBFFT) && !defined(PACKAGE_BUILDING)
-BUILD_DEPENDS+= ${LOCALBASE}/lib/libdjbfft.a:${PORTSDIR}/math/djbfft
-RUN_DEPENDS+= ${LOCALBASE}/lib/libdjbfft.a:${PORTSDIR}/math/djbfft
-
-CONFIGURE_ENV+= CFLAGS="${CFLAGS} -I${LOCALBASE}/include" \
- LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib"
-CONFIGURE_ARGS+= --enable-djbfft
-.endif
-
-MAN1= a52dec.1 extract_a52.1
-
-HEADER_FILES= liba52/a52_internal.h
-
-pre-everything::
-.ifndef(WITH_OPTIMIZED_CFLAGS)
- @${ECHO_MSG} ">>>"
- @${ECHO_MSG} ">>> You can enable extra optimizations by defining WITH_OPTIMIZED_CFLAGS."
- @${ECHO_MSG} ">>> For example, 'make WITH_OPTIMIZED_CFLAGS=yes'"
- @${ECHO_MSG} ">>>"
-.endif
-.ifndef(WITHOUT_DJBFFT)
- @${ECHO_MSG} '>>>'
- @${ECHO_MSG} '>>> You can disable djbfft optimized FFT routines by defining WITHOUT_DJBFFT.'
- @${ECHO_MSG} ">>> For example, 'make WITHOUT_DJBFFT=yes'"
- @${ECHO_MSG} '>>>'
-.endif
-
-post-patch:
-.ifndef(WITH_OPTIMIZED_CFLAGS)
- @${REINPLACE_CMD} -E -e 's!-O3!${CFLAGS}!' -e 's!-mcpu=[^"]+"!"!' \
- ${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
-.endif
-.ifndef(WITHOUT_DJBFFT)
- @${REINPLACE_CMD} -E -e 's|(fftc4.h)|djbfft/\1|' ${WRKSRC}/liba52/imdct.c
-.endif
-
-post-configure:
- @${LN} -sf ${LIBTOOL} ${WRKSRC}/libtool
-
-post-install:
-.ifndef(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- @${INSTALL_DATA} ${WRKSRC}/doc/liba52.txt ${DOCSDIR}
-.endif
-.for file in ${HEADER_FILES}
- @${INSTALL_DATA} ${WRKSRC}/${file} ${PREFIX}/include/a52dec
-.endfor
-
-.include <bsd.port.mk>
diff --git a/audio/liba52-devel/distinfo b/audio/liba52-devel/distinfo
deleted file mode 100644
index 1df915b44fa8..000000000000
--- a/audio/liba52-devel/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-MD5 (a52dec-0.7.4.tar.gz) = caa9f5bc44232dc8aeea773fea56be80
-SIZE (a52dec-0.7.4.tar.gz) = 241507
diff --git a/audio/liba52-devel/pkg-descr b/audio/liba52-devel/pkg-descr
deleted file mode 100644
index 10e66340e5da..000000000000
--- a/audio/liba52-devel/pkg-descr
+++ /dev/null
@@ -1,24 +0,0 @@
-[ from developer's site ]
-It is a free library for decoding ATSC A/52 streams, aka AC-3. The
-A/52 standard is used in a variety of applications, e.g., digital
-television and DVD. The main goals in liba52 development are:
-
-Portability - most of the code is written in C, and when we use
-platform-specific optimizations we always have a generic C routine
-to fall back on.
-
-Reuseability - we do not want liba52 to include any project-specific
-code, but it should still include enough features to be used by
-very diverse projects.
-
-Precision - We are trying to implement all of the A/52 standard,
-and to have a very precise output by doing all the calculations in
-floating point. We have a test suite that detects any deviation in
-the output when compared to previous versions. We do not have access
-to official A/52 test vectors though, so we have to use our judgement
-to ensure that such deviations are only introduced when we fix bugs!
-
-Speed - liba52 is really fast, on any modern PC it should take only
-a few percent of CPU time.
-
-WWW: http://liba52.sourceforge.net/
diff --git a/audio/liba52-devel/pkg-plist b/audio/liba52-devel/pkg-plist
deleted file mode 100644
index c03996cc1c6f..000000000000
--- a/audio/liba52-devel/pkg-plist
+++ /dev/null
@@ -1,14 +0,0 @@
-bin/a52dec
-bin/extract_a52
-include/a52dec/a52.h
-include/a52dec/a52_internal.h
-include/a52dec/attributes.h
-include/a52dec/audio_out.h
-include/a52dec/mm_accel.h
-lib/liba52.so.0
-lib/liba52.so
-lib/liba52.la
-lib/liba52.a
-%%PORTDOCS%%%%DOCSDIR%%/liba52.txt
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
-@dirrm include/a52dec