aboutsummaryrefslogtreecommitdiff
path: root/audio/linux-c7-alsa-plugins-oss/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'audio/linux-c7-alsa-plugins-oss/Makefile')
-rw-r--r--audio/linux-c7-alsa-plugins-oss/Makefile15
1 files changed, 7 insertions, 8 deletions
diff --git a/audio/linux-c7-alsa-plugins-oss/Makefile b/audio/linux-c7-alsa-plugins-oss/Makefile
index 00fb84c0f20e..8ecf35e1d896 100644
--- a/audio/linux-c7-alsa-plugins-oss/Makefile
+++ b/audio/linux-c7-alsa-plugins-oss/Makefile
@@ -1,27 +1,26 @@
# Created by: Piotr Kubaj <pkubaj@anongoth.pl>
# $FreeBSD$
-PORTNAME= alsa-plugins-oss
+PORTNAME= alsa-plugins
PORTVERSION= 1.1.1
CATEGORIES= audio linux
+PKGNAMESUFFIX= -oss
+LIB_DISTNAMES= ${LINUXNAME}-${DISTVERSIONFULL}
MAINTAINER= emulation@FreeBSD.org
COMMENT= OSS plugin for ALSA (Linux CentOS ${LINUX_DIST_VER})
LICENSE= GPLv3
-CONFLICTS= linux-c6-${PORTNAME}-[0-9]*
-
-SRC_DISTFILES= alsa-plugins-${PORTVERSION}-${RPMVERSION}${SRC_SUFX}:SOURCE
+CONFLICTS= linux-c6-${LINUXNAME}-[0-9]*
+DESCR= ${.CURDIR}/../${PORTNAME}/pkg-descr
+DOCSDIR= ${PREFIX}/usr/share/doc/${LINUXNAME}-${PORTVERSION}
+LINUXNAME= ${PORTNAME}${PKGNAMESUFFIX}
RPMVERSION= 1.el7
USES= linux:c7
USE_LDCONFIG= yes
USE_LINUX= alsalib
USE_LINUX_RPM= yes
-# We will use native configuration file, so delete a linux one
-post-extract:
- @${RM} -r ${WRKSRC}/etc
-
.include <bsd.port.mk>