aboutsummaryrefslogtreecommitdiff
path: root/audio/raop_play
diff options
context:
space:
mode:
Diffstat (limited to 'audio/raop_play')
-rw-r--r--audio/raop_play/Makefile2
-rw-r--r--audio/raop_play/files/patch-aexcl-Makefile.in13
-rw-r--r--audio/raop_play/files/patch-raop_play-aexcl_lib.h12
3 files changed, 19 insertions, 8 deletions
diff --git a/audio/raop_play/Makefile b/audio/raop_play/Makefile
index fd422b780e20..12b839443ee7 100644
--- a/audio/raop_play/Makefile
+++ b/audio/raop_play/Makefile
@@ -23,8 +23,6 @@ RUN_DEPENDS= mpg321:${PORTSDIR}/audio/mpg321 \
faad:${PORTSDIR}/audio/faad \
flac:${PORTSDIR}/audio/flac
-BROKEN= does not compile
-
GNU_CONFIGURE= yes
CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib"
USE_GMAKE= yes
diff --git a/audio/raop_play/files/patch-aexcl-Makefile.in b/audio/raop_play/files/patch-aexcl-Makefile.in
index a8c3d6e8c7ff..65bca60e729a 100644
--- a/audio/raop_play/files/patch-aexcl-Makefile.in
+++ b/audio/raop_play/files/patch-aexcl-Makefile.in
@@ -1,5 +1,5 @@
---- aexcl/Makefile.in.orig Fri Dec 16 23:17:00 2005
-+++ aexcl/Makefile.in Thu Jul 6 16:32:41 2006
+--- aexcl/Makefile.in.orig 2005-12-16 23:17:00.000000000 +0900
++++ aexcl/Makefile.in 2008-05-08 21:29:43.000000000 +0900
@@ -2,6 +2,7 @@
CC = @CC@
CXX = @CXX@
@@ -8,7 +8,12 @@
LIBS = @LIBS@
prefix = @prefix@
exec_prefix = @exec_prefix@
-@@ -17,8 +18,8 @@
+@@ -12,13 +13,12 @@
+ mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
+
+ TARGET=aexcl_play
+-GLIB_SUBST=1 # remove this line, if you want to use libglib-2.0
+ DESTDIR =
CXXFLAGS += -Wall -D_GNU_SOURCE -I../raop_play -I../rendezvous
GLIB = glib-2.0
@@ -19,7 +24,7 @@
ifdef GLIB_SUBST
GLIB_SUBST_OBJ = ipod/glibsubst.o
-@@ -29,8 +30,8 @@
+@@ -29,8 +29,8 @@
all: $(TARGET)
diff --git a/audio/raop_play/files/patch-raop_play-aexcl_lib.h b/audio/raop_play/files/patch-raop_play-aexcl_lib.h
index 9b08e7baf5db..6e8c0a885cec 100644
--- a/audio/raop_play/files/patch-raop_play-aexcl_lib.h
+++ b/audio/raop_play/files/patch-raop_play-aexcl_lib.h
@@ -1,5 +1,5 @@
---- raop_play/aexcl_lib.h~ Thu Jul 28 04:43:17 2005
-+++ raop_play/aexcl_lib.h Fri Aug 12 09:28:23 2005
+--- raop_play/aexcl_lib.h.orig 2005-12-16 23:17:01.000000000 +0900
++++ raop_play/aexcl_lib.h 2008-05-08 21:52:26.000000000 +0900
@@ -1,5 +1,5 @@
#include <stdio.h>
-#include <asm/types.h>
@@ -17,3 +17,11 @@
BEGIN_C_DECLS
+@@ -75,7 +78,6 @@
+ }
+ n=n<<1;
+ }
+- newsize=newsize;
+ np=realloc(*p,newsize);
+ if(!np){
+ ERRMSG("%s: realloc failed: %s\n",func,strerror(errno));