aboutsummaryrefslogtreecommitdiff
path: root/audio/rhythmbox-devel
diff options
context:
space:
mode:
Diffstat (limited to 'audio/rhythmbox-devel')
-rw-r--r--audio/rhythmbox-devel/Makefile66
-rw-r--r--audio/rhythmbox-devel/distinfo1
-rw-r--r--audio/rhythmbox-devel/files/patch-configure10
-rw-r--r--audio/rhythmbox-devel/files/patch-corba_Makefile.in11
-rw-r--r--audio/rhythmbox-devel/files/patch-lib_rb-tree-dnd.c26
-rw-r--r--audio/rhythmbox-devel/pkg-descr5
-rw-r--r--audio/rhythmbox-devel/pkg-plist166
7 files changed, 0 insertions, 285 deletions
diff --git a/audio/rhythmbox-devel/Makefile b/audio/rhythmbox-devel/Makefile
deleted file mode 100644
index 197109570324..000000000000
--- a/audio/rhythmbox-devel/Makefile
+++ /dev/null
@@ -1,66 +0,0 @@
-# New ports collection makefile for: rhythmbox
-# Date created: 17 August 2003
-# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
-#
-# $FreeBSD$
-#
-
-PORTNAME= rhythmbox
-PORTVERSION= 0.6.0
-CATEGORIES= audio gnome
-MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/${PORTNAME}/0.6
-DIST_SUBDIR= gnome2
-
-MAINTAINER= marcus@freebsd.org
-COMMENT= Audio player for the Gnome 2 desktop environment
-
-LIB_DEPENDS= musicbrainz.3:${PORTSDIR}/audio/libmusicbrainz \
- FLAC.5:${PORTSDIR}/audio/flac \
- mad.1:${PORTSDIR}/audio/mad
-
-USE_BZIP2= yes
-USE_X_PREFIX= yes
-USE_GMAKE= yes
-USE_GNOME= gnomehack gnomeprefix libgnomeui
-USE_LIBTOOL= yes
-CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib -L${X11BASE}/lib -lm" \
- CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include"
-
-.include <bsd.port.pre.mk>
-
-.if exists(${LOCALBASE}/lib/libvorbis.so)
-WITH_VORBIS= yes
-.endif
-
-.ifdef (WITH_VORBIS)
-LIB_DEPENDS+= vorbis.2:${PORTSDIR}/audio/libvorbis
-.else
-CONFIGURE_ARGS+= --disable-vorbis --disable-vorbistest
-.endif
-
-.ifdef (WITH_XINE)
-LIB_DEPENDS+= xine.7:${PORTSDIR}/multimedia/libxine
-CONFIGURE_ARGS+= --enable-xine
-.else
-LIB_DEPENDS+= gstplay-0.6.1:${PORTSDIR}/multimedia/gstreamer-plugins
-.endif
-
-pre-everything::
-.if !defined(WITH_XINE)
- @${ECHO_MSG}
- @${ECHO_MSG} "You must have gstreamer-plugins built with MAD support!"
- @${ECHO_MSG}
-.endif
-.if !defined(WITH_VORBIS)
- @${ECHO_MSG}
- @${ECHO_MSG} "Define WITH_VORBIS to enable Vorbis support"
- @${ECHO_MSG}
-.endif
-.if !defined(WITH_XINE)
- @${ECHO_MSG}
- @${ECHO_MSG} "Define WITH_XINE to use xine backend instead of gstreamer"
- @${ECHO_MSG}
-.endif
-
-.include <bsd.port.post.mk>
diff --git a/audio/rhythmbox-devel/distinfo b/audio/rhythmbox-devel/distinfo
deleted file mode 100644
index e82342d64f5a..000000000000
--- a/audio/rhythmbox-devel/distinfo
+++ /dev/null
@@ -1 +0,0 @@
-MD5 (gnome2/rhythmbox-0.6.0.tar.bz2) = 4b2f613f3a9f0e66facdc571867093c1
diff --git a/audio/rhythmbox-devel/files/patch-configure b/audio/rhythmbox-devel/files/patch-configure
deleted file mode 100644
index f195f07b43c6..000000000000
--- a/audio/rhythmbox-devel/files/patch-configure
+++ /dev/null
@@ -1,10 +0,0 @@
---- configure.orig Wed Dec 11 18:31:51 2002
-+++ configure Thu Dec 12 12:07:17 2002
-@@ -7414,6 +7414,7 @@
-
- # This can be used to rebuild libtool when needed
- LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
-+$ac_aux_dir/ltconfig $LIBTOOL_DEPS
-
- # Always use our own libtool.
- LIBTOOL='$(SHELL) $(top_builddir)/libtool'
diff --git a/audio/rhythmbox-devel/files/patch-corba_Makefile.in b/audio/rhythmbox-devel/files/patch-corba_Makefile.in
deleted file mode 100644
index 723285dfa01b..000000000000
--- a/audio/rhythmbox-devel/files/patch-corba_Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- corba/Makefile.in.orig Wed Aug 27 04:19:40 2003
-+++ corba/Makefile.in Wed Aug 27 04:19:56 2003
-@@ -237,7 +237,7 @@
-
- noinst_HEADERS = Rhythmbox.h
-
--idldir = $(prefix)/share/idl
-+idldir = $(datadir)/idl
- idl_DATA = Rhythmbox.idl
-
- CLEAN_FILES = $(rhythmbox_interface_idl_sources)
diff --git a/audio/rhythmbox-devel/files/patch-lib_rb-tree-dnd.c b/audio/rhythmbox-devel/files/patch-lib_rb-tree-dnd.c
deleted file mode 100644
index 5ce40a753dd3..000000000000
--- a/audio/rhythmbox-devel/files/patch-lib_rb-tree-dnd.c
+++ /dev/null
@@ -1,26 +0,0 @@
---- lib/rb-tree-dnd.c.orig Tue Nov 11 20:58:54 2003
-+++ lib/rb-tree-dnd.c Tue Nov 11 20:59:17 2003
-@@ -710,9 +710,10 @@
- gint n_targets,
- GdkDragAction actions)
- {
-+ RbTreeDndData *priv_data;
- g_return_if_fail (GTK_IS_TREE_VIEW (tree_view));
-
-- RbTreeDndData *priv_data = init_rb_tree_dnd_data (GTK_WIDGET(tree_view));
-+ priv_data = init_rb_tree_dnd_data (GTK_WIDGET(tree_view));
-
- if (!priv_data->button_press_event_handler) {
-
-@@ -746,9 +747,10 @@
- gint n_targets,
- GdkDragAction actions)
- {
-+ RbTreeDndData *priv_data;
- g_return_if_fail (GTK_IS_TREE_VIEW (tree_view));
-
-- RbTreeDndData *priv_data = init_rb_tree_dnd_data (GTK_WIDGET(tree_view));
-+ priv_data = init_rb_tree_dnd_data (GTK_WIDGET(tree_view));
-
- if (!priv_data->drag_leave_handler) {
-
diff --git a/audio/rhythmbox-devel/pkg-descr b/audio/rhythmbox-devel/pkg-descr
deleted file mode 100644
index 39e0558c2ab3..000000000000
--- a/audio/rhythmbox-devel/pkg-descr
+++ /dev/null
@@ -1,5 +0,0 @@
-Rhythmbox is an integrated music management application, originally inspired by
-Apple's iTunes. It is free software, designed to work well under the GNOME
-Desktop, and based on the powerful GStreamer media framework.
-
-WWW: http://web.rhythmbox.org/
diff --git a/audio/rhythmbox-devel/pkg-plist b/audio/rhythmbox-devel/pkg-plist
deleted file mode 100644
index 7e263f181dbe..000000000000
--- a/audio/rhythmbox-devel/pkg-plist
+++ /dev/null
@@ -1,166 +0,0 @@
-bin/rhythmbox
-etc/gconf/gconf.xml.defaults/apps/rhythmbox/%gconf.xml
-etc/gconf/gconf.xml.defaults/apps/rhythmbox/state/%gconf.xml
-etc/gconf/gconf.xml.defaults/apps/rhythmbox/state/iradio/%gconf.xml
-etc/gconf/gconf.xml.defaults/apps/rhythmbox/state/library/%gconf.xml
-etc/gconf/gconf.xml.defaults/apps/rhythmbox/state/load_failure_dialog/%gconf.xml
-etc/gconf/gconf.xml.defaults/apps/rhythmbox/ui/%gconf.xml
-etc/gconf/gconf.xml.defaults/apps/rhythmbox/ui/library/%gconf.xml
-etc/gconf/gconf.xml.defaults/schemas/apps/rhythmbox/%gconf.xml
-etc/gconf/gconf.xml.defaults/schemas/apps/rhythmbox/state/%gconf.xml
-etc/gconf/gconf.xml.defaults/schemas/apps/rhythmbox/state/iradio/%gconf.xml
-etc/gconf/gconf.xml.defaults/schemas/apps/rhythmbox/state/library/%gconf.xml
-etc/gconf/gconf.xml.defaults/schemas/apps/rhythmbox/state/load_failure_dialog/%gconf.xml
-etc/gconf/gconf.xml.defaults/schemas/apps/rhythmbox/ui/%gconf.xml
-etc/gconf/gconf.xml.defaults/schemas/apps/rhythmbox/ui/library/%gconf.xml
-etc/gconf/schemas/rhythmbox.schemas
-lib/bonobo/librb-nautilus-context-menu.so
-libdata/bonobo/servers/GNOME_Rhythmbox.server
-libdata/bonobo/servers/Rhythmbox_Nautilus_Context_Menu.server
-libdata/pkgconfig/rhythmbox.pc
-share/gnome/application-registry/rhythmbox.applications
-share/gnome/applications/rhythmbox.desktop
-share/gnome/gnome-2.0/ui/rhythmbox-ui.xml
-share/gnome/help/rhythmbox/C/authors.xml
-share/gnome/help/rhythmbox/C/fdl-appendix.xml
-share/gnome/help/rhythmbox/C/figures/rb-adv.png
-share/gnome/help/rhythmbox/C/figures/rb-asst-finish.png
-share/gnome/help/rhythmbox/C/figures/rb-asst-library.png
-share/gnome/help/rhythmbox/C/figures/rb-asst-start.png
-share/gnome/help/rhythmbox/C/figures/rb-basic.png
-share/gnome/help/rhythmbox/C/figures/rb-browser.png
-share/gnome/help/rhythmbox/C/figures/rb-context-menu.png
-share/gnome/help/rhythmbox/C/figures/rb-empty.png
-share/gnome/help/rhythmbox/C/figures/rb-full-play.png
-share/gnome/help/rhythmbox/C/figures/rb-group-create.png
-share/gnome/help/rhythmbox/C/figures/rb-group.png
-share/gnome/help/rhythmbox/C/figures/rb-imported.png
-share/gnome/help/rhythmbox/C/figures/rb-iradio-add.png
-share/gnome/help/rhythmbox/C/figures/rb-iradio.png
-share/gnome/help/rhythmbox/C/figures/rb-nextprev.png
-share/gnome/help/rhythmbox/C/figures/rb-nobrowse-play.png
-share/gnome/help/rhythmbox/C/figures/rb-notification-area-menu.png
-share/gnome/help/rhythmbox/C/figures/rb-notification-area.png
-share/gnome/help/rhythmbox/C/figures/rb-player.png
-share/gnome/help/rhythmbox/C/figures/rb-prefs.png
-share/gnome/help/rhythmbox/C/figures/rb-repeat.png
-share/gnome/help/rhythmbox/C/figures/rb-search.png
-share/gnome/help/rhythmbox/C/figures/rb-shuffle.png
-share/gnome/help/rhythmbox/C/figures/rb-sidebar.png
-share/gnome/help/rhythmbox/C/figures/rb-stats.png
-share/gnome/help/rhythmbox/C/figures/rb-toolbar-editor.png
-share/gnome/help/rhythmbox/C/figures/rb-toolbar.png
-share/gnome/help/rhythmbox/C/figures/rb-volume-changer.png
-share/gnome/help/rhythmbox/C/figures/rb-volume-mute.png
-share/gnome/help/rhythmbox/C/figures/rb-window.png
-share/gnome/help/rhythmbox/C/figures/rhythmbox-group.png
-share/gnome/help/rhythmbox/C/figures/rhythmbox-tray-icon.png
-share/gnome/help/rhythmbox/C/legal.xml
-share/gnome/help/rhythmbox/C/quick-reference.xml
-share/gnome/help/rhythmbox/C/rhythmbox.xml
-share/gnome/help/rhythmbox/C/user-guide.xml
-share/gnome/idl/Rhythmbox.idl
-share/gnome/mime-info/rhythmbox.keys
-share/gnome/omf/rhythmbox/rhythmbox-C.omf
-@exec scrollkeeper-install -q %D/share/gnome/omf/rhythmbox/rhythmbox-C.omf 2>/dev/null || /usr/bin/true
-share/gnome/pixmaps/rhythmbox.png
-share/gnome/rhythmbox/art/about-logo.png
-share/gnome/rhythmbox/art/rhythmbox-album.png
-share/gnome/rhythmbox/art/rhythmbox-audiocd.png
-share/gnome/rhythmbox/art/rhythmbox-automatic-playlist.png
-share/gnome/rhythmbox/art/rhythmbox-dnd.png
-share/gnome/rhythmbox/art/rhythmbox-iradio.png
-share/gnome/rhythmbox/art/rhythmbox-library.png
-share/gnome/rhythmbox/art/rhythmbox-next.png
-share/gnome/rhythmbox/art/rhythmbox-no-star.png
-share/gnome/rhythmbox/art/rhythmbox-pause.png
-share/gnome/rhythmbox/art/rhythmbox-paused.png
-share/gnome/rhythmbox/art/rhythmbox-play.png
-share/gnome/rhythmbox/art/rhythmbox-playing.png
-share/gnome/rhythmbox/art/rhythmbox-playlist-menu.png
-share/gnome/rhythmbox/art/rhythmbox-playlist.png
-share/gnome/rhythmbox/art/rhythmbox-previous.png
-share/gnome/rhythmbox/art/rhythmbox-repeat.png
-share/gnome/rhythmbox/art/rhythmbox-rewind.png
-share/gnome/rhythmbox/art/rhythmbox-set-star.png
-share/gnome/rhythmbox/art/rhythmbox-shuffle.png
-share/gnome/rhythmbox/art/rhythmbox-stop.png
-share/gnome/rhythmbox/art/rhythmbox-tray-icon.png
-share/gnome/rhythmbox/art/rhythmbox-unset-star.png
-share/gnome/rhythmbox/art/rhythmbox-visuals.png
-share/gnome/rhythmbox/art/rhythmbox-volume-max.png
-share/gnome/rhythmbox/art/rhythmbox-volume-medium.png
-share/gnome/rhythmbox/art/rhythmbox-volume-min.png
-share/gnome/rhythmbox/art/rhythmbox-volume-mute.png
-share/gnome/rhythmbox/art/rhythmbox-volume-zero.png
-share/gnome/rhythmbox/glade/buffering-dialog.glade
-share/gnome/rhythmbox/glade/create-playlist.glade
-share/gnome/rhythmbox/glade/druid.glade
-share/gnome/rhythmbox/glade/general-prefs.glade
-share/gnome/rhythmbox/glade/library-prefs.glade
-share/gnome/rhythmbox/glade/load-failure.glade
-share/gnome/rhythmbox/glade/song-info.glade
-share/gnome/rhythmbox/glade/station-new.glade
-share/gnome/rhythmbox/glade/station-properties.glade
-share/gnome/rhythmbox/glade/uri.glade
-share/gnome/rhythmbox/iradio-initial.pls
-share/gnome/rhythmbox/node-views/rb-node-view-albums.xml
-share/gnome/rhythmbox/node-views/rb-node-view-artists.xml
-share/gnome/rhythmbox/node-views/rb-node-view-cdaudio.xml
-share/gnome/rhythmbox/node-views/rb-node-view-genres.xml
-share/gnome/rhythmbox/node-views/rb-node-view-iradio-genres.xml
-share/gnome/rhythmbox/node-views/rb-node-view-iradio-stations.xml
-share/gnome/rhythmbox/node-views/rb-node-view-songs.xml
-share/locale/am/LC_MESSAGES/rhythmbox.mo
-share/locale/az/LC_MESSAGES/rhythmbox.mo
-share/locale/be/LC_MESSAGES/rhythmbox.mo
-share/locale/cs/LC_MESSAGES/rhythmbox.mo
-share/locale/cy/LC_MESSAGES/rhythmbox.mo
-share/locale/da/LC_MESSAGES/rhythmbox.mo
-share/locale/de/LC_MESSAGES/rhythmbox.mo
-share/locale/el/LC_MESSAGES/rhythmbox.mo
-share/locale/es/LC_MESSAGES/rhythmbox.mo
-share/locale/fi/LC_MESSAGES/rhythmbox.mo
-share/locale/fr/LC_MESSAGES/rhythmbox.mo
-share/locale/id/LC_MESSAGES/rhythmbox.mo
-share/locale/it/LC_MESSAGES/rhythmbox.mo
-share/locale/ja/LC_MESSAGES/rhythmbox.mo
-share/locale/ko/LC_MESSAGES/rhythmbox.mo
-share/locale/lv/LC_MESSAGES/rhythmbox.mo
-share/locale/ms/LC_MESSAGES/rhythmbox.mo
-share/locale/nl/LC_MESSAGES/rhythmbox.mo
-share/locale/no/LC_MESSAGES/rhythmbox.mo
-share/locale/pl/LC_MESSAGES/rhythmbox.mo
-share/locale/pt/LC_MESSAGES/rhythmbox.mo
-share/locale/pt_BR/LC_MESSAGES/rhythmbox.mo
-share/locale/ro/LC_MESSAGES/rhythmbox.mo
-share/locale/ru/LC_MESSAGES/rhythmbox.mo
-share/locale/sr/LC_MESSAGES/rhythmbox.mo
-share/locale/sr@Latn/LC_MESSAGES/rhythmbox.mo
-share/locale/sv/LC_MESSAGES/rhythmbox.mo
-share/locale/tr/LC_MESSAGES/rhythmbox.mo
-share/locale/vi/LC_MESSAGES/rhythmbox.mo
-share/locale/zh_TW/LC_MESSAGES/rhythmbox.mo
-@dirrm share/gnome/rhythmbox/node-views
-@dirrm share/gnome/rhythmbox/glade
-@dirrm share/gnome/rhythmbox/art
-@dirrm share/gnome/rhythmbox
-@dirrm share/gnome/omf/rhythmbox
-@dirrm share/gnome/help/rhythmbox/C/figures
-@dirrm share/gnome/help/rhythmbox/C
-@dirrm share/gnome/help/rhythmbox
-@dirrm etc/gconf/gconf.xml.defaults/schemas/apps/rhythmbox/ui/library
-@dirrm etc/gconf/gconf.xml.defaults/schemas/apps/rhythmbox/ui
-@dirrm etc/gconf/gconf.xml.defaults/schemas/apps/rhythmbox/state/load_failure_dialog
-@dirrm etc/gconf/gconf.xml.defaults/schemas/apps/rhythmbox/state/library
-@dirrm etc/gconf/gconf.xml.defaults/schemas/apps/rhythmbox/state/iradio
-@dirrm etc/gconf/gconf.xml.defaults/schemas/apps/rhythmbox/state
-@dirrm etc/gconf/gconf.xml.defaults/schemas/apps/rhythmbox
-@dirrm etc/gconf/gconf.xml.defaults/apps/rhythmbox/ui/library
-@dirrm etc/gconf/gconf.xml.defaults/apps/rhythmbox/ui
-@dirrm etc/gconf/gconf.xml.defaults/apps/rhythmbox/state/load_failure_dialog
-@dirrm etc/gconf/gconf.xml.defaults/apps/rhythmbox/state/library
-@dirrm etc/gconf/gconf.xml.defaults/apps/rhythmbox/state/iradio
-@dirrm etc/gconf/gconf.xml.defaults/apps/rhythmbox/state
-@dirrm etc/gconf/gconf.xml.defaults/apps/rhythmbox
-@unexec scrollkeeper-uninstall -q %D/share/gnome/omf/rhythmbox/rhythmbox-C.omf 2>/dev/null || /usr/bin/true