aboutsummaryrefslogtreecommitdiff
path: root/audio/speak_freely/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'audio/speak_freely/Makefile')
-rw-r--r--audio/speak_freely/Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/audio/speak_freely/Makefile b/audio/speak_freely/Makefile
index 1d76a6cfed47..ecd1824f93ab 100644
--- a/audio/speak_freely/Makefile
+++ b/audio/speak_freely/Makefile
@@ -1,7 +1,7 @@
# New ports collection makefile for: speak_freely
-# Original WWW site: http://www.fourmilab.ch/speakfree/unix/index.html
# Version required: 7.1
# Date created: 18 Apr 1996
+# Whom: Mister X (to make portlint happy ;)
#
# $FreeBSD$
#
@@ -14,15 +14,17 @@ MAINTAINER= ports@FreeBSD.org
LIB_DEPENDS= gsm.1:${PORTSDIR}/audio/gsm
-UTILS= sfspeaker sfmike sflwl
-DEMNS= sfecho sflwld
+UTILS= sfspeaker sfmike sflwl sflaunch
+DEMNS= sfecho sflwld sfreflect
DDEMNS= sfvod
SFLIB= ${PREFIX}/lib/speak_freely
MAN1= ${UTILS:S/$/.1/} ${DEMNS:S/$/.1/} ${DDEMNS:S/$/.1/}
+MAKE_ENV="OPTFLAGS=${CFLAGS}"
+
do-install:
if [ ! -d ${SFLIB} ]; then \
- install -d -o ${BINOWN} -g ${BINGRP} -m 755 ${SFLIB}; \
+ ${INSTALL} -d -o ${BINOWN} -g ${BINGRP} -m 755 ${SFLIB}; \
fi
cd ${WRKSRC}; \
$(INSTALL_DATA) busy.au ring.au ${SFLIB}