aboutsummaryrefslogtreecommitdiff
path: root/audio/speak_freely
diff options
context:
space:
mode:
Diffstat (limited to 'audio/speak_freely')
-rw-r--r--audio/speak_freely/Makefile47
-rw-r--r--audio/speak_freely/distinfo1
-rw-r--r--audio/speak_freely/files/patch-aa116
-rw-r--r--audio/speak_freely/files/patch-ac69
-rw-r--r--audio/speak_freely/files/patch-ad11
-rw-r--r--audio/speak_freely/files/patch-ae12
-rw-r--r--audio/speak_freely/files/patch-af11
-rw-r--r--audio/speak_freely/files/patch-ag8
-rw-r--r--audio/speak_freely/files/patch-ah11
-rw-r--r--audio/speak_freely/pkg-comment1
-rw-r--r--audio/speak_freely/pkg-descr11
-rw-r--r--audio/speak_freely/pkg-plist11
12 files changed, 0 insertions, 309 deletions
diff --git a/audio/speak_freely/Makefile b/audio/speak_freely/Makefile
deleted file mode 100644
index 36059ba7f46d..000000000000
--- a/audio/speak_freely/Makefile
+++ /dev/null
@@ -1,47 +0,0 @@
-# New ports collection makefile for: speak_freely
-# Date created: 18 Apr 1996
-# Whom: Mister X (to make portlint happy ;)
-#
-# $FreeBSD$
-#
-
-PORTNAME= speak_freely
-PORTVERSION= 7.1
-CATEGORIES= mbone audio security
-MASTER_SITES= http://www.fourmilab.ch/speakfree/unix/
-
-MAINTAINER= ports@FreeBSD.org
-
-LIB_DEPENDS= gsm.1:${PORTSDIR}/audio/gsm
-
-UTILS= sfspeaker sfmike sflwl sflaunch
-DEMNS= sfecho sflwld sfreflect
-DDEMNS= sfvod
-SFLIB= ${PREFIX}/lib/speak_freely
-MAN1= ${UTILS:S/$/.1/} ${DEMNS:S/$/.1/} ${DDEMNS:S/$/.1/}
-
-MAKE_ENV= "OPTFLAGS=${CFLAGS}"
-
-do-install:
- if [ ! -d ${SFLIB} ]; then \
- ${INSTALL} -d -o ${BINOWN} -g ${BINGRP} -m 755 ${SFLIB}; \
- fi
- cd ${WRKSRC}; \
- $(INSTALL_DATA) busy.au ring.au ${SFLIB}
- cd ${WRKSRC}; \
- for p in ${UTILS}; do \
- $(INSTALL_PROGRAM) $$p ${PREFIX}/bin; \
- $(INSTALL_MAN) $$p.1 ${PREFIX}/man/man1; \
- done;
- cd ${WRKSRC}; \
- for p in ${DEMNS}; do \
- $(INSTALL_PROGRAM) $$p ${PREFIX}/sbin; \
- $(INSTALL_MAN) $$p.1 ${PREFIX}/man/man1; \
- done;
- cd ${WRKSRC}; \
- for p in ${DDEMNS}; do \
- $(INSTALL_SCRIPT) $$p ${PREFIX}/sbin; \
- $(INSTALL_MAN) $$p.1 ${PREFIX}/man/man1; \
- done;
-
-.include <bsd.port.mk>
diff --git a/audio/speak_freely/distinfo b/audio/speak_freely/distinfo
deleted file mode 100644
index 1e09161e5bf1..000000000000
--- a/audio/speak_freely/distinfo
+++ /dev/null
@@ -1 +0,0 @@
-MD5 (speak_freely-7.1.tar.gz) = f06e4115c7139f7e30ea57064b324558
diff --git a/audio/speak_freely/files/patch-aa b/audio/speak_freely/files/patch-aa
deleted file mode 100644
index 63bbf0206ecd..000000000000
--- a/audio/speak_freely/files/patch-aa
+++ /dev/null
@@ -1,116 +0,0 @@
---- Makefile.orig Sat Sep 18 18:29:44 1999
-+++ Makefile Wed Jan 5 20:23:52 2000
-@@ -3,7 +3,7 @@
-
- # Debugging options
-
--DEBUG = -g -DHEXDUMP
-+#DEBUG = -g -DHEXDUMP
- #DEBUG = -g -DHEXDUMP -DNOCRYPTO
- #DEBUG = -O
-
-@@ -38,9 +38,9 @@
- # functionality is working. Please see the detailed description
- # of the available flags which follows these declarations.
- #
--CCFLAGS = -DAUDIO_BLOCKING -DLINUX -DHALF_DUPLEX -DM_LITTLE_ENDIAN
--CC = gcc -O3 # for GNU's gcc compiler
--LFLAGS = -lncurses -lm
-+#CCFLAGS = -DAUDIO_BLOCKING -DLINUX -DHALF_DUPLEX -DM_LITTLE_ENDIAN
-+#CC = gcc -O3 # for GNU's gcc compiler
-+#LFLAGS = -lncurses -lm
- #
- # If the above LFLAGS doesn't work, try the one below.
- #LFLAGS = -lcurses -lm
-@@ -220,8 +220,8 @@
- # Depending on how your driver handles non-blocking I/O,
- # you may also have to add -DAUDIO_BLOCKING to the
- # CCFLAGS line.
--#CCFLAGS = -DM_LITTLE_ENDIAN
--#LFLAGS = -lcurses -ltermcap -lcompat -lm
-+CCFLAGS = -DM_LITTLE_ENDIAN -DHALF_DUPLEX
-+LFLAGS = -lcurses -ltermcap -lcompat -lm
-
- # Hewlett-Packard
- # (courtesy of Marc Kilian)
-@@ -269,7 +269,7 @@
-
- # Compiler flags
-
--CFLAGS = $(DEBUG) -Iadpcm -Ilpc -Igsm/inc -Imd5 -Iidea -Ilibdes -Iblowfish $(CARGS) $(DUPLEX) $(CCFLAGS) $(DOMAIN)
-+CFLAGS = $(OPTFLAGS) $(DEBUG) -Iadpcm -Ilpc -I$(LOCALBASE)/include -Iidea -Ilibdes -Iblowfish $(CARGS) $(DUPLEX) $(CCFLAGS) $(DOMAIN)
-
- PROGRAMS = sfspeaker sfmike sflaunch sflwld sflwl sfecho sfreflect sfvod
-
-@@ -278,12 +278,12 @@
- SPKROBJS = speaker.o codecs.o deskey.o g711.o rate.o rtpacket.o soundbyte.o ulaw.o usleep.o vatpkt.o vox.o audio_hp.o audio_sgi.o common.o
-
- sfspeaker: $(SPKROBJS) adpcmlib.o libblowfish.o lpclib.o lpc10lib.o gsmlib.o deslib.o md5lib.o idealib.o libdes.o xdsub.o
-- $(CC) $(SPKROBJS) adpcm/adpcm-u.o blowfish/libblowfish.a des/des.a md5/md5.o idea/idea.a lpc10/liblpc10.a gsm/lib/libgsm.a lpc/lpc.o xdsub.o libdes/libdes.a $(LFLAGS) -o sfspeaker
-+ $(CC) $(SPKROBJS) adpcm/adpcm-u.o blowfish/libblowfish.a des/des.a -lmd idea/idea.a lpc10/liblpc10.a -L/usr/local/lib -lgsm lpc/lpc.o xdsub.o libdes/libdes.a $(LFLAGS) -o sfspeaker
-
- MIKEOBJS = mike.o codecs.o deskey.o g711.o rate.o rtpacket.o soundbyte.o ulaw.o usleep.o vatpkt.o xdsub.o audio_hp.o audio_sgi.o
-
- sfmike: $(MIKEOBJS) adpcmlib.o libblowfish.o lpclib.o lpc10lib.o gsmlib.o deslib.o md5lib.o idealib.o libdes.o
-- $(CC) $(MIKEOBJS) adpcm/adpcm-u.o des/des.a md5/md5.o idea/idea.a -lm blowfish/libblowfish.a lpc10/liblpc10.a gsm/lib/libgsm.a lpc/lpc.o libdes/libdes.a $(LFLAGS) -o sfmike
-+ $(CC) $(MIKEOBJS) adpcm/adpcm-u.o des/des.a -lmd idea/idea.a -lm blowfish/libblowfish.a lpc10/liblpc10.a -L/usr/local/lib -lgsm lpc/lpc.o libdes/libdes.a $(LFLAGS) -o sfmike
-
- LAUNCHOBJS = launch.o soundbyte.o usleep.o g711.o
-
-@@ -303,12 +303,12 @@
- ECHOOBJS = echo.o codecs.o g711.o rtpacket.o ulaw.o xdsub.o
-
- sfecho: $(ECHOOBJS) md5lib.o
-- $(CC) $(ECHOOBJS) md5/md5.o adpcm/adpcm-u.o lpc/lpc.o $(LFLAGS) -o sfecho
-+ $(CC) $(ECHOOBJS) -lmd adpcm/adpcm-u.o lpc/lpc.o $(LFLAGS) -o sfecho
-
- REFLECTOBJS = reflect.o codecs.o html.o g711.o rtpacket.o ulaw.o xdsub.o
-
- sfreflect: $(REFLECTOBJS) md5lib.o
-- $(CC) $(REFLECTOBJS) md5/md5.o adpcm/adpcm-u.o lpc/lpc.o $(LFLAGS) -o sfreflect
-+ $(CC) $(REFLECTOBJS) -lmd adpcm/adpcm-u.o lpc/lpc.o $(LFLAGS) -o sfreflect
-
- # Configure the voice on demand server for the platform's
- # location of Perl and network constant definitions.
-@@ -337,7 +337,7 @@
- # in make not necessarily available on all platforms.
-
- adpcmlib.o:
-- ( echo "Building ADPCM library."; cd adpcm ; make CC="$(CC)" )
-+ ( echo "Building ADPCM library."; cd adpcm ; make CC="$(CC) $(CCFLAGS)" )
- echo "ADPCM" >adpcmlib.o
-
- deslib.o:
-@@ -349,11 +349,11 @@
- echo "BLOWFISH" >libblowfish.o
-
- libdes.o:
-- ( echo "Building LIBDES library."; cd libdes ; make -f Makefile.sf CC="$(CC) $(CCFLAGS) $(DEBUG)" )
-+ ( echo "Building LIBDES library."; cd libdes ; make -f Makefile.sf CC="$(CC) $(OPTFLAGS) $(CCFLAGS) $(DEBUG)" )
- echo "LIBDES" >libdes.o
-
- lpclib.o:
-- ( echo "Building LPC library."; cd lpc ; make CC="$(CC) $(CCFLAGS) $(DEBUG)" )
-+ ( echo "Building LPC library."; cd lpc ; make CC="$(CC) $(OPTFLAGS) $(CCFLAGS) $(DEBUG)" )
- echo "LPC" >lpclib.o
-
- lpc10lib.o:
-@@ -361,15 +361,15 @@
- echo "LPC" >lpc10lib.o
-
- gsmlib.o:
-- ( echo "Building GSM library."; cd gsm ; make CC="$(CC)" )
-+# ( echo "Building GSM library."; cd gsm ; make CC="$(CC) $(CCFLAGS)" )
- echo "GSM" >gsmlib.o
-
- md5lib.o:
-- ( echo "Building MD5 library."; cd md5 ; make CC="$(CC)" )
-+# ( echo "Building MD5 library."; cd md5 ; make CC="$(CC) $(CCFLAGS)" )
- echo "MD5" >md5lib.o
-
- idealib.o:
-- ( echo "Building IDEA library."; cd idea ; make CC="$(CC)" )
-+ ( echo "Building IDEA library."; cd idea ; make CC="$(CC) $(CCFLAGS)" )
- echo "IDEA" >idealib.o
-
- # Object file dependencies
diff --git a/audio/speak_freely/files/patch-ac b/audio/speak_freely/files/patch-ac
deleted file mode 100644
index 999b8335bb16..000000000000
--- a/audio/speak_freely/files/patch-ac
+++ /dev/null
@@ -1,69 +0,0 @@
---- mike.c.orig Tue Sep 14 08:27:51 1999
-+++ mike.c Fri Dec 31 15:29:10 1999
-@@ -132,8 +132,8 @@
- #endif /* UNIX420 */
-
- #ifdef UNIX5
--#include <termio.h>
--static struct termio old_term_params;
-+#include <termios.h>
-+static struct termios old_term_params;
- #endif /* UNIX5 */
-
- /* Set raw mode on terminal file. Basically, get the terminal into a
-@@ -152,16 +152,16 @@
- #endif /* UNIX420 */
-
- #ifdef UNIX5
-- struct termio term_params;
-+ struct termios term_params;
-
-- ioctl(fileno(stdin), TCGETA, &old_term_params);
-+ tcgetattr(fileno(stdin), &old_term_params);
- term_params = old_term_params;
- term_params.c_iflag &= ~(ICRNL|IXON|IXOFF); /* no cr translation */
- term_params.c_iflag &= ~(ISTRIP); /* no stripping of high order bit */
- term_params.c_oflag &= ~(OPOST); /* no output processing */
- term_params.c_lflag &= ~(ISIG|ICANON|ECHO); /* raw mode */
- term_params.c_cc[4] = 1; /* satisfy read after 1 char */
-- ioctl(fileno(stdin), TCSETAF, &term_params);
-+ tcsetattr(fileno(stdin), TCSAFLUSH, &term_params);
- #endif /* UNIX5 */
- /*printf("\n(raw)\n");*/
- }
-@@ -180,7 +180,7 @@
- #endif /* UNIX420 */
-
- #ifdef UNIX5
-- ioctl(fileno(stdin), TCSETAF, &old_term_params);
-+ tcsetattr(fileno(stdin), TCSAFLUSH, &old_term_params);
- #endif /* UNIX5 */
- /*printf("\n(cooked)\n");*/
- }
-@@ -1144,7 +1144,7 @@
- /* SENDFILE -- Send a file or, if the file name is NULL or a
- single period, send real-time sound input. */
-
--static int sendfile(f)
-+static int sfsendfile(f)
- char *f;
- {
- soundbuf netbuf;
-@@ -2306,7 +2306,7 @@
- return 1;
- }
- } else {
-- int ok = sendfile(op);
-+ int ok = sfsendfile(op);
- if (ok != 0)
- return ok;
- sentfile++;
-@@ -2318,7 +2318,7 @@
- usage();
- } else {
- if (sentfile == 0) {
-- return sendfile(NULL);
-+ return sfsendfile(NULL);
- }
- }
-
diff --git a/audio/speak_freely/files/patch-ad b/audio/speak_freely/files/patch-ad
deleted file mode 100644
index 9fcad35ba658..000000000000
--- a/audio/speak_freely/files/patch-ad
+++ /dev/null
@@ -1,11 +0,0 @@
---- adpcm/Makefile.orig Fri Dec 31 15:34:54 1999
-+++ adpcm/Makefile Fri Dec 31 15:35:09 1999
-@@ -1,7 +1,7 @@
- #
- # Makefile for adpcm and test programs
- # -------------------
--CFLAGS=-O -I..
-+CFLAGS+= -I..
- # May need this on a sun:
- #CFLAGS=-O -I/usr/demo/SOUND
-
diff --git a/audio/speak_freely/files/patch-ae b/audio/speak_freely/files/patch-ae
deleted file mode 100644
index 4af5b7701d04..000000000000
--- a/audio/speak_freely/files/patch-ae
+++ /dev/null
@@ -1,12 +0,0 @@
---- soundbyte.c.orig Fri Dec 31 15:36:07 1999
-+++ soundbyte.c Fri Dec 31 15:38:58 1999
-@@ -13,7 +13,9 @@
- #ifdef Solaris
- #include <sys/filio.h>
- #else
-+#ifndef __FreeBSD__
- #include <sys/dir.h>
-+#endif
- #include <sys/file.h>
- #endif
-
diff --git a/audio/speak_freely/files/patch-af b/audio/speak_freely/files/patch-af
deleted file mode 100644
index 8f99c43f7cd2..000000000000
--- a/audio/speak_freely/files/patch-af
+++ /dev/null
@@ -1,11 +0,0 @@
---- blowfish/Makefile.orig Wed Jan 5 20:12:14 2000
-+++ blowfish/Makefile Wed Jan 5 20:15:02 2000
-@@ -18,7 +18,7 @@
-
- MAKE=make -f Makefile
- CC=cc
--CFLAG= -O
-+CFLAG= $(OPTFLAGS)
-
- #CC=gcc
- #CFLAG= -O4 -funroll-loops -fomit-frame-pointer
diff --git a/audio/speak_freely/files/patch-ag b/audio/speak_freely/files/patch-ag
deleted file mode 100644
index 8de3e742784f..000000000000
--- a/audio/speak_freely/files/patch-ag
+++ /dev/null
@@ -1,8 +0,0 @@
---- des/Makefile.orig Wed Jan 5 20:20:30 2000
-+++ des/Makefile Wed Jan 5 20:20:44 2000
-@@ -1,4 +1,4 @@
--CFLAGS=-O
-+CFLAGS=$(OPTFLAGS)
-
- all: des.a
-
diff --git a/audio/speak_freely/files/patch-ah b/audio/speak_freely/files/patch-ah
deleted file mode 100644
index 48e6d2a4b513..000000000000
--- a/audio/speak_freely/files/patch-ah
+++ /dev/null
@@ -1,11 +0,0 @@
---- idea/Makefile.orig Wed Jan 5 20:20:55 2000
-+++ idea/Makefile Wed Jan 5 20:21:08 2000
-@@ -7,7 +7,7 @@
- # Compiler flags
-
- CC = cc
--CFLAGS = -O
-+CFLAGS = $(OPTFLAGS)
-
- all: idea.a
-
diff --git a/audio/speak_freely/pkg-comment b/audio/speak_freely/pkg-comment
deleted file mode 100644
index 131b6287c617..000000000000
--- a/audio/speak_freely/pkg-comment
+++ /dev/null
@@ -1 +0,0 @@
-Voice Communication Over Data Networks
diff --git a/audio/speak_freely/pkg-descr b/audio/speak_freely/pkg-descr
deleted file mode 100644
index 1361a82873e2..000000000000
--- a/audio/speak_freely/pkg-descr
+++ /dev/null
@@ -1,11 +0,0 @@
- Speak Freely allows users of a variety of Unix and Unix-
- like workstations equipped with audio hardware connected
- by a network to converse, using the audio input and output
- facilities of the workstation to digitise and later recon-
- struct the sound and the network to relay sound packets.
- Optional compression is provided, allowing conversations
- over relatively low-bandwidth Internet links as well as
- local area networks.
-
-WWW: http://www.speakfreely.org/
- http://www.fourmilab.ch/speakfree/unix/index.html
diff --git a/audio/speak_freely/pkg-plist b/audio/speak_freely/pkg-plist
deleted file mode 100644
index 39a54f5325c1..000000000000
--- a/audio/speak_freely/pkg-plist
+++ /dev/null
@@ -1,11 +0,0 @@
-bin/sfspeaker
-bin/sfmike
-bin/sflwl
-bin/sflaunch
-sbin/sfecho
-sbin/sflwld
-sbin/sfreflect
-sbin/sfvod
-lib/speak_freely/ring.au
-lib/speak_freely/busy.au
-@dirrm lib/speak_freely