aboutsummaryrefslogtreecommitdiff
path: root/audio/speex-devel
diff options
context:
space:
mode:
Diffstat (limited to 'audio/speex-devel')
-rw-r--r--audio/speex-devel/Makefile42
-rw-r--r--audio/speex-devel/distinfo2
-rw-r--r--audio/speex-devel/files/patch-configure10
-rw-r--r--audio/speex-devel/files/patch-libspeex::stack_alloc.h14
-rw-r--r--audio/speex-devel/files/patch-src::speexdec.c17
-rw-r--r--audio/speex-devel/pkg-descr8
-rw-r--r--audio/speex-devel/pkg-plist11
7 files changed, 0 insertions, 104 deletions
diff --git a/audio/speex-devel/Makefile b/audio/speex-devel/Makefile
deleted file mode 100644
index 894b40650b4d..000000000000
--- a/audio/speex-devel/Makefile
+++ /dev/null
@@ -1,42 +0,0 @@
-# ex:ts=8
-# Ports collection makefile for: Speex
-# Date created: Jul 30, 2002
-# Whom: ijliao
-#
-# $FreeBSD$
-#
-
-PORTNAME= speex
-PORTVERSION= 1.0.3
-PORTREVISION= 1
-PORTEPOCH= 1
-CATEGORIES= audio
-MASTER_SITES= http://www.speex.org/download/
-DISTNAME= ${PORTNAME}-${PORTVERSION:S/.r/rc/}
-
-MAINTAINER= jre@vineyard.net
-COMMENT= An open-source patent-free voice codec
-
-LIB_DEPENDS= ogg.5:${PORTSDIR}/audio/libogg
-
-USE_GETOPT_LONG= yes
-USE_REINPLACE= yes
-USE_LIBTOOL_VER= 13
-LIBTOOLFLAGS= --disable-ltlibs --release-ignore
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
-INSTALLS_SHLIB= yes
-
-MAN1= speexdec.1 speexenc.1
-
-CPPFLAGS= -I${LOCALBASE}/include
-LDFLAGS= -L${LOCALBASE}/lib
-
-post-patch:
- @${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} -e \
- 's|doc win32|win32|g ; \
- s|^mandir =.*$$|mandir = @mandir@|g'
- @${REINPLACE_CMD} -e 's| in -lgnugetopt||g ; \
- s|LIBS="-lgnugetopt|LIBS="|g' ${WRKSRC}/configure
-
-.include <bsd.port.mk>
diff --git a/audio/speex-devel/distinfo b/audio/speex-devel/distinfo
deleted file mode 100644
index 9e707216e396..000000000000
--- a/audio/speex-devel/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-MD5 (speex-1.0.3.tar.gz) = 9b16492ae39afbf72d8bb46b2f258476
-SIZE (speex-1.0.3.tar.gz) = 398002
diff --git a/audio/speex-devel/files/patch-configure b/audio/speex-devel/files/patch-configure
deleted file mode 100644
index 868364574624..000000000000
--- a/audio/speex-devel/files/patch-configure
+++ /dev/null
@@ -1,10 +0,0 @@
---- configure.orig Mon Jul 29 11:40:32 2002
-+++ configure Wed Jul 31 03:49:39 2002
-@@ -5287,6 +5287,7 @@
-
- # This can be used to rebuild libtool when needed
- LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
-+$ac_aux_dir/ltconfig $LIBTOOL_DEPS
-
- # Always use our own libtool.
- LIBTOOL='$(SHELL) $(top_builddir)/libtool'
diff --git a/audio/speex-devel/files/patch-libspeex::stack_alloc.h b/audio/speex-devel/files/patch-libspeex::stack_alloc.h
deleted file mode 100644
index 25883aab513f..000000000000
--- a/audio/speex-devel/files/patch-libspeex::stack_alloc.h
+++ /dev/null
@@ -1,14 +0,0 @@
-
-$FreeBSD$
-
---- libspeex/stack_alloc.h.orig Wed Jun 11 17:10:53 2003
-+++ libspeex/stack_alloc.h Wed Jun 11 17:11:12 2003
-@@ -48,7 +48,7 @@
- #else
-
- /*Aligns the stack to a 'size' boundary */
--#define ALIGN(stack, size) ((stack) += ((size) - (int)(stack)) & ((size) - 1))
-+#define ALIGN(stack, size) ((stack) += ((size) - (long)(stack)) & ((size) - 1))
-
- /* Allocates 'size' elements of type 'type' on the stack */
- #define PUSH(stack, size, type) (ALIGN((stack),sizeof(type)),(stack)+=((size)*sizeof(type)),(type*)((stack)-((size)*sizeof(type))))
diff --git a/audio/speex-devel/files/patch-src::speexdec.c b/audio/speex-devel/files/patch-src::speexdec.c
deleted file mode 100644
index 96a7c2c22841..000000000000
--- a/audio/speex-devel/files/patch-src::speexdec.c
+++ /dev/null
@@ -1,17 +0,0 @@
---- src/speexdec.c.orig Sun Jun 1 14:58:51 2003
-+++ src/speexdec.c Wed Jun 11 02:07:49 2003
-@@ -72,6 +72,14 @@
- ((buf[base+1]<<8)&0xff00)| \
- (buf[base]&0xff))
-
-+#if !defined(AFMT_S16_NE)
-+#if defined(BYTE_ORDER) && (BYTE_ORDER == BIG_ENDIAN)
-+#define AFMT_S16_NE AFMT_S16_BE
-+#else
-+#define AFMT_S16_NE AFMT_S16_LE
-+#endif
-+#endif
-+
- static void print_comments(char *comments, int length)
- {
- char *c=comments;
diff --git a/audio/speex-devel/pkg-descr b/audio/speex-devel/pkg-descr
deleted file mode 100644
index deda059aaa99..000000000000
--- a/audio/speex-devel/pkg-descr
+++ /dev/null
@@ -1,8 +0,0 @@
-The Speex is a patent-free, Open Source/Free Software voice codec.
-Unlike other codecs like MP3 and Ogg Vorbis, Speex is designed to
-compress voice at bitrates in the 2-45 kbps range. Possible
-applications include VoIP, internet audio streaming, archiving of
-speech data (e.g. voice mail), and audio books. In some sense, it is
-meant to be complementary to the Ogg Vorbis codec.
-
-WWW: http://www.speex.org/
diff --git a/audio/speex-devel/pkg-plist b/audio/speex-devel/pkg-plist
deleted file mode 100644
index 32b38b470ecd..000000000000
--- a/audio/speex-devel/pkg-plist
+++ /dev/null
@@ -1,11 +0,0 @@
-@comment $FreeBSD$
-bin/speexdec
-bin/speexenc
-include/speex.h
-include/speex_bits.h
-include/speex_callbacks.h
-include/speex_header.h
-include/speex_stereo.h
-lib/libspeex.a
-lib/libspeex.so
-lib/libspeex.so.2