aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
Diffstat (limited to 'audio')
-rw-r--r--audio/festival/Makefile10
-rw-r--r--audio/festival/pkg-descr2
-rw-r--r--audio/gnuspeechsa/Makefile1
-rw-r--r--audio/musescore/Makefile2
-rw-r--r--audio/vsound/Makefile2
-rw-r--r--audio/xmcd/Makefile3
6 files changed, 15 insertions, 5 deletions
diff --git a/audio/festival/Makefile b/audio/festival/Makefile
index 2494d0430a0c..450682db9b7c 100644
--- a/audio/festival/Makefile
+++ b/audio/festival/Makefile
@@ -7,6 +7,7 @@ CATEGORIES= audio accessibility
MASTER_SITES= FESTIVAL
DISTFILES= ${DISTNAME}-release.tar.gz \
speech_tools-${PORTVERSION}-release.tar.gz
+DIST_SUBDIR= festival
PATCHFILES= src_modules_diphone_diphone.h.diff?id=b58a836:debian \
src_modules_diphone_di_io.cc.diff?id=b58a836:debian \
@@ -24,12 +25,15 @@ PATCH_SITES= ftp://ftp.netbsd.org/pub/pkgsrc/current/pkgsrc/audio/festival/patch
MAINTAINER= mi@aldan.algebra.com
COMMENT= Multi-lingual speech synthesis system
+BROKEN_aarch64= XXX
+BROKEN_armv6= Fails to link: cc.mak: No such file or directory
+BROKEN_mips64= Fails to link: cc.mak: No such file or directory
+BROKEN_powerpc64= Does not build
+
OPTIONS_DEFINE= NAS ESD
OPTIONS_DEFAULT=NAS ESD
ESD_DESC= ${ESOUND_DESC}
-DIST_SUBDIR= festival
-
CXXFLAGS+= -DFTLIBDIR=${LOCALBASE}/share/festival/lib
CONFIGURE_WRKSRC= ${WRKDIR}/festival
USES= gmake
@@ -43,8 +47,6 @@ WRKSRC= ${WRKDIR}
SPT_PATCHES= include_ling__class_EST__FeatureFunctionPackage.h \
include_unix_EST__socket__unix.h
-BROKEN_powerpc64= Does not build
-
do-build:
.for d in speech_tools festival
${MAKE_CMD} -C ${WRKDIR}/$d ${MAKE_FLAGS} Makefile ${MAKE_ARGS}
diff --git a/audio/festival/pkg-descr b/audio/festival/pkg-descr
index f3ce17acd94b..2282e42663bd 100644
--- a/audio/festival/pkg-descr
+++ b/audio/festival/pkg-descr
@@ -15,6 +15,6 @@ manual.
If you need the OGI extensions, install ports/audio/festival+OGI instead.
-WWW: http://www.cstr.ed.ac.uk/projects/festival/
+WWW: http://www.cstr.ed.ac.uk/projects/festival/
Trevor Johnson
diff --git a/audio/gnuspeechsa/Makefile b/audio/gnuspeechsa/Makefile
index 05b72f9861f1..cea96b069ecf 100644
--- a/audio/gnuspeechsa/Makefile
+++ b/audio/gnuspeechsa/Makefile
@@ -13,6 +13,7 @@ LICENSE= GPLv3+
LICENSE_FILE= ${WRKSRC}/COPYING
BROKEN_FreeBSD_9= does not build
+BROKEN_aarch64= Does not build: the clang compiler does not support -march=native
BROKEN_powerpc64= Does not build
USES= cmake compiler:c++11-lib
diff --git a/audio/musescore/Makefile b/audio/musescore/Makefile
index c5595f4dcca7..4c40ea1c5f25 100644
--- a/audio/musescore/Makefile
+++ b/audio/musescore/Makefile
@@ -26,6 +26,8 @@ ALL_TARGET= lrelease manpages all
DATADIR= ${PREFIX}/share/mscore-${PORTVERSION:R}
+BROKEN_aarch64= Fails to compile: error: constant expression evaluates to -1
+
OPTIONS_DEFINE= ALSA JACK PORTAUDIO PULSEAUDIO
OPTIONS_DEFAULT= PORTAUDIO
diff --git a/audio/vsound/Makefile b/audio/vsound/Makefile
index aa24fe81a5cc..17872fad0d59 100644
--- a/audio/vsound/Makefile
+++ b/audio/vsound/Makefile
@@ -19,6 +19,8 @@ RUN_DEPENDS= sox:audio/sox
USES= alias libtool
GNU_CONFIGURE= yes
+BROKEN_aarch64= Fails to build: error: Cannot determine endian-ness of processor
+
OPTIONS_DEFINE= DOCS
post-install:
diff --git a/audio/xmcd/Makefile b/audio/xmcd/Makefile
index b9b61c5a3487..e5fa3a7cb284 100644
--- a/audio/xmcd/Makefile
+++ b/audio/xmcd/Makefile
@@ -22,6 +22,9 @@ PKGMESSAGE= ${WRKDIR}/pkg-message
LIBBINDIR= ${STAGEDIR}${PREFIX}/lib/X11/xmcd/bin-${OPSYS}_${OSREL:R:R}-${ARCH}
+BROKEN_aarch64= Fails to compile: many undefined symbols in xorg.cf
+BROKEN_armv6= Fails to compile: many undefined symbols in xorg.cf
+BROKEN_mips64= Fails to compile: many undefined symbols in xorg.cf
BROKEN_powerpc64= Does not build on powerpc64
pre-patch: