aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
Diffstat (limited to 'audio')
-rw-r--r--audio/mpegaudio/files/patch-ad13
-rw-r--r--audio/mpegaudio/files/patch-ae13
-rw-r--r--audio/mpegaudio/pkg-plist46
3 files changed, 45 insertions, 27 deletions
diff --git a/audio/mpegaudio/files/patch-ad b/audio/mpegaudio/files/patch-ad
index 399dfa79ebcf..c7484588e63e 100644
--- a/audio/mpegaudio/files/patch-ad
+++ b/audio/mpegaudio/files/patch-ad
@@ -1,5 +1,5 @@
---- musicin.c.orig Wed Jan 5 10:13:44 1994
-+++ musicin.c Tue Aug 22 02:40:40 2000
+--- musicin.c.orig Wed Jan 5 02:13:44 1994
++++ musicin.c Fri Dec 15 02:03:30 2006
@@ -101,6 +101,8 @@
#include "common.h"
#include "encoder.h"
@@ -123,3 +123,12 @@
if (*t == 'y' || *t == 'Y') exit(0);
}
+@@ -919,7 +921,7 @@
+ /*
+ /************************************************************************/
+
+-static void usage() /* print syntax & exit */
++void usage() /* print syntax & exit */
+ {
+ fprintf(stderr,
+ "usage: %s queries for all arguments, or\n",
diff --git a/audio/mpegaudio/files/patch-ae b/audio/mpegaudio/files/patch-ae
index d7dc9e57a4bd..ef1600a5eeb2 100644
--- a/audio/mpegaudio/files/patch-ae
+++ b/audio/mpegaudio/files/patch-ae
@@ -1,5 +1,5 @@
---- musicout.c.orig Wed Jan 5 13:39:27 1994
-+++ musicout.c Tue Aug 22 02:37:30 2000
+--- musicout.c.orig Wed Jan 5 05:39:27 1994
++++ musicout.c Fri Dec 15 02:04:31 2006
@@ -58,6 +58,8 @@
#include "common.h"
#include "decoder.h"
@@ -45,3 +45,12 @@
if (*t == 'y' || *t == 'Y') exit(0);
}
else { /* interpret CL Args */
+@@ -429,7 +431,7 @@
+ exit( 0 );
+ }
+
+-static void usage() /* print syntax & exit */
++void usage() /* print syntax & exit */
+ {
+ fprintf(stderr,
+ "usage: %s queries for all arguments, or\n",
diff --git a/audio/mpegaudio/pkg-plist b/audio/mpegaudio/pkg-plist
index e6d8e8877d92..470b91d986af 100644
--- a/audio/mpegaudio/pkg-plist
+++ b/audio/mpegaudio/pkg-plist
@@ -1,25 +1,25 @@
bin/mpeg_musicin
bin/mpeg_musicout
-share/mpegaudio/tables/1cb0
-share/mpegaudio/tables/1cb1
-share/mpegaudio/tables/1cb2
-share/mpegaudio/tables/1th0
-share/mpegaudio/tables/1th1
-share/mpegaudio/tables/1th2
-share/mpegaudio/tables/2cb0
-share/mpegaudio/tables/2cb1
-share/mpegaudio/tables/2cb2
-share/mpegaudio/tables/2th0
-share/mpegaudio/tables/2th1
-share/mpegaudio/tables/2th2
-share/mpegaudio/tables/absthr_0
-share/mpegaudio/tables/absthr_1
-share/mpegaudio/tables/absthr_2
-share/mpegaudio/tables/alloc_0
-share/mpegaudio/tables/alloc_1
-share/mpegaudio/tables/alloc_2
-share/mpegaudio/tables/alloc_3
-share/mpegaudio/tables/dewindow
-share/mpegaudio/tables/enwindow
-@dirrm share/mpegaudio/tables
-@dirrm share/mpegaudio
+%%DATADIR%%/tables/1cb0
+%%DATADIR%%/tables/1cb1
+%%DATADIR%%/tables/1cb2
+%%DATADIR%%/tables/1th0
+%%DATADIR%%/tables/1th1
+%%DATADIR%%/tables/1th2
+%%DATADIR%%/tables/2cb0
+%%DATADIR%%/tables/2cb1
+%%DATADIR%%/tables/2cb2
+%%DATADIR%%/tables/2th0
+%%DATADIR%%/tables/2th1
+%%DATADIR%%/tables/2th2
+%%DATADIR%%/tables/absthr_0
+%%DATADIR%%/tables/absthr_1
+%%DATADIR%%/tables/absthr_2
+%%DATADIR%%/tables/alloc_0
+%%DATADIR%%/tables/alloc_1
+%%DATADIR%%/tables/alloc_2
+%%DATADIR%%/tables/alloc_3
+%%DATADIR%%/tables/dewindow
+%%DATADIR%%/tables/enwindow
+@dirrm %%DATADIR%%/tables
+@dirrm %%DATADIR%%