aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
Diffstat (limited to 'audio')
-rw-r--r--audio/Makefile1
-rw-r--r--audio/audiotag/Makefile53
-rw-r--r--audio/audiotag/distinfo3
-rw-r--r--audio/audiotag/pkg-descr4
4 files changed, 61 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 8460847b5feb..181b2ef32c36 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -46,6 +46,7 @@
SUBDIR += audacious-mac
SUBDIR += audacity
SUBDIR += audacity-devel
+ SUBDIR += audiotag
SUBDIR += aumix
SUBDIR += aureal-kmod
SUBDIR += autocd
diff --git a/audio/audiotag/Makefile b/audio/audiotag/Makefile
new file mode 100644
index 000000000000..8f603b577459
--- /dev/null
+++ b/audio/audiotag/Makefile
@@ -0,0 +1,53 @@
+# New ports collection makefile for: audiotag
+# Date created: 2008-04-08
+# Whom: Bapt <baptiste.daroussin@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= audiotag
+PORTVERSION= 0.17
+CATEGORIES= audio multimedia
+MASTER_SITES= http://www.tempestgames.com/ryan/downloads/
+
+MAINTAINER= baptiste.daroussin@gmail.com
+COMMENT= A command-line tool for mass tagging/renaming of audio files
+
+OPTIONS= VORBIS "Support renaming/tagging ogg vorbis files" On \
+ ID3 "Support renaming/tagging files supporting id3 tags" On \
+ MP4 "Support renaming/tagging mp4 files" On
+
+USE_PERL5_RUN= yes
+
+NO_BUILD= yes
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_VORBIS)
+RUN_DEPENDS+= vorbiscomment:${PORTSDIR}/audio/vorbis-tools
+.endif
+.if defined(WITH_FLAC)
+RUN_DEPENDS+= flac:${PORTSDIR}/audio/flac
+.endif
+.if defined(WITH_ID3)
+RUN_DEPENDS+= id3tag:${PORTSDIR}/audio/id3lib
+.endif
+.if defined(WITH_MP4)
+RUN_DEPENDS+= AtomicParsley:${PORTSDIR}/multimedia/AtomicParsley
+.endif
+
+PORTDOCS= COPYING ChangeLog README
+PLIST_FILES= bin/audiotag
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/audiotag ${PREFIX}/bin
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for f in ${PORTDOCS}
+ @${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/audio/audiotag/distinfo b/audio/audiotag/distinfo
new file mode 100644
index 000000000000..7b406bc55851
--- /dev/null
+++ b/audio/audiotag/distinfo
@@ -0,0 +1,3 @@
+MD5 (audiotag-0.17.tar.gz) = d6de6792e04c4d9ac44bdeca3fdcdd7e
+SHA256 (audiotag-0.17.tar.gz) = 11c90d05006eea5f3e56c4dabe1becd0da50faf9b4fb87fabf139785001add5c
+SIZE (audiotag-0.17.tar.gz) = 15161
diff --git a/audio/audiotag/pkg-descr b/audio/audiotag/pkg-descr
new file mode 100644
index 000000000000..8ae1f452790b
--- /dev/null
+++ b/audio/audiotag/pkg-descr
@@ -0,0 +1,4 @@
+Audiotag is a command-line tool for mass tagging/renaming of audio files
+it supports the vorbis comment, id3 tags, and MP4 tags.
+
+WWW: http://www.tempestgames.com/ryan/