aboutsummaryrefslogtreecommitdiff
path: root/base/gcc6/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'base/gcc6/Makefile')
-rw-r--r--base/gcc6/Makefile7
1 files changed, 2 insertions, 5 deletions
diff --git a/base/gcc6/Makefile b/base/gcc6/Makefile
index 2e26c3a62976..05b0bfc6f833 100644
--- a/base/gcc6/Makefile
+++ b/base/gcc6/Makefile
@@ -49,17 +49,14 @@ CONFIGURE_ARGS+= \
--with-gxx-include-dir=/usr/include/c++/v1/ \
--with-sysroot="/" \
--with-build-sysroot=${CROSS_SYSROOT} \
- -with-pkgversion="GNU Collection for FreeBSD"
+ -with-pkgversion="GNU Collection for FreeBSD" \
+ --enable-initfini-array
ALL_TARGET?= all-gcc
INSTALL_TARGET?= install-gcc
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 1200000
-CONFIGURE_ARGS+= --enable-initfini-array
-.endif
-
.if ${HOSTARCH} == "amd64"
CONFIGURE_TARGET= x86_64-unknown-${OPSYS:tl}${OSREL}
.else