aboutsummaryrefslogtreecommitdiff
path: root/benchmarks
diff options
context:
space:
mode:
Diffstat (limited to 'benchmarks')
-rw-r--r--benchmarks/forkbomb/Makefile3
-rw-r--r--benchmarks/gtkperf/Makefile4
-rw-r--r--benchmarks/iozone/Makefile2
-rw-r--r--benchmarks/iperf/Makefile2
-rw-r--r--benchmarks/polygraph/Makefile2
-rw-r--r--benchmarks/polygraph31/Makefile2
-rw-r--r--benchmarks/postal/Makefile1
-rw-r--r--benchmarks/sipp/Makefile4
-rw-r--r--benchmarks/webbench/Makefile1
9 files changed, 8 insertions, 13 deletions
diff --git a/benchmarks/forkbomb/Makefile b/benchmarks/forkbomb/Makefile
index 6e956de468d6..7d60cd05a914 100644
--- a/benchmarks/forkbomb/Makefile
+++ b/benchmarks/forkbomb/Makefile
@@ -15,9 +15,6 @@ MASTER_SITE_SUBDIR= system/benchmark
MAINTAINER= ports@FreeBSD.org
COMMENT= System stress testing tool
-MAKE_ENV+= CPPFLAGS="${CPPFLAGS}" \
- LDFLAGS="${LDFLAGS}"
-
MAN8= forkbomb.8
PLIST_FILES= sbin/forkbomb
diff --git a/benchmarks/gtkperf/Makefile b/benchmarks/gtkperf/Makefile
index ffd773c5a1b4..29a776c839b5 100644
--- a/benchmarks/gtkperf/Makefile
+++ b/benchmarks/gtkperf/Makefile
@@ -23,8 +23,8 @@ USE_GNOME= gtk20 gnomeprefix
.if !defined(WITHOUT_NLS)
USE_GETTEXT= yes
USE_ICONV= yes
-CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS+= --enable-nls
PLIST_SUB= NLS=""
.else
diff --git a/benchmarks/iozone/Makefile b/benchmarks/iozone/Makefile
index aee53c1cb235..72fde403861f 100644
--- a/benchmarks/iozone/Makefile
+++ b/benchmarks/iozone/Makefile
@@ -34,7 +34,7 @@ OPTIONS= THREADS "Enable threading (uses pthreads)" on \
.if defined (WITH_THREADS)
CFLAGS+= ${PTHREAD_CFLAGS}
-MAKE_ENV= LDFLAGS=${PTHREAD_LIBS}
+LDFLAGS+= ${PTHREAD_LIBS}
.else
CFLAGS+=-DNO_THREADS
.endif
diff --git a/benchmarks/iperf/Makefile b/benchmarks/iperf/Makefile
index de7215bd9ca5..00a9795cee6c 100644
--- a/benchmarks/iperf/Makefile
+++ b/benchmarks/iperf/Makefile
@@ -32,7 +32,7 @@ CONFIGURE_ARGS+= --disable-ipv6
.if defined(WITHOUT_THREADS)
CONFIGURE_ARGS+= --disable-threads
.else
-CONFIGURE_ENV+= CFLAGS+=${PTHREAD_LIBS}
+CFLAGS+= ${PTHREAD_LIBS}
.endif
post-install:
diff --git a/benchmarks/polygraph/Makefile b/benchmarks/polygraph/Makefile
index 44adb235b06c..e3e318255ea3 100644
--- a/benchmarks/polygraph/Makefile
+++ b/benchmarks/polygraph/Makefile
@@ -18,7 +18,7 @@ MAINTAINER= as@bsdgroup.de
COMMENT= A benchmarking tool for Web proxies
GNU_CONFIGURE= YES
-CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS} -Wno-deprecated"
+CPPFLAGS+= -Wno-deprecated
CONFIGURE_ARGS+=--datadir=${DATADIR}
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
diff --git a/benchmarks/polygraph31/Makefile b/benchmarks/polygraph31/Makefile
index e1263f8b1637..e50dbe89ec26 100644
--- a/benchmarks/polygraph31/Makefile
+++ b/benchmarks/polygraph31/Makefile
@@ -17,7 +17,7 @@ MAINTAINER= adrian@FreeBSD.org
COMMENT= A benchmarking tool for Web proxies
GNU_CONFIGURE= YES
-CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS} -Wno-deprecated"
+CPPFLAGS+= -Wno-deprecated
CONFIGURE_ARGS+=--datadir=${DATADIR}
WRKSRC= ${WRKDIR}/${PORTNAME:S/31//}-${PORTVERSION}
diff --git a/benchmarks/postal/Makefile b/benchmarks/postal/Makefile
index da69452a0941..55264b56a87e 100644
--- a/benchmarks/postal/Makefile
+++ b/benchmarks/postal/Makefile
@@ -39,6 +39,5 @@ CONFIGURE_ARGS+= --disable-openssl
CFLAGS+= ${PTHREAD_CFLAGS}
LDFLAGS+= ${PTHREAD_LIBS}
-CONFIGURE_ENV+= LDFLAGS="${LDFLAGS}"
.include <bsd.port.post.mk>
diff --git a/benchmarks/sipp/Makefile b/benchmarks/sipp/Makefile
index 3d4b8de7fd09..12c7c8eb8a24 100644
--- a/benchmarks/sipp/Makefile
+++ b/benchmarks/sipp/Makefile
@@ -22,8 +22,8 @@ MAN1= sipp.1
USE_GMAKE= yes
CPP= ${CXX}
-MAKE_ENV+= CPPFLAGS="${CXXFLAGS}" \
- CCLINK="${CXX}"
+MAKE_ENV+= CCLINK="${CXX}"
+CPPFLAGS+= ${CXXFLAGS}
WRKSRC= ${WRKDIR}/sipp.svn
OPTIONS= OPENSSL "OpenSSL support (for digest auth and SIP over TLS)" on \
diff --git a/benchmarks/webbench/Makefile b/benchmarks/webbench/Makefile
index e3d16250cc1e..8fc6154cabc1 100644
--- a/benchmarks/webbench/Makefile
+++ b/benchmarks/webbench/Makefile
@@ -14,7 +14,6 @@ MASTER_SITE_SUBDIR= apps/www/servers
MAINTAINER= ports@FreeBSD.org
COMMENT= Simple forking web benchmark
-MAKE_ENV+= LDFLAGS="${LDFLAGS}"
MAKE_ARGS+= CFLAGS="${CPPFLAGS} ${CFLAGS}"
.if !defined(NO_INSTALL_MANPAGES)