aboutsummaryrefslogtreecommitdiff
path: root/benchmarks
diff options
context:
space:
mode:
Diffstat (limited to 'benchmarks')
-rw-r--r--benchmarks/sipp/Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/benchmarks/sipp/Makefile b/benchmarks/sipp/Makefile
index 50d86e9a5174..6b3e5dab38b2 100644
--- a/benchmarks/sipp/Makefile
+++ b/benchmarks/sipp/Makefile
@@ -22,14 +22,16 @@ MAKE_ENV+= CPP="${CXX}" CPPFLAGS="${CXXFLAGS}" CCLINK="${CXX}"
.include <bsd.port.pre.mk>
-.if ${ARCH} == "ia64"
-BROKEN= Does not compile - patch needed by someone who can test it
-.endif
-
.if !defined(WITHOUT_DIGEST_AUTH)
ALL_TARGET=ossl
.endif
+post-patch:
+.if ${ARCH} == "ia64"
+ @${REINPLACE_CMD} -e 's/^\(MFLAGS_ia64=\)\+DD64$$/\1/' \
+ ${WRKSRC}/Makefile
+.endif
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
${INSTALL_MAN} ${FILESDIR}/sipp.1 ${PREFIX}/man/man1