aboutsummaryrefslogtreecommitdiff
path: root/biology/recombine/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'biology/recombine/Makefile')
-rw-r--r--biology/recombine/Makefile16
1 files changed, 7 insertions, 9 deletions
diff --git a/biology/recombine/Makefile b/biology/recombine/Makefile
index aeb27c53d208..7889cad023b0 100644
--- a/biology/recombine/Makefile
+++ b/biology/recombine/Makefile
@@ -10,26 +10,24 @@ DISTNAME= ${PORTNAME}${PORTVERSION}.src.doc
MAINTAINER= ports@FreeBSD.org
COMMENT= Program to fit population models across sites
+USES= shebangfix
+
WRKSRC= ${WRKDIR}/${PORTNAME}${PORTVERSION}
ALL_TARGET= ${PORTNAME}
PLIST_FILES+= bin/filetran bin/recombine
PORTDOCS= recombine.txt
+SHEBANG_FILES= filetran
OPTIONS_DEFINE= DOCS
-NO_STAGE= yes
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/
- ${INSTALL_SCRIPT} ${WRKSRC}/filetran ${PREFIX}/bin/
-
-.include <bsd.port.options.mk>
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/filetran ${STAGEDIR}${PREFIX}/bin
post-install:
-.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/recombine.txt ${DOCSDIR}/
-.endif
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/recombine.txt ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>