aboutsummaryrefslogtreecommitdiff
path: root/cad/astk-serveur/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'cad/astk-serveur/Makefile')
-rw-r--r--cad/astk-serveur/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/cad/astk-serveur/Makefile b/cad/astk-serveur/Makefile
index 0cebc043add1..b5c91eeb81fb 100644
--- a/cad/astk-serveur/Makefile
+++ b/cad/astk-serveur/Makefile
@@ -108,9 +108,9 @@ SHIA= zsh
SHIADEP= ${SHIA}
.if !defined(WITH_ED)
-. if exists(${X11BASE}/bin/nedit)
+. if exists(${LOCALBASE}/bin/nedit)
WITH_ED= nedit
-RUN_DEPENDS+= ${X11BASE}/bin/nedit:${PORTSDIR}/editors/nedit
+RUN_DEPENDS+= ${LOCALBASE}/bin/nedit:${PORTSDIR}/editors/nedit
. elif exists(${LOCALBASE}/bin/gvim)
WITH_ED= gvim
RUN_DEPENDS+= ${LOCALBASE}/bin/gvim:${PORTSDIR}/editors/vim
@@ -125,10 +125,10 @@ WITH_ED= gedit
RUN_DEPENDS+= ${LOCALBASE}/bin/gedit:${PORTSDIR}/editors/gedit
. elif exists(${LOCALBASE}/bin/kwrite)
WITH_ED= kwrite
-RUN_DEPENDS+= ${X11BASE}/bin/kwrite:${PORTSDIR}/x11/kdebase3
+RUN_DEPENDS+= ${LOCALBASE}/bin/kwrite:${PORTSDIR}/x11/kdebase3
. elif exists(${LOCALBASE}/bin/xedit)
WITH_ED= xedit
-RUN_DEPENDS+= ${X11BASE}/bin/xedit:${PORTSDIR}/x11/xedit
+RUN_DEPENDS+= ${LOCALBASE}/bin/xedit:${PORTSDIR}/x11/xedit
. else
WITH_ED= vi
. endif
@@ -206,12 +206,12 @@ do-configure:
-e "s#?vaster?#${vaster}#" \
-e "s#?TOOLS_DIR?#${tools_dir}#" ${conf_dir}/outils
${REINPLACE_CMD} -e "s#?HOME_ASTK?#${inst_dir}#" \
- -e "s#?XTERM?#${X11BASE}/bin/xterm#" \
+ -e "s#?XTERM?#${LOCALBASE}/bin/xterm#" \
-e "s#?FULL_SERVER_NAME?#${SERVER_NAME}#" \
-e "s#?SERVER_NAME?#${HOST_NAME}#" \
-e "s#?ASTER_ROOT?#${PREFIX}/aster#" \
-e "s#?EDITOR?#${WITH_ED}#" ${conf_dir}/config_serveurs
- ${REINPLACE_CMD} -e "s#?XTERM?#${X11BASE}/bin/xterm#" \
+ ${REINPLACE_CMD} -e "s#?XTERM?#${LOCALBASE}/bin/xterm#" \
-e "s#?ASTER_VERSION?#${ASTER_VER}#" \
-e "s#langue : ENG#langue : ${ASTK_LANG}#" \
-e "s#?DOMAIN_NAME?#${DOMAIN_NAME}#" \