aboutsummaryrefslogtreecommitdiff
path: root/cad/graywolf/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'cad/graywolf/Makefile')
-rw-r--r--cad/graywolf/Makefile18
1 files changed, 12 insertions, 6 deletions
diff --git a/cad/graywolf/Makefile b/cad/graywolf/Makefile
index 222f1c0fe06b..82d90db7d75d 100644
--- a/cad/graywolf/Makefile
+++ b/cad/graywolf/Makefile
@@ -1,9 +1,8 @@
# $FreeBSD$
PORTNAME= graywolf
-DISTVERSION= 0.1.6-3
-DISTVERSIONSUFFIX= -g6c5e24f
-PORTREVISION= 1
+DISTVERSION= 0.1.6-4
+DISTVERSIONSUFFIX= -gf47937b
CATEGORIES= cad
PATCH_SITES= https://github.com/${GH_ACCOUNT}/${PORTNAME}/commit/
@@ -17,15 +16,22 @@ LICENSE= GPLv2
BROKEN_aarch64= Fails to link: missing sbrk
LIB_DEPENDS= libgsl.so:math/gsl
+TEST_DEPENDS= bash:shells/bash \
+ rsync:net/rsync
-USES= cmake compiler:c11 pkgconfig xorg
-USE_GITHUB= yes
-GH_ACCOUNT= rubund
+USES= cmake compiler:c11 pkgconfig shebangfix xorg
USE_XORG= ice sm x11 xext
USE_LDCONFIG= yes
+USE_GITHUB= yes
+GH_ACCOUNT= rubund
+
+SHEBANG_GLOB= *.sh
+
USE_GCC= any # lots of obviously incorrect C where clang fails, which gcc nevertheless magically finds a way to compile
CFLAGS+= -fcommon
+TEST_TARGET= test # most tests crash
+
.include <bsd.port.mk>