aboutsummaryrefslogtreecommitdiff
path: root/cad/scv/files/patch-scripts-copyExamples.sh
diff options
context:
space:
mode:
Diffstat (limited to 'cad/scv/files/patch-scripts-copyExamples.sh')
-rw-r--r--cad/scv/files/patch-scripts-copyExamples.sh26
1 files changed, 26 insertions, 0 deletions
diff --git a/cad/scv/files/patch-scripts-copyExamples.sh b/cad/scv/files/patch-scripts-copyExamples.sh
new file mode 100644
index 000000000000..8d80aeecfa30
--- /dev/null
+++ b/cad/scv/files/patch-scripts-copyExamples.sh
@@ -0,0 +1,26 @@
+--- scripts/copyExamples.sh.orig Thu Aug 7 08:38:02 2003
++++ scripts/copyExamples.sh Sat Dec 16 14:51:22 2006
+@@ -1,4 +1,4 @@
+-#!/bin/sh -h
++#!/bin/sh
+
+ # copyExamples.sh <srcdir> <dstdir>
+
+@@ -37,15 +37,13 @@
+ for f in *[chp] *.v* *.tcl README; do
+ if test -r $f; then
+ rm -f $dstdir/$f
+- cp $f $dstdir
+- chmod u+w $dstdir/$f
++ install -m 644 $f $dstdir
+ fi
+ done
+ # only copy Makefile in leaf dirs
+ if test -r Makefile -a $isleaf = "yes"; then
+ rm -f $dstdir/Makefile
+- cp Makefile $dstdir
+- chmod u+w $dstdir/Makefile
++ install -m 644 Makefile $dstdir
+ fi
+
+ fi