aboutsummaryrefslogtreecommitdiff
path: root/chinese/fcitx5-chinese-addons/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'chinese/fcitx5-chinese-addons/Makefile')
-rw-r--r--chinese/fcitx5-chinese-addons/Makefile25
1 files changed, 12 insertions, 13 deletions
diff --git a/chinese/fcitx5-chinese-addons/Makefile b/chinese/fcitx5-chinese-addons/Makefile
index b6511569efaa..886836647e51 100644
--- a/chinese/fcitx5-chinese-addons/Makefile
+++ b/chinese/fcitx5-chinese-addons/Makefile
@@ -1,9 +1,10 @@
PORTNAME= fcitx5-chinese-addons
-DISTVERSION= 5.0.8
-PORTREVISION= 4
+DISTVERSION= 5.0.17
CATEGORIES= chinese textproc
-MASTER_SITES= https://download.fcitx-im.org/data/:py_stroke,py_table
-DISTFILES= ${PY_STROKE_TAR}:py_stroke \
+MASTER_SITES= https://download.fcitx-im.org/fcitx5/${PORTNAME}/ \
+ https://download.fcitx-im.org/data/:py_stroke,py_table
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
+ ${PY_STROKE_TAR}:py_stroke \
${PY_TABLE_TAR}:py_table
DIST_SUBDIR= ${PORTNAME}
@@ -15,15 +16,16 @@ LICENSE= LGPL21+
LICENSE_FILE= ${WRKSRC}/LICENSES/LGPL-2.1-or-later.txt
BUILD_DEPENDS= fcitx5-lua>0:textproc/fcitx5-lua
-LIB_DEPENDS= libcurl.so:ftp/curl \
+LIB_DEPENDS= libboost_iostreams.so:devel/boost-libs \
+ libcurl.so:ftp/curl \
+ libFcitx5Core.so:textproc/fcitx5 \
libfmt.so:devel/libfmt \
- libopencc.so:chinese/opencc \
- libboost_iostreams.so:devel/boost-libs \
libIMEPinyin.so:chinese/libime \
- libFcitx5Core.so:textproc/fcitx5
+ libopencc.so:chinese/opencc
RUN_DEPENDS= fcitx5-lua>0:textproc/fcitx5-lua
-USES= compiler:c++17-lang gettext cmake kde:5 localbase pkgconfig
+USES= cmake compiler:c++17-lang gettext kde:5 localbase pkgconfig \
+ tar:xz
OPTIONS_DEFINE= GUI
OPTIONS_DEFAULT= GUI
@@ -32,13 +34,10 @@ USE_LDCONFIG= yes
GUI_DESC= Configuration GUI
GUI_USES= qt:5
-GUI_USE= qt=dbus,concurrent,webkit,buildtools:build,qmake:build
+GUI_USE= qt=concurrent,dbus,webkit,buildtools:build,qmake:build
GUI_LIB_DEPENDS= libFcitx5Qt5DBusAddons.so:textproc/fcitx5-qt
GUI_CMAKE_ON= -DUSE_WEBKIT:BOOL=true
-USE_GITHUB= yes
-GH_ACCOUNT= fcitx
-
USE_KDE= ecm
CMAKE_ON= ENABLE_OPENCC