aboutsummaryrefslogtreecommitdiff
path: root/chinese
diff options
context:
space:
mode:
Diffstat (limited to 'chinese')
-rw-r--r--chinese/Makefile1
-rw-r--r--chinese/fireflyttf/Makefile42
-rw-r--r--chinese/fireflyttf/distinfo2
-rw-r--r--chinese/fireflyttf/files/local.conf-sung47
-rw-r--r--chinese/fireflyttf/pkg-descr4
-rw-r--r--chinese/fireflyttf/pkg-plist10
-rw-r--r--chinese/opendesktop-fonts/Makefile42
-rw-r--r--chinese/opendesktop-fonts/distinfo2
-rw-r--r--chinese/opendesktop-fonts/files/local.conf-sung47
-rw-r--r--chinese/opendesktop-fonts/pkg-descr4
-rw-r--r--chinese/opendesktop-fonts/pkg-plist10
11 files changed, 211 insertions, 0 deletions
diff --git a/chinese/Makefile b/chinese/Makefile
index a79e2b9d3d02..a8f301403bc2 100644
--- a/chinese/Makefile
+++ b/chinese/Makefile
@@ -40,6 +40,7 @@
SUBDIR += eterm
SUBDIR += fcitx
SUBDIR += firebird
+ SUBDIR += fireflyttf
SUBDIR += fortunetw
SUBDIR += gb2jis
SUBDIR += gb2ps
diff --git a/chinese/fireflyttf/Makefile b/chinese/fireflyttf/Makefile
new file mode 100644
index 000000000000..c04919190a81
--- /dev/null
+++ b/chinese/fireflyttf/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: firefly TrueType Font
+# Date created: 2 Sep 2004
+# Whom: Shen Chuan-Hsing <statue@freebsd.sinica.edu.tw>
+#
+# $FreeBSD$
+#
+
+PORTNAME= fireflyttf
+PORTVERSION= 1.1.0
+CATEGORIES= chinese x11-fonts
+MASTER_SITES= http://www.study-area.org/apt/firefly-font/
+DISTNAME= fireflysung.ttf
+EXTRACT_SUFX= .gz
+
+MAINTAINER= statue@freebsd.sinica.edu.tw
+COMMENT= Firefly TrueType Font is combine of two arphic sung fonts
+
+BUILD_DEPENDS= fc-cache:${PORTSDIR}/x11-fonts/fontconfig \
+ ttfm.sh:${PORTSDIR}/chinese/ttfm
+RUN_DEPENDS= fc-cache:${PORTSDIR}/x11-fonts/fontconfig \
+ ttfm.sh:${PORTSDIR}/chinese/ttfm
+
+NO_BUILD= yes
+WRKSRC= ${WRKDIR}
+USE_XLIB= yes
+FONTDIR= ${PREFIX}/share/fonts/TrueType
+XFONTDIR= ${X11BASE}/lib/X11/fonts/TrueType
+EXTRACT_AFTER_ARGS= > ${DISTNAME}
+
+.include <bsd.port.pre.mk>
+
+do-install:
+ @${MKDIR} ${FONTDIR}
+ @${INSTALL_DATA} ${WRKSRC}/${DISTNAME} ${FONTDIR}
+ @${ECHO_MSG} "===> Running ttfm.sh"
+ -@${PREFIX}/bin/ttfm.sh --add xttfm ${DISTNAME}
+ @${ECHO_MSG} "===> Running fc-cache"
+ -@${X11BASE}/bin/fc-cache -f -v ${XFONTDIR}
+ ${INSTALL_DATA} ${FILESDIR}/local.conf-sung ${FONTDIR}
+ ${INSTALL_DATA} ${FILESDIR}/local.conf-sung ${X11BASE}/etc/fonts/local.conf
+
+.include <bsd.port.post.mk>
diff --git a/chinese/fireflyttf/distinfo b/chinese/fireflyttf/distinfo
new file mode 100644
index 000000000000..0423507da02c
--- /dev/null
+++ b/chinese/fireflyttf/distinfo
@@ -0,0 +1,2 @@
+MD5 (fireflysung.ttf.gz) = 7b443608f2024567d631ab831b26f6a5
+SIZE (fireflysung.ttf.gz) = 7529763
diff --git a/chinese/fireflyttf/files/local.conf-sung b/chinese/fireflyttf/files/local.conf-sung
new file mode 100644
index 000000000000..38597782af3f
--- /dev/null
+++ b/chinese/fireflyttf/files/local.conf-sung
@@ -0,0 +1,47 @@
+<?xml version="1.0"?>
+<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
+<fontconfig>
+ <!-- Firefly Truetype Font -->
+ <match target="font">
+ <test name="family"><string>AR PL New Sung</string></test>
+ <edit name="antialias"><bool>true</bool></edit>
+ <edit name="hinting"><bool>true</bool></edit>
+ <edit name="autohint"><bool>false</bool></edit>
+ </match>
+
+ <match target="font">
+ <test name="family"><string>AR PL New Sung</string></test>
+ <test name="size" compare="less_eq"><int>16</int></test>
+ <edit name="antialias" mode="assign"><bool>false</bool></edit>
+ <edit name="hinting" mode="assign"><bool>true</bool></edit>
+ </match>
+
+ <match target="font">
+ <test name="family"><string>AR PL New Sung</string></test>
+ <edit name="globaladvance"><bool>false</bool></edit>
+ </match>
+ <!-- end Firefly Truetype Font -->
+
+ <!-- x11-fonts/bitstream-vera -->
+ <alias>
+ <family>serif</family>
+ <prefer>
+ <family>Bitstream Vera Serif</family>
+ <family>AR PL New Sung</family>
+ </prefer>
+ </alias>
+ <alias>
+ <family>sans-serif</family>
+ <prefer>
+ <family>Bitstream Vera Sans</family>
+ <family>AR PL New Sung</family>
+ </prefer>
+ </alias>
+ <alias>
+ <family>monospace</family>
+ <prefer>
+ <family>Bitstream Vera Sans Mono</family>
+ <family>AR PL New Sung</family>
+ </prefer>
+ </alias>
+</fontconfig>
diff --git a/chinese/fireflyttf/pkg-descr b/chinese/fireflyttf/pkg-descr
new file mode 100644
index 000000000000..f0724d3fd20b
--- /dev/null
+++ b/chinese/fireflyttf/pkg-descr
@@ -0,0 +1,4 @@
+Firefly Truetype Font is combine of two arphic sung font and is embed
+9pt, 10pt, 11pt bitmaps.
+
+WWW: http://www.study-area.org/apt/firefly-font/
diff --git a/chinese/fireflyttf/pkg-plist b/chinese/fireflyttf/pkg-plist
new file mode 100644
index 000000000000..87aa373d2879
--- /dev/null
+++ b/chinese/fireflyttf/pkg-plist
@@ -0,0 +1,10 @@
+@unexec if cmp -s %%X11BASE%%/etc/fonts/local.conf %D/share/fonts/TrueType/local.conf-sung; then rm -f %%X11BASE%%/etc/fonts/local.conf; fi
+share/fonts/TrueType/local.conf-sung
+@exec cp %D/share/fonts/TrueType/local.conf-sung %%X11BASE%%/etc/fonts/local.conf
+@unexec %D/bin/ttfm.sh --remove xttfm %D/share/fonts/TrueType/fireflysung.ttf || true
+share/fonts/TrueType/fireflysung.ttf
+@exec %D/bin/ttfm.sh --add xttfm %D/share/fonts/TrueType/fireflysung.ttf || true
+@unexec %%X11BASE%%/bin/fc-cache -f -v %%X11BASE%%/lib/X11/fonts/TrueType || true
+@exec %%X11BASE%%/bin/fc-cache -f -v %%X11BASE%%/lib/X11/fonts/TrueType || true
+@unexec rmdir %D/share/fonts/TrueType 2>/dev/null || true
+@unexec rmdir %D/share/fonts 2>/dev/null || true
diff --git a/chinese/opendesktop-fonts/Makefile b/chinese/opendesktop-fonts/Makefile
new file mode 100644
index 000000000000..c04919190a81
--- /dev/null
+++ b/chinese/opendesktop-fonts/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: firefly TrueType Font
+# Date created: 2 Sep 2004
+# Whom: Shen Chuan-Hsing <statue@freebsd.sinica.edu.tw>
+#
+# $FreeBSD$
+#
+
+PORTNAME= fireflyttf
+PORTVERSION= 1.1.0
+CATEGORIES= chinese x11-fonts
+MASTER_SITES= http://www.study-area.org/apt/firefly-font/
+DISTNAME= fireflysung.ttf
+EXTRACT_SUFX= .gz
+
+MAINTAINER= statue@freebsd.sinica.edu.tw
+COMMENT= Firefly TrueType Font is combine of two arphic sung fonts
+
+BUILD_DEPENDS= fc-cache:${PORTSDIR}/x11-fonts/fontconfig \
+ ttfm.sh:${PORTSDIR}/chinese/ttfm
+RUN_DEPENDS= fc-cache:${PORTSDIR}/x11-fonts/fontconfig \
+ ttfm.sh:${PORTSDIR}/chinese/ttfm
+
+NO_BUILD= yes
+WRKSRC= ${WRKDIR}
+USE_XLIB= yes
+FONTDIR= ${PREFIX}/share/fonts/TrueType
+XFONTDIR= ${X11BASE}/lib/X11/fonts/TrueType
+EXTRACT_AFTER_ARGS= > ${DISTNAME}
+
+.include <bsd.port.pre.mk>
+
+do-install:
+ @${MKDIR} ${FONTDIR}
+ @${INSTALL_DATA} ${WRKSRC}/${DISTNAME} ${FONTDIR}
+ @${ECHO_MSG} "===> Running ttfm.sh"
+ -@${PREFIX}/bin/ttfm.sh --add xttfm ${DISTNAME}
+ @${ECHO_MSG} "===> Running fc-cache"
+ -@${X11BASE}/bin/fc-cache -f -v ${XFONTDIR}
+ ${INSTALL_DATA} ${FILESDIR}/local.conf-sung ${FONTDIR}
+ ${INSTALL_DATA} ${FILESDIR}/local.conf-sung ${X11BASE}/etc/fonts/local.conf
+
+.include <bsd.port.post.mk>
diff --git a/chinese/opendesktop-fonts/distinfo b/chinese/opendesktop-fonts/distinfo
new file mode 100644
index 000000000000..0423507da02c
--- /dev/null
+++ b/chinese/opendesktop-fonts/distinfo
@@ -0,0 +1,2 @@
+MD5 (fireflysung.ttf.gz) = 7b443608f2024567d631ab831b26f6a5
+SIZE (fireflysung.ttf.gz) = 7529763
diff --git a/chinese/opendesktop-fonts/files/local.conf-sung b/chinese/opendesktop-fonts/files/local.conf-sung
new file mode 100644
index 000000000000..38597782af3f
--- /dev/null
+++ b/chinese/opendesktop-fonts/files/local.conf-sung
@@ -0,0 +1,47 @@
+<?xml version="1.0"?>
+<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
+<fontconfig>
+ <!-- Firefly Truetype Font -->
+ <match target="font">
+ <test name="family"><string>AR PL New Sung</string></test>
+ <edit name="antialias"><bool>true</bool></edit>
+ <edit name="hinting"><bool>true</bool></edit>
+ <edit name="autohint"><bool>false</bool></edit>
+ </match>
+
+ <match target="font">
+ <test name="family"><string>AR PL New Sung</string></test>
+ <test name="size" compare="less_eq"><int>16</int></test>
+ <edit name="antialias" mode="assign"><bool>false</bool></edit>
+ <edit name="hinting" mode="assign"><bool>true</bool></edit>
+ </match>
+
+ <match target="font">
+ <test name="family"><string>AR PL New Sung</string></test>
+ <edit name="globaladvance"><bool>false</bool></edit>
+ </match>
+ <!-- end Firefly Truetype Font -->
+
+ <!-- x11-fonts/bitstream-vera -->
+ <alias>
+ <family>serif</family>
+ <prefer>
+ <family>Bitstream Vera Serif</family>
+ <family>AR PL New Sung</family>
+ </prefer>
+ </alias>
+ <alias>
+ <family>sans-serif</family>
+ <prefer>
+ <family>Bitstream Vera Sans</family>
+ <family>AR PL New Sung</family>
+ </prefer>
+ </alias>
+ <alias>
+ <family>monospace</family>
+ <prefer>
+ <family>Bitstream Vera Sans Mono</family>
+ <family>AR PL New Sung</family>
+ </prefer>
+ </alias>
+</fontconfig>
diff --git a/chinese/opendesktop-fonts/pkg-descr b/chinese/opendesktop-fonts/pkg-descr
new file mode 100644
index 000000000000..f0724d3fd20b
--- /dev/null
+++ b/chinese/opendesktop-fonts/pkg-descr
@@ -0,0 +1,4 @@
+Firefly Truetype Font is combine of two arphic sung font and is embed
+9pt, 10pt, 11pt bitmaps.
+
+WWW: http://www.study-area.org/apt/firefly-font/
diff --git a/chinese/opendesktop-fonts/pkg-plist b/chinese/opendesktop-fonts/pkg-plist
new file mode 100644
index 000000000000..87aa373d2879
--- /dev/null
+++ b/chinese/opendesktop-fonts/pkg-plist
@@ -0,0 +1,10 @@
+@unexec if cmp -s %%X11BASE%%/etc/fonts/local.conf %D/share/fonts/TrueType/local.conf-sung; then rm -f %%X11BASE%%/etc/fonts/local.conf; fi
+share/fonts/TrueType/local.conf-sung
+@exec cp %D/share/fonts/TrueType/local.conf-sung %%X11BASE%%/etc/fonts/local.conf
+@unexec %D/bin/ttfm.sh --remove xttfm %D/share/fonts/TrueType/fireflysung.ttf || true
+share/fonts/TrueType/fireflysung.ttf
+@exec %D/bin/ttfm.sh --add xttfm %D/share/fonts/TrueType/fireflysung.ttf || true
+@unexec %%X11BASE%%/bin/fc-cache -f -v %%X11BASE%%/lib/X11/fonts/TrueType || true
+@exec %%X11BASE%%/bin/fc-cache -f -v %%X11BASE%%/lib/X11/fonts/TrueType || true
+@unexec rmdir %D/share/fonts/TrueType 2>/dev/null || true
+@unexec rmdir %D/share/fonts 2>/dev/null || true