aboutsummaryrefslogtreecommitdiff
path: root/comms/remserial/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'comms/remserial/Makefile')
-rw-r--r--comms/remserial/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/comms/remserial/Makefile b/comms/remserial/Makefile
new file mode 100644
index 000000000000..60d77d94bba8
--- /dev/null
+++ b/comms/remserial/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: remserial
+# Date created: 05 Jan 2011
+# Whom: Emanuel Haupt <ehaupt@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= remserial
+PORTVERSION= 1.4
+CATEGORIES= comms
+MASTER_SITES= http://lpccomp.bc.ca/remserial/ \
+ CRITICAL
+
+MAINTAINER= ehaupt@FreeBSD.org
+COMMENT= Bridge between a TCP/IP network port and a character-oriented device
+
+USE_DOS2UNIX= yes
+MAKE_JOBS_SAFE= yes
+
+PLIST_FILES= bin/remserial
+PORTDOCS= README.txt
+
+CFLAGS+= -DOSVERSION=\"${OSVERSION}\"
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${PORTDOCS} ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>