aboutsummaryrefslogtreecommitdiff
path: root/comms/ruby-serialport/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'comms/ruby-serialport/Makefile')
-rw-r--r--comms/ruby-serialport/Makefile44
1 files changed, 44 insertions, 0 deletions
diff --git a/comms/ruby-serialport/Makefile b/comms/ruby-serialport/Makefile
new file mode 100644
index 000000000000..8148d30bdac2
--- /dev/null
+++ b/comms/ruby-serialport/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: Ruby/SerialPort
+# Date created: 21 February 2003
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= serialport
+PORTVERSION= 0.6
+CATEGORIES= comms ruby
+MASTER_SITES= http://davedd.free.fr/ruby-serialport/
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DISTNAME= ruby-${PORTNAME}-${PORTVERSION}
+DIST_SUBDIR= ruby
+
+MAINTAINER= knu@FreeBSD.org
+COMMENT= A Ruby library to communicate via the RS232 port
+
+USE_RUBY= yes
+USE_RUBY_EXTCONF= yes
+
+INSTALL_TARGET= site-install
+
+DOCS= CHANGELOG README
+EXAMPLES= test/*.rb
+
+post-patch:
+.for f in ${EXAMPLES}
+ ${RUBY} -i -pe 'sub!(%r"\.\./serialport", "serialport")' ${WRKSRC}/${f}
+.endfor
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${RUBY_MODEXAMPLESDIR}
+.for f in ${EXAMPLES}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_MODEXAMPLESDIR}/
+.endfor
+ ${MKDIR} ${RUBY_MODDOCDIR}
+.for f in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_MODDOCDIR}/
+.endfor
+.endif
+
+.include <bsd.port.mk>