aboutsummaryrefslogtreecommitdiff
path: root/comms/scrcpy/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'comms/scrcpy/Makefile')
-rw-r--r--comms/scrcpy/Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/comms/scrcpy/Makefile b/comms/scrcpy/Makefile
index ace66f2eee2d..ea43ce405d42 100644
--- a/comms/scrcpy/Makefile
+++ b/comms/scrcpy/Makefile
@@ -1,7 +1,6 @@
PORTNAME= scrcpy
DISTVERSIONPREFIX= v
-DISTVERSION= 1.21
-PORTREVISION= 1
+DISTVERSION= 1.24
CATEGORIES= comms net
MASTER_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/releases/download/${DISTVERSIONFULL}/:server
DISTFILES= ${SERVER_FILE}:server
@@ -26,9 +25,12 @@ USE_SDL= sdl2
MESON_ARGS= -Dportable=false \
-Dprebuilt_server=${WRKSRC}/${SERVER_FILE}
-PLIST_FILES= bin/scrcpy man/man1/scrcpy.1.gz \
+PLIST_FILES= bin/scrcpy \
+ etc/bash_completion.d/scrcpy \
+ man/man1/scrcpy.1.gz \
share/icons/hicolor/256x256/apps/scrcpy.png \
- ${DATADIR}/scrcpy-server
+ ${DATADIR}/scrcpy-server \
+ share/zsh/site-functions/_scrcpy
PORTDOCS= FAQ.md README.md
OPTIONS_DEFINE= DOCS