aboutsummaryrefslogtreecommitdiff
path: root/comms
diff options
context:
space:
mode:
Diffstat (limited to 'comms')
-rw-r--r--comms/ghfaxviewer/Makefile8
-rw-r--r--comms/gmfsk/Makefile8
-rw-r--r--comms/grig/Makefile8
-rw-r--r--comms/hamfax/Makefile8
4 files changed, 28 insertions, 4 deletions
diff --git a/comms/ghfaxviewer/Makefile b/comms/ghfaxviewer/Makefile
index 8ba762cc7b88..0f0fdfe51de4 100644
--- a/comms/ghfaxviewer/Makefile
+++ b/comms/ghfaxviewer/Makefile
@@ -29,6 +29,12 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
MAN1= halifax.1 ghfaxviewer.1
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile on FreeBSD >= 5.x"
+.endif
+
pre-patch:
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@@ -36,4 +42,4 @@ pre-patch:
's|\(\$$(datadir)/\)gnome/|\1|g ; \
s|\$$(datadir)/locale|$$(prefix)/share/locale|g'
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/comms/gmfsk/Makefile b/comms/gmfsk/Makefile
index cc76b4ddefe7..355617fe187c 100644
--- a/comms/gmfsk/Makefile
+++ b/comms/gmfsk/Makefile
@@ -26,7 +26,13 @@ USE_GMAKE= yes
USE_AUTOCONF_VER= 253
USE_GNOME= libgnomeui
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile on FreeBSD >= 5.x"
+.endif
+
post-install:
@${CAT} pkg-message
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/comms/grig/Makefile b/comms/grig/Makefile
index 6994d7745848..d8610828580e 100644
--- a/comms/grig/Makefile
+++ b/comms/grig/Makefile
@@ -25,7 +25,13 @@ CONFIGURE_ARGS= --disable-nls # nls not supported yet
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile on FreeBSD >= 5.x"
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|GCONF_LIBS="`|GCONF_LIBS="-lgconf-gtk-1 `|' ${WRKSRC}/configure
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/comms/hamfax/Makefile b/comms/hamfax/Makefile
index 34287f87543b..ec415f8910d9 100644
--- a/comms/hamfax/Makefile
+++ b/comms/hamfax/Makefile
@@ -26,4 +26,10 @@ CONFIGURE_ARGS= --with-Qt-dir=${X11BASE} CXX="g++ ${PTHREAD_CFLAGS}" \
USE_GMAKE= yes
USE_BZIP2= yes
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile on FreeBSD >= 5.x"
+.endif
+
+.include <bsd.port.post.mk>