aboutsummaryrefslogtreecommitdiff
path: root/converters/py-bencode.py/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'converters/py-bencode.py/Makefile')
-rw-r--r--converters/py-bencode.py/Makefile22
1 files changed, 22 insertions, 0 deletions
diff --git a/converters/py-bencode.py/Makefile b/converters/py-bencode.py/Makefile
new file mode 100644
index 000000000000..065e7546fe42
--- /dev/null
+++ b/converters/py-bencode.py/Makefile
@@ -0,0 +1,22 @@
+# $FreeBSD$
+
+PORTNAME= bencode.py
+PORTVERSION= 1.2.0
+CATEGORIES= converters devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= antoine@FreeBSD.org
+COMMENT= Bencoding and bdecoding implementation
+
+LICENSE= BTOSL
+LICENSE_NAME= BitTorrent Open Source License
+LICENSE_TEXT= See http://directory.fsf.org/wiki/License:BitTorrentOSL1.1
+LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pbr>=1.9:devel/py-pbr
+
+USES= python
+USE_PYTHON= distutils autoplist
+
+.include <bsd.port.mk>