aboutsummaryrefslogtreecommitdiff
path: root/databases/db47/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'databases/db47/Makefile')
-rw-r--r--databases/db47/Makefile49
1 files changed, 0 insertions, 49 deletions
diff --git a/databases/db47/Makefile b/databases/db47/Makefile
deleted file mode 100644
index 01ae208706e3..000000000000
--- a/databases/db47/Makefile
+++ /dev/null
@@ -1,49 +0,0 @@
-# New ports collection makefile for: db46
-# Date created: 2007-07-26
-# Whom: Gea-Suan Lin <gslin@gslin.org>
-#
-# $FreeBSD$
-#
-
-PORTNAME= db46
-PORTVERSION= 4.6.21.0
-CATEGORIES= databases
-MASTER_SITES= http://download-west.oracle.com/berkeley-db/ \
- http://download-east.oracle.com/berkeley-db/ \
- http://download-uk.oracle.com/berkeley-db/
-PKGNAMEPREFIX?=
-DISTNAME= db-${PORTVERSION:R}
-DIST_SUBDIR= bdb
-
-# I allow matthias.andree@gmx.de and all freebsd committer to do changes
-# to this package.
-MAINTAINER= gslin@gslin.org
-COMMENT= The Berkeley DB package, revision 4.6
-
-BDBVER= ${PORTVERSION:R:R}
-CONFIGURE_ARGS= --enable-compat185 --enable-dump185 --enable-cxx \
- --enable-dynamic --enable-rpc --enable-pthread_api \
- --includedir=${PREFIX}/include/${PORTNAME} \
- --libdir=${PREFIX}/lib/${PORTNAME} \
- --bindir=${PREFIX}/bin/${PORTNAME}
-CONFIGURE_SCRIPT= ../dist/configure
-GNU_CONFIGURE= yes
-INSTALL_TARGET= install_include install_lib install_utilities
-LIBTOOLFILES= ${CONFIGURE_SCRIPT}
-WRKSRC= ${WRKDIR}/${DISTNAME}/build_unix
-USE_LDCONFIG= yes
-
-.if !defined(NOPORTDOCS)
-INSTALL_TARGET+= install_docs docdir=${DOCSDIR}
-PORTDOCS= *
-.endif
-
-post-install:
-.for i in libdb libdb_cxx
- ${LN} -s -f ${PORTNAME}/${i}-${BDBVER}.so.0 ${PREFIX}/lib
- ${LN} -s -f ${i}-${BDBVER}.so.0 ${PREFIX}/lib/${i}-${BDBVER}.so
-.endfor
- cd ${PREFIX}/bin/${PORTNAME} ; \
- for i in * ; do ${LN} -s -f ${PORTNAME}/$$i ../$$i-${BDBVER} ; done
-
-.include <bsd.port.mk>