aboutsummaryrefslogtreecommitdiff
path: root/databases/firebird-client
diff options
context:
space:
mode:
Diffstat (limited to 'databases/firebird-client')
-rw-r--r--databases/firebird-client/Makefile98
-rw-r--r--databases/firebird-client/distinfo4
-rw-r--r--databases/firebird-client/files/RELNOTES79
-rw-r--r--databases/firebird-client/files/patch-ad12
-rw-r--r--databases/firebird-client/files/patch-ae10
-rw-r--r--databases/firebird-client/files/patch-af13
-rw-r--r--databases/firebird-client/files/patch-ag11
-rw-r--r--databases/firebird-client/pkg-comment1
-rw-r--r--databases/firebird-client/pkg-descr22
-rw-r--r--databases/firebird-client/pkg-install159
-rw-r--r--databases/firebird-client/pkg-message19
-rw-r--r--databases/firebird-client/pkg-plist106
-rw-r--r--databases/firebird-client/scripts/addservice9
-rw-r--r--databases/firebird-client/scripts/createuser50
-rw-r--r--databases/firebird-client/scripts/post-install84
-rw-r--r--databases/firebird-client/scripts/pre-build15
-rw-r--r--databases/firebird-client/scripts/pre-install20
-rw-r--r--databases/firebird-client/scripts/rmservice8
18 files changed, 0 insertions, 720 deletions
diff --git a/databases/firebird-client/Makefile b/databases/firebird-client/Makefile
deleted file mode 100644
index 486467c2efda..000000000000
--- a/databases/firebird-client/Makefile
+++ /dev/null
@@ -1,98 +0,0 @@
-# New ports collection makefile for: Firebird
-# Date created: 20 December 2000
-# Whom: Geoffrey C. Speicher <geoff@sea-incorporated.com>
-#
-# $FreeBSD$
-#
-
-PORTNAME= firebird
-PORTVERSION= 1.0
-CATEGORIES= databases
-MASTER_SITES= http://firebird.sourceforge.net/download/ \
- http://www.aims.com.au/chris/ \
- ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR=firebird
-DISTFILES= bootkit-1.0.0.796.tar.gz \
- bootkit-freebsd-1.0.0.796.tar.gz \
- interbase0.9-4-v5examples.tar.gz \
- Firebird-1.0.0.796.src.tar.gz
-
-MAINTAINER= chris@aims.com.au
-
-WRKSRC= ${WRKDIR}/firebird-1.0.0.796
-INSTALLS_SHLIB= yes
-LDCONFIG_DIRS= %%PREFIX%%/firebird/lib
-MSG_FILE= ${PKGDIR}/pkg-message
-PKGMESSAGE= ${WRKDIR}/pkg-message
-
-ONLY_FOR_ARCHS= i386
-
-.include <bsd.port.pre.mk>
-
-do-extract:
- @${MKDIR} ${WRKDIR}
- @( \
- cd ${WRKDIR}; ${TAR} -zxf \
- ${DISTDIR}/Firebird-1.0.0.796.src.tar.gz; \
- cd firebird-1.0.0.796; \
- ${TAR} -zxf ${DISTDIR}/bootkit-1.0.0.796.tar.gz; \
- ${TAR} -zxf ${DISTDIR}/bootkit-freebsd-1.0.0.796.tar.gz; \
- ${CP} -f msgs/msg.gbak misc/msg.gbak \
- )
-
-post-patch:
- @${SED} 's|%%PREFIX%%|${PREFIX}|g' ${MSG_FILE} > ${PKGMESSAGE}
-.if ${OSVERSION} >= 500016 || ${OSVERSION} >= 430001
- @${PERL} -pi -e 's,\-ldescrypt,\-lcrypt,g' \
- ${WRKSRC}/builds/original/prefix.freebsd
-.else
- @${PERL} -pi -e 's,^crypt_set_format.*,,' ${WRKSRC}/jrd/enc.c
-.endif
-
-do-configure:
- @( \
- cd ${WRKDIR}/firebird-1.0.0.796; \
- INTERBASE=${WRKDIR}/firebird-1.0.0.796/interbase; export INTERBASE; \
- REFDBPATH=${WRKDIR}/refDatabases; export REFDBPATH; \
- ${SH} buildBootDatabases; \
- NOPROMPT_SETUP=yes; export NOPROMPT_SETUP; \
- FIREBIRD_64_BIT_IO=yes; export FIREBIRD_64_BIT_IO; \
- ${CAT} builds_win32/original/build_no.ksh | ${TR} -d '\r' \
- > builds_win32/original/build_no.ksh.fix; \
- ${MV} -f builds_win32/original/build_no.ksh.fix \
- builds_win32/original/build_no.ksh; \
- ${SH} Configure.sh PROD FREEBSD; \
- )
-
-do-build:
- @( \
- ${ECHO_CMD} '#!/bin/sh'; ${ECHO_CMD} \
- '[ -d ${LDCONFIG_RUNLIST} ] && ${LDCONFIG} -m ${LDCONFIG_RUNLIST}'; \
- ) > ${WRKDIR}/000.${PORTNAME}.sh
- @( \
- ${LN} -sf ${WRKDIR}/refDatabases/jrd/isc.gdb \
- ${WRKDIR}/firebird-1.0.0.796/interbase/isc4.gdb; \
- ${LN} -sf ${WRKDIR}/refDatabases/msgs/msg.gdb \
- ${WRKDIR}/firebird-1.0.0.796/msg.gdb; \
- cd ${WRKDIR}/firebird-1.0.0.796; \
- INTERBASE=${WRKDIR}/firebird-1.0.0.796/interbase; export INTERBASE; \
- REFDBPATH=${WRKDIR}/refDatabases; export REFDBPATH; \
- ${SH} boot.freebsd; \
- )
-
-do-install:
- @( \
- cd ${WRKDIR}/firebird-1.0.0.796; \
- ${RM} ${WRKDIR}/firebird-1.0.0.796/interbase/isc4_tmp.gdb; \
- ${CP} /dev/null interbase/interbase.log; \
- ${CP} -Rp interbase ${PREFIX}/firebird; \
- ${RM} ${PREFIX}/firebird/install; \
- ${RM} ${PREFIX}/firebird/lib/libgds.so.1.0; \
- ${LN} -fs gds.so ${PREFIX}/firebird/lib/libgds.so.1; \
- cd ${PREFIX}/firebird/examples; \
- ${TAR} -xzf ${DISTDIR}/interbase0.9-4-v5examples.tar.gz; \
- ${CP} ${FILESDIR}/RELNOTES ${PREFIX}/firebird/; \
- ${INSTALL_SCRIPT} ${WRKDIR}/000.${PORTNAME}.sh ${PREFIX}/etc/rc.d/ \
- )
-
-.include <bsd.port.post.mk>
diff --git a/databases/firebird-client/distinfo b/databases/firebird-client/distinfo
deleted file mode 100644
index dfdff30e23a3..000000000000
--- a/databases/firebird-client/distinfo
+++ /dev/null
@@ -1,4 +0,0 @@
-MD5 (bootkit-1.0.0.796.tar.gz) = edcabe09957ed10b12e2f44eac9ae155
-MD5 (bootkit-freebsd-1.0.0.796.tar.gz) = 95bd14ec76bcf2b4ed41e3253ed58847
-MD5 (interbase0.9-4-v5examples.tar.gz) = 17cba82bbf5066d515f2dee97bf8327a
-MD5 (Firebird-1.0.0.796.src.tar.gz) = 53bfebb4a269eb0f3c508587a843ddf8
diff --git a/databases/firebird-client/files/RELNOTES b/databases/firebird-client/files/RELNOTES
deleted file mode 100644
index 5434347e24d2..000000000000
--- a/databases/firebird-client/files/RELNOTES
+++ /dev/null
@@ -1,79 +0,0 @@
-Firebird 1.0.0 FreeBSD Release Notes 13-Mar-2002
---------------------------------------
-FB-T6.2.796 Firebird Final Release
-
-Welcome to the FreeBSD Firebird port! Users should note that there
-was a package called `firebird-1.0.tgz' released in mid-August
-2000. Unfortunately, that package was released before Firebird
-version numbering conventions were established, so although the
-version number would suggest that it is newer than the current
-release, it is certainly not. Users of the August 1.0 package
-should upgrade to 0.9_4 or later, which has fixed many bugs and
-security problems, including the recently-discovered back door.
-
- Firebird originally required a running copy of Firebird (or
-InterBase) in order to build itself. This port uses a boot kit to
-overcome that, so that it does not require itself to build.
-Unfortunately, the side effect of this is that if you have a lock
-manager running from an already-installed version of Firebird or
-InterBase, this port will not build.
-
- Firebird is installed SUID with owner and group `firebird'.
-This does affect where you can and cannot create databases when
-connecting remotely, as well as which existing databases you can
-access. If you want a database to be available remotely, be sure
-it's readable and writeable to group firebird.
-
- There may be times when you manage to get your system into a
-state where using any of the Firebird utilites (isql, gbak, gsec,
-etc.) gives you the message "semget failed". One surefire way to
-do this is to build and install the port. :) If this happens,
-make sure that the lock manager is not running and its semaphores
-have been removed. The former can be accomplished with 'ps ax
-|grep gds' and 'kill'; the latter with 'ipcs -s' and 'ipcrm -s'.
-
- For example, after building and installing the port, you will
-probably go through something like this:
-
-# isql /usr/interbase/isc4.gdb
-Statement failed, SQLCODE = -902
-
-operating system directive semget failed
--No such file or directory
-
-# ipcs -s
-Semaphores:
-T ID KEY MODE OWNER GROUP
-s 1310720 252034728 --rw-rw-rw- root wheel
-
-# ipcrm -s 1310720
-
-and you should be in business.
-
- Once this is done, you should be able to connect normally to
-databases. Your first connection will restart the lock manager.
-
- There may be times, however, when you still get "semget failed"
-even though the lock manager is not running and the semaphores have
-been cleaned up. There seems to be a conflict with this release
-and the PostgreSQL 7 release as installed from the ports collection.
-If you're having trouble with Firebird and you're running PostgreSQL,
-try stopping PostgreSQL:
-
- /usr/local/etc/rc.d/pgsql.sh stop
-
-and see if that helps.
-
- Complete documentation for InterBase(tm) is available (free of
-charge) from http://www.interbase.com/ in PDF format. While
-InterBase and Firebird are two distinct entities, all InterBase
-documentation is pertinent to Firebird. More information on Firebird
-and InterBase can be found at the following:
-
- http://sourceforge.net/projects/firebird/
- http://www.ibphoenix.com/
- http://www.interbase2000.org/
- http://www.firebirdsql.org/
-
-Chris Knight
-<chris@aims.com.au>
diff --git a/databases/firebird-client/files/patch-ad b/databases/firebird-client/files/patch-ad
deleted file mode 100644
index 4bcb2c1ce13c..000000000000
--- a/databases/firebird-client/files/patch-ad
+++ /dev/null
@@ -1,12 +0,0 @@
---- setup_dirs.orig Tue Aug 7 05:00:12 2001
-+++ setup_dirs Fri Dec 28 16:12:49 2001
-@@ -60,7 +60,8 @@
- DefaultAns=$2
- echo -n "${1}"
- Answer="$DefaultAns"
-- read Answer
-+# read Answer
-+ echo ""
- }
-
-
diff --git a/databases/firebird-client/files/patch-ae b/databases/firebird-client/files/patch-ae
deleted file mode 100644
index 12f66c37082b..000000000000
--- a/databases/firebird-client/files/patch-ae
+++ /dev/null
@@ -1,10 +0,0 @@
---- jrd/common.h.orig Sat Nov 17 20:07:00 2001
-+++ jrd/common.h Sun Nov 18 18:54:26 2001
-@@ -137,6 +137,7 @@
- /* FreeBSD for Intel platforms */
- #ifdef FREEBSD
-
-+#define UNIX_64_BIT_IO
- #define FB_ALIGN(n,b) ((n + b - 1) & ~(b - 1))
- #define ALIGNMENT 4
- #define DOUBLE_ALIGN 4
diff --git a/databases/firebird-client/files/patch-af b/databases/firebird-client/files/patch-af
deleted file mode 100644
index 7ce937566bc3..000000000000
--- a/databases/firebird-client/files/patch-af
+++ /dev/null
@@ -1,13 +0,0 @@
---- jrd/enc.c.orig Fri Aug 4 06:50:03 2000
-+++ jrd/enc.c Sun Nov 18 19:17:19 2001
-@@ -31,6 +31,10 @@
- *
- **************************************/
-
-+#ifdef FREEBSD
-+crypt_set_format("des");
-+#endif
-+
- return CRYPT_FUNC( string, salt);
- }
- #endif
diff --git a/databases/firebird-client/files/patch-ag b/databases/firebird-client/files/patch-ag
deleted file mode 100644
index a4768621e878..000000000000
--- a/databases/firebird-client/files/patch-ag
+++ /dev/null
@@ -1,11 +0,0 @@
---- Configure.sh.orig Tue Nov 20 05:00:25 2001
-+++ Configure.sh Fri Dec 28 19:11:50 2001
-@@ -515,7 +515,7 @@
- BuildBootFlg="No"
- BuildHostType=""
- BuildBuildType="PROD"
--MasterSourceDir="`pwd`/refDatabases"
-+MasterSourceDir="$REFDBPATH"
- BuildIOsize=32
-
- export BuildHostType
diff --git a/databases/firebird-client/pkg-comment b/databases/firebird-client/pkg-comment
deleted file mode 100644
index f8cb5bc1d7b3..000000000000
--- a/databases/firebird-client/pkg-comment
+++ /dev/null
@@ -1 +0,0 @@
-The open-source InterBase(tm) 6.0 spin-off (Classic version)
diff --git a/databases/firebird-client/pkg-descr b/databases/firebird-client/pkg-descr
deleted file mode 100644
index c0ac8b0093af..000000000000
--- a/databases/firebird-client/pkg-descr
+++ /dev/null
@@ -1,22 +0,0 @@
-The open-source InterBase(tm) 6.0 spin-off (Classic server version)
-
-InterBase is a world-class DBMS with a history too rich to detail
-here. Once selling for several thousands of dollars per license,
-some very big players use it worldwide. Inprise has open-sourced
-InterBase 6.0, and a lively bunch of folks has charged themselves
-with seeing that it lives on through the Firebird project.
-
-Note that as of Firebird 0.9_4, the locksmith back door has
-been closed.
-
-For more information on Firebird and InterBase, see:
-
-http://sourceforge.net/projects/firebird/
-http://www.ibphoenix.com/
-http://www.interbase2000.org/
-http://www.interbase.com/
-http://www.firebirdsql.org/
-
-For more information on the locksmith back door, see:
-
-https://www.kb.cert.org/vuls/id/247371
diff --git a/databases/firebird-client/pkg-install b/databases/firebird-client/pkg-install
deleted file mode 100644
index af43f63a3943..000000000000
--- a/databases/firebird-client/pkg-install
+++ /dev/null
@@ -1,159 +0,0 @@
-#!/bin/sh
-
-# Created in haste by smashing together various
-# files from the port scripts.
-
-if [ "$2" = "PRE-INSTALL" ]; then
-if [ -d $PKG_PREFIX/firebird ]; then
- if [ -d $PKG_PREFIX/firebird.old ]; then
- rm -rf $PKG_PREFIX/firebird.old
- fi
- mv $PKG_PREFIX/firebird $PKG_PREFIX/firebird.old
-fi
-
-if [ -L /usr/interbase ]; then
- rm -f /usr/interbase
-fi
-
-if [ -d /usr/interbase ]; then
- mv /usr/interbase /usr/interbase.old
-fi
-
-ln -fs $PKG_PREFIX/firebird /usr/interbase
-
-perl <<EOF
-eval '(exit \$?0)' && eval 'exec /usr/bin/perl -S \$0 \${1+"\$@"}'
-& eval 'exec /usr/bin/perl -S \$0 \$argv:q'
-if 0;
-
-if( \$> ) {
- print "\nYou must be root to run this step!\n\n";
- exit 1;
-}
-
-if( getpwnam( "firebird" ) ) {
- ( \$null, \$null, \$fbUID ) = getpwnam( "firebird" );
-} else {
- \$fbUID = 90;
- while( getpwuid( \$fbUID ) ) {
- \$fbUID++;
- }
-}
-
-if( getgrnam( "firebird" ) ) {
- ( \$null, \$null, \$fbGID ) = getgrnam( "firebird" );
-} else {
- \$fbGID = 90;
- while( getgrgid( \$fbGID ) ) {
- \$fbGID++;
- }
- &append_file( "/etc/group", "firebird:*:\$fbGID:" );
-}
-
-print "firebird user using uid \$fbUID\n";
-print "firebird user using gid \$fbGID\n";
-
-system( "/usr/bin/chpass -a \"firebird:*:\$fbUID:\$fbGID\:\:0:0:Firebird pseudo-user:\$ENV{'PKG_PREFIX'}/firebird:/bin/sh\"" );
-
-sub append_file {
- local(\$file,@list) = @_;
- local(\$LOCK_EX) = 2;
- local(\$LOCK_NB) = 4;
- local(\$LOCK_UN) = 8;
-
- open(F, ">> \$file") || die "\$file: \$!\n";
- while( ! flock( F, \$LOCK_EX | \$LOCK_NB ) ) {
- exit 1;
- }
- print F join( "\n", @list) . "\n";
- close F;
- flock( F, \$LOCK_UN );
-}
-EOF
-elif [ "$2" = "POST-INSTALL" ]; then
-chown -R firebird:firebird $PKG_PREFIX/firebird
-
-# Turn everybody to read only.
-chmod -R o=r $PKG_PREFIX/firebird
-
-# Now fix up the mess.
-
-# fix up directories
-for i in `find $PKG_PREFIX/firebird -print`
- do
- FileName=$i
- if [ -d $FileName ]
- then
- chmod o=rx $FileName
- fi
- done
-
-# make lib ldconfig-compatible
-chown -R root:wheel $PKG_PREFIX/firebird/lib
-chmod -R g-w $PKG_PREFIX/firebird/lib
-
-# Fix UDF load problem
-cd $PKG_PREFIX/firebird/lib
-ln -sf ib_util.so libib_util.so
-
-cd $PKG_PREFIX/firebird/bin
-
-# all users can run everything.
-chmod o=rx *
-
-# SUID is needed for running server programs.
-
-for i in gds_lock_mgr gds_drop gds_inet_server
- do
- chmod ug+s $i
- done
-
-
-# Lock files
-
-cd $PKG_PREFIX/firebird
-
-for i in isc_init1 isc_lock1 isc_event1
- do
- FileName=$i.`hostname`
- touch $FileName
- chmod uga=rw $FileName
- chown firebird:firebird $FileName
- done
-
-
-touch interbase.log
-chmod ugo=rw interbase.log
-
-# make databases writable by all
-chmod ugo=rw examples/v5/*.gdb
-chmod ugo=rw help/*.gdb
-chmod ugo=rw isc4.gdb
-
-# remove any existing gds service
-cp /etc/services /etc/services.old
-cp /etc/inetd.conf /etc/inetd.conf.old
-cat /etc/services |grep -v gds_db >/etc/services.new
-cat /etc/inetd.conf |grep -v gds_db >/etc/inetd.conf.new
-mv /etc/services.new /etc/services
-mv /etc/inetd.conf.new /etc/inetd.conf
-
-# add the gds service and restart inetd
-cat >>/etc/services <<EOF
-gds_db 3050/tcp #InterBase Database Remote Protocol
-EOF
-cat >>/etc/inetd.conf <<EOF
-gds_db stream tcp nowait firebird /usr/interbase/bin/gds_inet_server gds_inet_server
-EOF
-if [ -f /var/run/inetd.pid ]; then
- kill -HUP `cat /var/run/inetd.pid`
-fi
-
-# shared lib startup script
-if [ -d $PKG_PREFIX/etc/rc.d ]; then
- (
- echo "#!/bin/sh"; echo "[ -d $PKG_PREFIX/firebird/lib ] && /sbin/ldconfig -m $PKG_PREFIX/firebird/lib"
- ) > $PKG_PREFIX/etc/rc.d/000.firebird.sh
-fi
-
-fi
diff --git a/databases/firebird-client/pkg-message b/databases/firebird-client/pkg-message
deleted file mode 100644
index f15892a06aaa..000000000000
--- a/databases/firebird-client/pkg-message
+++ /dev/null
@@ -1,19 +0,0 @@
-
----------------------------------------------------------
-Firebird is now installed. There is a symbolic link from
-/usr/interbase -> %%PREFIX%%/firebird. Firebird needs this
-link for proper operation.
-
-It is STRONGLY recommended that you change the SYSDBA
-password with:
-
-$ cd /usr/interbase
-$ gsec -user SYSDBA -pass masterkey
-GSEC> modify SYSDBA -pw newpassword
-GSEC> quit
-
-before doing anything serious with Firebird.
-
-See %%PREFIX%%/firebird/RELNOTES for more.
----------------------------------------------------------
-
diff --git a/databases/firebird-client/pkg-plist b/databases/firebird-client/pkg-plist
deleted file mode 100644
index 10f152fcbc82..000000000000
--- a/databases/firebird-client/pkg-plist
+++ /dev/null
@@ -1,106 +0,0 @@
-etc/rc.d/000.firebird.sh
-firebird/intl/gdsintl
-firebird/examples/v5/ib_udf.sql
-firebird/examples/v5/README
-firebird/examples/v5/align.h
-firebird/examples/v5/api1.c
-firebird/examples/v5/api10.c
-firebird/examples/v5/api11.c
-firebird/examples/v5/api12.c
-firebird/examples/v5/api13.c
-firebird/examples/v5/api14.e
-firebird/examples/v5/api15.c
-firebird/examples/v5/api16.c
-firebird/examples/v5/api16t.c
-firebird/examples/v5/api2.c
-firebird/examples/v5/api3.c
-firebird/examples/v5/api4.c
-firebird/examples/v5/api5.c
-firebird/examples/v5/api6.c
-firebird/examples/v5/api7.c
-firebird/examples/v5/api8.c
-firebird/examples/v5/api9.c
-firebird/examples/v5/api9f.c
-firebird/examples/v5/apifull.c
-firebird/examples/v5/employe2.sql
-firebird/examples/v5/dyn1.e
-firebird/examples/v5/dyn2.e
-firebird/examples/v5/dyn3.e
-firebird/examples/v5/dyn4.e
-firebird/examples/v5/dyn5.e
-firebird/examples/v5/dynfull.e
-firebird/examples/v5/employee.gbk
-firebird/examples/v5/employee.gdb
-firebird/examples/v5/example.h
-firebird/examples/v5/api9f.sql
-firebird/examples/v5/intlemp.gbk
-firebird/examples/v5/intlemp.gdb
-firebird/examples/v5/stat1.e
-firebird/examples/v5/stat10.e
-firebird/examples/v5/stat11.e
-firebird/examples/v5/stat12.e
-firebird/examples/v5/stat12t.e
-firebird/examples/v5/stat2.e
-firebird/examples/v5/stat3.e
-firebird/examples/v5/stat4.e
-firebird/examples/v5/stat5.e
-firebird/examples/v5/stat6.e
-firebird/examples/v5/stat7.e
-firebird/examples/v5/stat8.e
-firebird/examples/v5/stat9.e
-firebird/examples/v5/udf.sql
-firebird/examples/v5/udflib.c
-firebird/examples/v5/makefile
-firebird/include/perf.h
-firebird/include/ib_util.h
-firebird/include/gds.hxx
-firebird/include/gds.h
-firebird/include/ibase.h
-firebird/include/iberror.h
-firebird/include/gds.f
-firebird/UDF/ib_udf
-firebird/lib/ib_util.so
-firebird/lib/gds.a
-firebird/lib/gds.so
-firebird/lib/libgds.so
-firebird/lib/libgds.so.1
-firebird/lib/libgds_pyxis.a
-firebird/lib/libgds.a
-firebird/lib/libib_util.so
-firebird/lib/gds_pyxis.a
-firebird/help/help.gbak
-firebird/help/help.gdb
-firebird/bin/isc4.gbak
-firebird/bin/gpre
-firebird/bin/gds_pipe
-firebird/bin/gds_drop
-firebird/bin/gds_lock_mgr
-firebird/bin/gfix
-firebird/bin/gdef
-firebird/bin/isql
-firebird/bin/gds_lock_print
-firebird/bin/qli
-firebird/bin/gds_inet_server
-firebird/bin/gsplit
-firebird/bin/gstat
-firebird/bin/gds_relay
-firebird/bin/gsec
-firebird/bin/gbak
-firebird/services.isc
-firebird/isc_config
-firebird/isc4.gdb
-firebird/interbase.msg
-firebird/interbase.log
-firebird/inetd.conf.isc
-firebird/RELNOTES
-@dirrm firebird
-@dirrm firebird/intl
-@dirrm firebird/examples/v3
-@dirrm firebird/examples/v4
-@dirrm firebird/examples/v5
-@dirrm firebird/examples
-@dirrm firebird/include
-@dirrm firebird/UDF
-@dirrm firebird/lib
-@dirrm firebird/help
-@dirrm firebird/bin
diff --git a/databases/firebird-client/scripts/addservice b/databases/firebird-client/scripts/addservice
deleted file mode 100644
index df9aea5e91de..000000000000
--- a/databases/firebird-client/scripts/addservice
+++ /dev/null
@@ -1,9 +0,0 @@
-#!/bin/sh
-
-cat >>/etc/services <<EOF
-gds_db 3050/tcp #InterBase Database Remote Protocol
-EOF
-cat >>/etc/inetd.conf <<EOF
-gds_db stream tcp nowait firebird /usr/interbase/bin/gds_inet_server gds_inet_server
-EOF
-kill -HUP `cat /var/run/inetd.pid`
diff --git a/databases/firebird-client/scripts/createuser b/databases/firebird-client/scripts/createuser
deleted file mode 100644
index eba7ce1b887d..000000000000
--- a/databases/firebird-client/scripts/createuser
+++ /dev/null
@@ -1,50 +0,0 @@
-#!/usr/bin/perl
-#
-
-eval '(exit $?0)' && eval 'exec /usr/bin/perl -S $0 ${1+"$@"}'
-& eval 'exec /usr/bin/perl -S $0 $argv:q'
-if 0;
-
-if( $> ) {
- print "\nYou must be root to run this step!\n\n";
- exit 1;
-}
-
-if( getpwnam( "firebird" ) ) {
- ( $null, $null, $fbUID ) = getpwnam( "firebird" );
-} else {
- $fbUID = 90;
- while( getpwuid( $fbUID ) ) {
- $fbUID++;
- }
-}
-
-if( getgrnam( "firebird" ) ) {
- ( $null, $null, $fbGID ) = getgrnam( "firebird" );
-} else {
- $fbGID = 90;
- while( getgrgid( $fbGID ) ) {
- $fbGID++;
- }
- &append_file( "/etc/group", "firebird:*:$fbGID:" );
-}
-
-print "firebird user using uid $fbUID\n";
-print "firebird user using gid $fbGID\n";
-
-system( "/usr/bin/chpass -a \"firebird:*:$fbUID:$fbGID\:\:0:0:Firebird pseudo-user:$ENV{'PREFIX'}/firebird:/bin/sh\"" );
-
-sub append_file {
- local($file,@list) = @_;
- local($LOCK_EX) = 2;
- local($LOCK_NB) = 4;
- local($LOCK_UN) = 8;
-
- open(F, ">> $file") || die "$file: $!\n";
- while( ! flock( F, $LOCK_EX | $LOCK_NB ) ) {
- exit 1;
- }
- print F join( "\n", @list) . "\n";
- close F;
- flock( F, $LOCK_UN );
-}
diff --git a/databases/firebird-client/scripts/post-install b/databases/firebird-client/scripts/post-install
deleted file mode 100644
index 68b4ccadb907..000000000000
--- a/databases/firebird-client/scripts/post-install
+++ /dev/null
@@ -1,84 +0,0 @@
-#!/bin/sh
-
-chown -R firebird:firebird $PREFIX/firebird
-
-# Turn everybody to read only.
-chmod -R o=r $PREFIX/firebird
-
-# Now fix up the mess.
-
-# fix up directories
-for i in `find $PREFIX/firebird -print`
- do
- FileName=$i
- if [ -d $FileName ]
- then
- chmod o=rx $FileName
- fi
- done
-
-# make lib ldconfig-compatible
-chown -R root:wheel $PREFIX/firebird/lib
-chmod -R g-w $PREFIX/firebird/lib
-
-# Fix UDF load problem
-cd $PREFIX/firebird/lib
-ln -sf ib_util.so libib_util.so
-
-cd $PREFIX/firebird/bin
-
-# all users can run everything.
-chmod o=rx *
-
-# SUID is needed for running server programs.
-
-for i in gds_lock_mgr gds_drop gds_inet_server
- do
- chmod ug+s $i
- done
-
-
-# Lock files
-
-cd $PREFIX/firebird
-
-for i in isc_init1 isc_lock1 isc_event1
- do
- FileName=$i.`hostname`
- touch $FileName
- chmod uga=rw $FileName
- chown firebird:firebird $FileName
- done
-
-
-touch interbase.log
-chmod ugo=rw interbase.log
-
-# make databases writable by all
-chmod ugo=rw examples/v5/*.gdb
-chmod ugo=rw help/*.gdb
-chmod ugo=rw isc4.gdb
-
-# remove any existing gds service
-sh $SCRIPTDIR/rmservice
-
-# add the gds service and restart inetd
-sh $SCRIPTDIR/addservice
-if [ -f /var/run/inetd.pid ]; then
- kill -HUP `cat /var/run/inetd.pid`
-fi
-
-sed "s|%%PREFIX%%|$PREFIX|" $SCRIPTDIR/../pkg-message
-
-cat <<EOF
-
-==========================================================
-!! NOTE !!
-
-As there are some oddities to the Firebird build process,
-it is likely you WILL NOT BE ABLE TO USE IT until you
-remove the semaphore created during the build process.
-Please read $PREFIX/firebird/RELNOTES for more information.
-==========================================================
-
-EOF
diff --git a/databases/firebird-client/scripts/pre-build b/databases/firebird-client/scripts/pre-build
deleted file mode 100644
index 6605df7770fd..000000000000
--- a/databases/firebird-client/scripts/pre-build
+++ /dev/null
@@ -1,15 +0,0 @@
-#!/bin/sh
-
-GDS_LOCK_MGR=`ps ax |grep gds_lock_mgr |grep -v grep`;
-
-if [ "$GDS_LOCK_MGR" != "" ]; then
- echo "It appears you have a gds_lock_manager already running.";
- echo;
- echo "You must cease all InterBase operations to build this port.";
- echo "Make sure nobody is connected to any databases, then use";
- echo "'gds_drop -a' and manually verify (with ipcs) that the";
- echo "semaphores were removed.";
- exit 1;
-fi
-exit 0
-
diff --git a/databases/firebird-client/scripts/pre-install b/databases/firebird-client/scripts/pre-install
deleted file mode 100644
index a6e1b37a9008..000000000000
--- a/databases/firebird-client/scripts/pre-install
+++ /dev/null
@@ -1,20 +0,0 @@
-#!/bin/sh
-
-if [ -d $PREFIX/firebird ]; then
- if [ -d $PREFIX/firebird.old ]; then
- rm -rf $PREFIX/firebird.old
- fi
- mv $PREFIX/firebird $PREFIX/firebird.old
-fi
-
-if [ -L /usr/interbase ]; then
- rm -f /usr/interbase
-fi
-
-if [ -d /usr/interbase ]; then
- mv /usr/interbase /usr/interbase.old
-fi
-
-ln -fs $PREFIX/firebird /usr/interbase
-
-perl $SCRIPTDIR/createuser
diff --git a/databases/firebird-client/scripts/rmservice b/databases/firebird-client/scripts/rmservice
deleted file mode 100644
index 58adfc17419d..000000000000
--- a/databases/firebird-client/scripts/rmservice
+++ /dev/null
@@ -1,8 +0,0 @@
-#!/bin/sh
-
-cp /etc/services /etc/services.old
-cp /etc/inetd.conf /etc/inetd.conf.old
-cat /etc/services |grep -v gds_db >/etc/services.new
-cat /etc/inetd.conf |grep -v gds_db >/etc/inetd.conf.new
-mv /etc/services.new /etc/services
-mv /etc/inetd.conf.new /etc/inetd.conf