aboutsummaryrefslogtreecommitdiff
path: root/databases/grass7/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'databases/grass7/Makefile')
-rw-r--r--databases/grass7/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/databases/grass7/Makefile b/databases/grass7/Makefile
index 775ae951d3d6..1389f77593b7 100644
--- a/databases/grass7/Makefile
+++ b/databases/grass7/Makefile
@@ -25,7 +25,7 @@ COMMENT= Open source Geographical Information System (GIS)
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/GPL.TXT
-BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}numpy>=1.2:math/py-numpy
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}numpy>=1.2:math/py-numpy@${PY_FLAVOR}
LIB_DEPENDS= libgdal.so:graphics/gdal \
libpng.so:graphics/png \
libproj.so:graphics/proj \
@@ -113,7 +113,7 @@ PGSQL_USES= pgsql
PGSQL_CONFIGURE_ON= --with-postgres
SQLITE_USES= sqlite
SQLITE_CONFIGURE_ON= --with-sqlite
-SQLITE_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlite3>0:databases/py-sqlite3
+SQLITE_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlite3>0:databases/py-sqlite3@${PY_FLAVOR}
.include <bsd.port.options.mk>