aboutsummaryrefslogtreecommitdiff
path: root/databases/mysql54-server/files
diff options
context:
space:
mode:
Diffstat (limited to 'databases/mysql54-server/files')
-rw-r--r--databases/mysql54-server/files/patch-Makefile.in15
-rw-r--r--databases/mysql54-server/files/patch-ab35
-rw-r--r--databases/mysql54-server/files/patch-af73
-rw-r--r--databases/mysql54-server/files/patch-ap11
-rw-r--r--databases/mysql54-server/files/patch-aq13
-rw-r--r--databases/mysql54-server/files/patch-as16
-rw-r--r--databases/mysql54-server/files/patch-configure99
-rw-r--r--databases/mysql54-server/files/patch-include::Makefile.in14
8 files changed, 0 insertions, 276 deletions
diff --git a/databases/mysql54-server/files/patch-Makefile.in b/databases/mysql54-server/files/patch-Makefile.in
deleted file mode 100644
index 00190736f765..000000000000
--- a/databases/mysql54-server/files/patch-Makefile.in
+++ /dev/null
@@ -1,15 +0,0 @@
---- Makefile.in.orig Sat Jan 1 17:59:38 2000
-+++ Makefile.in Mon Jan 3 17:19:23 2000
-@@ -144,7 +144,11 @@
- # These are built from source in the Docs directory
- EXTRA_DIST = INSTALL-SOURCE-GENERIC README PUBLIC INSTALL-SOURCE MIRRORS
-
--SUBDIRS = include @docs_dirs@ @readline_dir@ client @sql_server_dirs@ scripts tests man @bench_dirs@ support-files
-+.if defined(CLIENT_ONLY)
-+SUBDIRS = include @readline_dir@ client tests man
-+.else
-+SUBDIRS = include @docs_dirs@ @sql_server_dirs@ scripts @bench_dirs@ support-files
-+.endif
-
-
- # Relink after clean
diff --git a/databases/mysql54-server/files/patch-ab b/databases/mysql54-server/files/patch-ab
deleted file mode 100644
index 04825c3dc4b1..000000000000
--- a/databases/mysql54-server/files/patch-ab
+++ /dev/null
@@ -1,35 +0,0 @@
---- scripts/mysql_install_db.sh.orig Sat Aug 28 13:10:54 1999
-+++ scripts/mysql_install_db.sh Mon Sep 13 00:13:04 1999
-@@ -15,10 +15,6 @@
- force=0
- IN_RPM=0
-
--# Are we doing an rpm install?
--if test "$1" = "-IN-RPM"; then IN_RPM=1; shift; fi
--if test "$1" = "--force"; then force=1; shift; fi
--
- # Get mysqld/safe_mysqld options from /etc/my.cnf or ~/.my.cnf
- if test -w /
- then
-@@ -60,8 +56,6 @@
- fi
- fi
-
--# On IRIX hostname is in /usr/bsd so add this to the path
--PATH=$PATH:/usr/bsd
- hostname=`hostname` # Install this too in the user table
-
- # Check if hostname is valid
-@@ -255,12 +249,6 @@
- END_OF_DATA
- then
- echo ""
-- if test "$IN_RPM" -eq 0
-- then
-- echo "To start mysqld at boot time you have to copy support-files/mysql.server"
-- echo "to the right place for your system"
-- echo
-- fi
- echo "PLEASE REMEMBER TO SET A PASSWORD FOR THE MySQL root USER !"
- echo "This is done with:"
- echo "$bindir/mysqladmin -u root password 'new-password'"
diff --git a/databases/mysql54-server/files/patch-af b/databases/mysql54-server/files/patch-af
deleted file mode 100644
index 2593da4d1c64..000000000000
--- a/databases/mysql54-server/files/patch-af
+++ /dev/null
@@ -1,73 +0,0 @@
---- scripts/safe_mysqld.sh.orig Fri May 14 11:11:46 1999
-+++ scripts/safe_mysqld.sh Tue Jun 8 11:14:02 1999
-@@ -12,33 +12,9 @@
-
- trap '' 1 2 3 15 # we shouldn't let anyone kill us
-
--# Check if we are starting this relative (for the binary release)
--if test -d ./data/mysql -a -f ./share/mysql/english/errmsg.sys -a \
-- -x ./bin/mysqld
--then
-- MY_BASEDIR_VERSION=`pwd` # Where bin, share and data are
-- DATADIR=$MY_BASEDIR_VERSION/data # Where the databases are
-- ledir=$MY_BASEDIR_VERSION/bin # Where mysqld is
--# Check if this is a 'moved install directory'
--elif test -f ./var/mysql/db.frm -a -f ./share/mysql/english/errmsg.sys -a \
-- -x ./libexec/mysqld
--then
-- MY_BASEDIR_VERSION=`pwd` # Where libexec, share and var are
-- DATADIR=$MY_BASEDIR_VERSION/var # Where the databases are
-- ledir=$MY_BASEDIR_VERSION/libexec # Where mysqld is
--else
-- MY_BASEDIR_VERSION=@prefix@
-- DATADIR=@localstatedir@
-- ledir=@libexecdir@
-- if test ! -x $ledir/mysqld
-- then
-- echo "The file $ledir/mysqld doesn't exist or is not executable"
-- echo "Please do a cd to the mysql installation directory and restart"
-- echo "this script from there as follows:"
-- echo "./bin/safe_mysqld".
-- exit 1;
-- fi
--fi
-+MY_BASEDIR_VERSION=@prefix@
-+DATADIR=@localstatedir@
-+ledir=@libexecdir@
-
- pid_file=$DATADIR/`@HOSTNAME@`.pid
- log=$DATADIR/`@HOSTNAME@`.log
-@@ -114,33 +90,6 @@
- if test ! -f $pid_file # This is removed if normal shutdown
- then
- break;
-- fi
-- if @IS_LINUX@
-- then
-- # Test if one process was hanging.
-- # This is only a fix for Linux (running as base 3 mysqld processes)
-- # but should work for the rest of the servers.
-- # The only thing is ps x => redhat 5 gives warnings when using ps -x.
-- # kill -9 is used or the process won't react on the kill.
-- numofproces=`ps x | grep -v "grep" | grep -c $ledir/mysqld`
-- echo -e "\nNumber of processes running now: $numofproces" | tee -a $err_log
-- I=1
-- while test "$I" -le "$numofproces"
-- do
-- PROC=`ps x | grep $ledir/mysqld | grep -v "grep" | tail -1`
-- for T in $PROC
-- do
-- break
-- done
-- # echo "TEST $I - $T **"
-- if kill -9 $T
-- then
-- echo "mysqld process hanging, pid $T - killed" | tee -a $err_log
-- else
-- break
-- fi
-- I=`expr $I + 1`
-- done
- fi
- echo "mysqld restarted on " `date` | tee -a $err_log
- done
diff --git a/databases/mysql54-server/files/patch-ap b/databases/mysql54-server/files/patch-ap
deleted file mode 100644
index 097b449a181a..000000000000
--- a/databases/mysql54-server/files/patch-ap
+++ /dev/null
@@ -1,11 +0,0 @@
---- strings/Makefile.in.orig Sat Jan 1 18:00:30 2000
-+++ strings/Makefile.in Mon Jan 3 17:21:19 2000
-@@ -145,7 +145,7 @@
- INCLUDES = @MT_INCLUDES@ -I$(srcdir)/../include -I../include
- pkglib_LIBRARIES = libmystrings.a
- #no assembler
--@ASSEMBLER_x86_TRUE@ASRCS = strings-x86.s longlong2str-x86.s
-+@ASSEMBLER_x86_TRUE@ASRCS = strings-x86.S longlong2str-x86.S
- @ASSEMBLER_x86_FALSE@@ASSEMBLER_sparc_TRUE@ASRCS = bmove_upp-sparc.s strappend-sparc.s strend-sparc.s strinstr-sparc.s strmake-sparc.s strmov-sparc.s strnmov-sparc.s strstr-sparc.s strxmov-sparc.s
- @ASSEMBLER_x86_FALSE@@ASSEMBLER_sparc_FALSE@ASRCS =
- # These file MUST all be on the same line!! Otherwise automake
diff --git a/databases/mysql54-server/files/patch-aq b/databases/mysql54-server/files/patch-aq
deleted file mode 100644
index 573324175921..000000000000
--- a/databases/mysql54-server/files/patch-aq
+++ /dev/null
@@ -1,13 +0,0 @@
---- sql/Makefile.in.orig Sat Jan 1 18:01:13 2000
-+++ sql/Makefile.in Wed Jan 5 20:28:17 2000
-@@ -317,6 +317,10 @@
- else :; fi
- sql_yacc.hh: sql_yacc.cc
-
-+# gcc takes a lot of memory and cpu time if it compiles sql_yacc.cc with -O
-+sql_yacc.o: sql_yacc.cc
-+ $(CXXCOMPILE) -O0 -c $<
-+
-
- # This directory's subdirectories are mostly independent; you can cd
- # into them and run `make' without going through this Makefile.
diff --git a/databases/mysql54-server/files/patch-as b/databases/mysql54-server/files/patch-as
deleted file mode 100644
index 903bc9950a28..000000000000
--- a/databases/mysql54-server/files/patch-as
+++ /dev/null
@@ -1,16 +0,0 @@
---- sql/mysqld.cc.orig Sun Feb 13 02:40:18 2000
-+++ sql/mysqld.cc Mon Feb 21 21:24:51 2000
-@@ -63,8 +63,11 @@
- inline void reset_floating_point_exceptions()
- {
- /* Don't fall for overflow, underflow,divide-by-zero or loss of precision */
-- fpsetmask(~(FP_X_INV | FP_X_DNML | FP_X_OFL | FP_X_UFL |
-- FP_X_DZ | FP_X_IMP));
-+#if defined(__i386__)
-+ fpsetmask(~(FP_X_INV | FP_X_DNML | FP_X_OFL | FP_X_UFL | FP_X_DZ | FP_X_IMP));
-+#else
-+ fpsetmask(~(FP_X_INV | FP_X_OFL | FP_X_UFL | FP_X_DZ | FP_X_IMP));
-+#endif
- }
- #else
- #define reset_floating_point_exceptions()
diff --git a/databases/mysql54-server/files/patch-configure b/databases/mysql54-server/files/patch-configure
deleted file mode 100644
index 8476a2bd9a60..000000000000
--- a/databases/mysql54-server/files/patch-configure
+++ /dev/null
@@ -1,99 +0,0 @@
---- configure.orig Wed Jan 12 04:32:17 2000
-+++ configure Tue Jan 25 14:58:09 2000
-@@ -2743,7 +2743,7 @@
- ;;
- esac
- fi
--HOSTNAME="$ac_cv_path_HOSTNAME"
-+HOSTNAME="$ac_cv_path_HOSTNAME -s"
- if test -n "$HOSTNAME"; then
- echo "$ac_t""$HOSTNAME" 1>&6
- else
-@@ -2871,30 +2871,7 @@
- echo $ac_n "checking "how to check if pid exists"""... $ac_c" 1>&6
- echo "configure:2873: checking "how to check if pid exists"" >&5
- PS=$ac_cv_path_PS
--# Linux style
--if $PS p $$ 2> /dev/null | grep $0 > /dev/null
--then
-- FIND_PROC="$PS p \$\$PID | grep mysqld > /dev/null"
--# Solaris
--elif $PS -p $$ 2> /dev/null | grep $0 > /dev/null
--then
-- FIND_PROC="$PS -p \$\$PID | grep mysqld > /dev/null"
--# BSD style
--elif $PS -uaxww 2> /dev/null | grep $0 > /dev/null
--then
-- FIND_PROC="$PS -uaxww | grep mysqld | grep \" \$\$PID \" > /dev/null"
--# SysV style
--elif $PS -ef 2> /dev/null | grep $0 > /dev/null
--then
-- FIND_PROC="$PS -ef | grep mysqld | grep \" \$\$PID \" > /dev/null"
--# Do anybody use this?
--elif $PS $$ 2> /dev/null | grep $0 > /dev/null
--then
-- FIND_PROC="$PS \$\$PID | grep mysqld > /dev/null"
--else
-- { echo "configure: error: Could not find the right ps switches. Which OS is this ?. See the Installation chapter in the Reference Manual." 1>&2; exit 1; }
--fi
--
-+FIND_PROC="$PS -uaxww | grep mysqld | grep \" \$\$PID \" > /dev/null"
- echo "$ac_t"""$FIND_PROC"" 1>&6
-
- # Check if a pid is valid
-@@ -4614,8 +4591,6 @@
- #define $ac_tr_lib 1
- EOF
-
-- LIBS="-lc_r $LIBS"
--
- else
- echo "$ac_t""no" 1>&6
- fi
-@@ -4849,28 +4824,6 @@
- fi
-
-
--# Build optimized or debug version ?
--# First check for gcc and g++
--if test "$ac_cv_prog_gcc" = "yes"
--then
-- DEBUG_CFLAGS="-g"
-- DEBUG_OPTIMIZE_CC="-O"
-- OPTIMIZE_CFLAGS="-O6"
--else
-- DEBUG_CFLAGS="-g"
-- DEBUG_OPTIMIZE_CC=""
-- OPTIMIZE_CFLAGS="-O"
--fi
--if test "$ac_cv_prog_cxx_g" = "yes"
--then
-- DEBUG_CXXFLAGS="-g"
-- DEBUG_OPTIMIZE_CXX="-O"
-- OPTIMIZE_CXXFLAGS="-O3"
--else
-- DEBUG_CXXFLAGS="-g"
-- DEBUG_OPTIMIZE_CXX=""
-- OPTIMIZE_CXXFLAGS="-O"
--fi
- # Check whether --with-debug or --without-debug was given.
- if test "${with_debug+set}" = set; then
- withval="$with_debug"
-@@ -7973,7 +7926,7 @@
- #include <pthread.h>
- int main() {
- pthread_attr_t thr_attr;
--pthread_attr_setscope(&thr_attr,0);
-+XXXpthread_attr_setscope(&thr_attr,0);
- ; return 0; }
- EOF
- if { (eval echo configure:7980: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
-@@ -8178,7 +8131,7 @@
- echo ""
- echo "Configuring MIT Pthreads"
- # We will never install so installation paths are not needed.
-- (cd mit-pthreads; sh ./configure)
-+ (cd mit-pthreads; sh ./configure ${CONFIGURE_ARGS})
- echo "End of MIT Pthreads configuration"
- echo ""
- fi
diff --git a/databases/mysql54-server/files/patch-include::Makefile.in b/databases/mysql54-server/files/patch-include::Makefile.in
deleted file mode 100644
index ed7654838e66..000000000000
--- a/databases/mysql54-server/files/patch-include::Makefile.in
+++ /dev/null
@@ -1,14 +0,0 @@
---- include/Makefile.in.orig Sat Jan 1 17:59:41 2000
-+++ include/Makefile.in Wed Jan 5 21:04:23 2000
-@@ -259,7 +259,11 @@
-
- install-am: all-am
- @$(MAKE) $(AM_MAKEFLAGS) install-exec-am install-data-am
-+.if defined(CLIENT_ONLY)
- install: install-am
-+.else
-+install:
-+.endif
- uninstall-am: uninstall-pkgincludeHEADERS
- uninstall: uninstall-am
- all-am: Makefile $(HEADERS) all-local