aboutsummaryrefslogtreecommitdiff
path: root/databases/mysql54-server/files
diff options
context:
space:
mode:
Diffstat (limited to 'databases/mysql54-server/files')
-rw-r--r--databases/mysql54-server/files/mysql-client.sh15
-rw-r--r--databases/mysql54-server/files/mysql-server.sh18
-rw-r--r--databases/mysql54-server/files/patch-Makefile.in16
-rw-r--r--databases/mysql54-server/files/patch-ab15
-rw-r--r--databases/mysql54-server/files/patch-af71
-rw-r--r--databases/mysql54-server/files/patch-ap11
-rw-r--r--databases/mysql54-server/files/patch-as16
-rw-r--r--databases/mysql54-server/files/patch-configure132
-rw-r--r--databases/mysql54-server/files/patch-include::Makefile.in14
9 files changed, 0 insertions, 308 deletions
diff --git a/databases/mysql54-server/files/mysql-client.sh b/databases/mysql54-server/files/mysql-client.sh
deleted file mode 100644
index bef414c12ed2..000000000000
--- a/databases/mysql54-server/files/mysql-client.sh
+++ /dev/null
@@ -1,15 +0,0 @@
-#!/bin/sh
-
-case "$1" in
- start)
- /sbin/ldconfig -m %%PREFIX%%/lib/mysql
- ;;
- stop)
- ;;
- *)
- echo ""
- echo "Usage: `basename $0` { start | stop }"
- echo ""
- exit 64
- ;;
-esac
diff --git a/databases/mysql54-server/files/mysql-server.sh b/databases/mysql54-server/files/mysql-server.sh
deleted file mode 100644
index 0ff5374c48f7..000000000000
--- a/databases/mysql54-server/files/mysql-server.sh
+++ /dev/null
@@ -1,18 +0,0 @@
-#!/bin/sh
-
-case "$1" in
- start)
- if [ -x %%PREFIX%%/bin/safe_mysqld ]; then
- %%PREFIX%%/bin/safe_mysqld --user=mysql > /dev/null & && echo -n ' mysqld'
- fi
- ;;
- stop)
- /usr/bin/killall mysqld > /dev/null 2>&1 && echo -n ' mysqld'
- ;;
- *)
- echo ""
- echo "Usage: `basename $0` { start | stop }"
- echo ""
- exit 64
- ;;
-esac
diff --git a/databases/mysql54-server/files/patch-Makefile.in b/databases/mysql54-server/files/patch-Makefile.in
deleted file mode 100644
index bed75f614ccc..000000000000
--- a/databases/mysql54-server/files/patch-Makefile.in
+++ /dev/null
@@ -1,16 +0,0 @@
---- Makefile.in.orig Wed Apr 18 10:54:42 2001
-+++ Makefile.in Sat Apr 21 13:00:23 2001
-@@ -181,8 +181,12 @@
- # These are built from source in the Docs directory
- EXTRA_DIST = INSTALL-SOURCE README COPYING COPYING.LIB MIRRORS
-
--SUBDIRS = include @docs_dirs@ @readline_dir@ @thread_dirs@ @sql_client_dirs@ @sql_server_dirs@ scripts tests man @bench_dirs@ support-files
-
-+.if defined(CLIENT_ONLY)
-+SUBDIRS = include @readline_dir@ @sql_client_dirs@ tests man
-+.else
-+SUBDIRS = include @thread_dirs@ @docs_dirs@ @sql_server_dirs@ scripts support-files
-+.endif
-
- # Relink after clean
- CLEANFILES = linked_client_sources linked_server_sources linked_libmysql_sources linked_libmysql_r_sources linked_include_sources
diff --git a/databases/mysql54-server/files/patch-ab b/databases/mysql54-server/files/patch-ab
deleted file mode 100644
index 2aa8724dd21f..000000000000
--- a/databases/mysql54-server/files/patch-ab
+++ /dev/null
@@ -1,15 +0,0 @@
---- scripts/mysql_install_db.sh.orig Sat Dec 16 22:49:02 2000
-+++ scripts/mysql_install_db.sh Mon Dec 18 11:55:07 2000
-@@ -301,12 +301,6 @@
- END_OF_DATA
- then
- echo ""
-- if test "$IN_RPM" -eq 0
-- then
-- echo "To start mysqld at boot time you have to copy support-files/mysql.server"
-- echo "to the right place for your system"
-- echo
-- fi
- echo "PLEASE REMEMBER TO SET A PASSWORD FOR THE MySQL root USER !"
- echo "This is done with:"
- echo "$bindir/mysqladmin -u root -p password 'new-password'"
diff --git a/databases/mysql54-server/files/patch-af b/databases/mysql54-server/files/patch-af
deleted file mode 100644
index 9c4a0b951402..000000000000
--- a/databases/mysql54-server/files/patch-af
+++ /dev/null
@@ -1,71 +0,0 @@
---- scripts/safe_mysqld.sh.orig Thu Apr 19 10:11:02 2001
-+++ scripts/safe_mysqld.sh Thu Apr 19 15:15:54 2001
-@@ -73,30 +73,9 @@
- done
- }
-
--MY_PWD=`pwd`
--# Check if we are starting this relative (for the binary release)
--if test -d $MY_PWD/data/mysql -a -f ./share/mysql/english/errmsg.sys -a \
-- -x ./bin/mysqld
--then
-- MY_BASEDIR_VERSION=$MY_PWD # Where bin, share and data are
-- ledir=$MY_BASEDIR_VERSION/bin # Where mysqld is
-- DATADIR=$MY_BASEDIR_VERSION/data
-- if test -z "$defaults"
-- then
-- defaults="--defaults-extra-file=$MY_BASEDIR_VERSION/data/my.cnf"
-- fi
--# Check if this is a 'moved install directory'
--elif test -f ./var/mysql/db.frm -a -f ./share/mysql/english/errmsg.sys -a \
-- -x ./libexec/mysqld
--then
-- MY_BASEDIR_VERSION=$MY_PWD # Where libexec, share and var are
-- ledir=$MY_BASEDIR_VERSION/libexec # Where mysqld is
-- DATADIR=$MY_BASEDIR_VERSION/var
--else
-- MY_BASEDIR_VERSION=@prefix@
-- DATADIR=@localstatedir@
-- ledir=@libexecdir@
--fi
-+MY_BASEDIR_VERSION=@prefix@
-+DATADIR=@localstatedir@
-+ledir=@libexecdir@
-
- MYSQL_UNIX_PORT=${MYSQL_UNIX_PORT:-@MYSQL_UNIX_ADDR@}
- MYSQL_TCP_PORT=${MYSQL_TCP_PORT:-@MYSQL_TCP_PORT@}
-@@ -240,34 +219,6 @@
- if test ! -f $pid_file # This is removed if normal shutdown
- then
- break
-- fi
--
-- if @IS_LINUX@
-- then
-- # Test if one process was hanging.
-- # This is only a fix for Linux (running as base 3 mysqld processes)
-- # but should work for the rest of the servers.
-- # The only thing is ps x => redhat 5 gives warnings when using ps -x.
-- # kill -9 is used or the process won't react on the kill.
-- numofproces=`ps xa | grep -v "grep" | grep -c $ledir/$MYSQLD`
-- echo -e "\nNumber of processes running now: $numofproces" | tee -a $err_log
-- I=1
-- while test "$I" -le "$numofproces"
-- do
-- PROC=`ps xa | grep $ledir/$MYSQLD | grep -v "grep" | tail -1`
-- for T in $PROC
-- do
-- break
-- done
-- # echo "TEST $I - $T **"
-- if kill -9 $T
-- then
-- echo "$MYSQLD process hanging, pid $T - killed" | tee -a $err_log
-- else
-- break
-- fi
-- I=`expr $I + 1`
-- done
- fi
-
- echo "`date +'%y%m%d %H:%M:%S mysqld restarted'`" | tee -a $err_log
diff --git a/databases/mysql54-server/files/patch-ap b/databases/mysql54-server/files/patch-ap
deleted file mode 100644
index 097b449a181a..000000000000
--- a/databases/mysql54-server/files/patch-ap
+++ /dev/null
@@ -1,11 +0,0 @@
---- strings/Makefile.in.orig Sat Jan 1 18:00:30 2000
-+++ strings/Makefile.in Mon Jan 3 17:21:19 2000
-@@ -145,7 +145,7 @@
- INCLUDES = @MT_INCLUDES@ -I$(srcdir)/../include -I../include
- pkglib_LIBRARIES = libmystrings.a
- #no assembler
--@ASSEMBLER_x86_TRUE@ASRCS = strings-x86.s longlong2str-x86.s
-+@ASSEMBLER_x86_TRUE@ASRCS = strings-x86.S longlong2str-x86.S
- @ASSEMBLER_x86_FALSE@@ASSEMBLER_sparc_TRUE@ASRCS = bmove_upp-sparc.s strappend-sparc.s strend-sparc.s strinstr-sparc.s strmake-sparc.s strmov-sparc.s strnmov-sparc.s strstr-sparc.s strxmov-sparc.s
- @ASSEMBLER_x86_FALSE@@ASSEMBLER_sparc_FALSE@ASRCS =
- # These file MUST all be on the same line!! Otherwise automake
diff --git a/databases/mysql54-server/files/patch-as b/databases/mysql54-server/files/patch-as
deleted file mode 100644
index 903bc9950a28..000000000000
--- a/databases/mysql54-server/files/patch-as
+++ /dev/null
@@ -1,16 +0,0 @@
---- sql/mysqld.cc.orig Sun Feb 13 02:40:18 2000
-+++ sql/mysqld.cc Mon Feb 21 21:24:51 2000
-@@ -63,8 +63,11 @@
- inline void reset_floating_point_exceptions()
- {
- /* Don't fall for overflow, underflow,divide-by-zero or loss of precision */
-- fpsetmask(~(FP_X_INV | FP_X_DNML | FP_X_OFL | FP_X_UFL |
-- FP_X_DZ | FP_X_IMP));
-+#if defined(__i386__)
-+ fpsetmask(~(FP_X_INV | FP_X_DNML | FP_X_OFL | FP_X_UFL | FP_X_DZ | FP_X_IMP));
-+#else
-+ fpsetmask(~(FP_X_INV | FP_X_OFL | FP_X_UFL | FP_X_DZ | FP_X_IMP));
-+#endif
- }
- #else
- #define reset_floating_point_exceptions()
diff --git a/databases/mysql54-server/files/patch-configure b/databases/mysql54-server/files/patch-configure
deleted file mode 100644
index f10ab97c44a8..000000000000
--- a/databases/mysql54-server/files/patch-configure
+++ /dev/null
@@ -1,132 +0,0 @@
---- configure.orig Wed May 9 22:34:50 2001
-+++ configure Sat May 12 11:23:21 2001
-@@ -2994,7 +2994,7 @@
- ;;
- esac
- fi
--HOSTNAME="$ac_cv_path_HOSTNAME"
-+HOSTNAME="$ac_cv_path_HOSTNAME -s"
- if test -n "$HOSTNAME"; then
- echo "$ac_t""$HOSTNAME" 1>&6
- else
-@@ -3128,38 +3128,7 @@
- echo $ac_n "checking "how to check if pid exists"""... $ac_c" 1>&6
- echo "configure:3130: checking "how to check if pid exists"" >&5
- PS=$ac_cv_path_PS
--# Linux style
--if $PS p $$ 2> /dev/null | grep $0 > /dev/null
--then
-- FIND_PROC="$PS p \$\$PID | grep mysqld > /dev/null"
--# Solaris
--elif $PS -p $$ 2> /dev/null | grep $0 > /dev/null
--then
-- FIND_PROC="$PS -p \$\$PID | grep mysqld > /dev/null"
--# BSD style
--elif $PS -uaxww 2> /dev/null | grep $0 > /dev/null
--then
-- FIND_PROC="$PS -uaxww | grep mysqld | grep \" \$\$PID \" > /dev/null"
--# SysV style
--elif $PS -ef 2> /dev/null | grep $0 > /dev/null
--then
-- FIND_PROC="$PS -ef | grep mysqld | grep \" \$\$PID \" > /dev/null"
--# Do anybody use this?
--elif $PS $$ 2> /dev/null | grep $0 > /dev/null
--then
-- FIND_PROC="$PS \$\$PID | grep mysqld > /dev/null"
--else
-- case $SYSTEM_TYPE in
-- *darwin*)
-- FIND_PROC="$PS -uaxww | grep mysqld | grep \" \$\$PID \" > /dev/null"
-- ;;
-- *cygwin*)
-- FIND_PROC="$PS -e | grep mysqld | grep \" \$\$PID \" > /dev/null"
-- ;;
-- *)
-- { echo "configure: error: Could not find the right ps switches. Which OS is this ?. See the Installation chapter in the Reference Manual." 1>&2; exit 1; }
-- esac
--fi
-+FIND_PROC="$PS -uaxww | grep mysqld | grep \" \$\$PID \" > /dev/null"
-
- echo "$ac_t"""$FIND_PROC"" 1>&6
-
-@@ -5922,7 +5891,6 @@
- #define $ac_tr_lib 1
- EOF
-
-- LIBS="-lc_r $LIBS"
-
- else
- echo "$ac_t""no" 1>&6
-@@ -6154,28 +6122,6 @@
- fi
-
-
--# Build optimized or debug version ?
--# First check for gcc and g++
--if test "$ac_cv_prog_gcc" = "yes"
--then
-- DEBUG_CFLAGS="-g"
-- DEBUG_OPTIMIZE_CC="-O"
-- OPTIMIZE_CFLAGS="$MAX_C_OPTIMIZE"
--else
-- DEBUG_CFLAGS="-g"
-- DEBUG_OPTIMIZE_CC=""
-- OPTIMIZE_CFLAGS="-O"
--fi
--if test "$ac_cv_prog_cxx_g" = "yes"
--then
-- DEBUG_CXXFLAGS="-g"
-- DEBUG_OPTIMIZE_CXX="-O"
-- OPTIMIZE_CXXFLAGS="-O3"
--else
-- DEBUG_CXXFLAGS="-g"
-- DEBUG_OPTIMIZE_CXX=""
-- OPTIMIZE_CXXFLAGS="-O"
--fi
- # Check whether --with-debug or --without-debug was given.
- if test "${with_debug+set}" = set; then
- withval="$with_debug"
-@@ -6856,10 +6802,6 @@
- ac_link='${CXX-g++} -o conftest${ac_exeext} $CXXFLAGS $CPPFLAGS $LDFLAGS conftest.$ac_ext $LIBS 1>&5'
- cross_compiling=$ac_cv_prog_cxx_cross
-
--if test "$ac_cv_prog_gxx" = "yes"
--then
-- CXXFLAGS="$CXXFLAGS -Werror"
--fi
- mysql_cv_btype_last_arg_accept=none
- cat > conftest.$ac_ext <<EOF
- #line 6866 "configure"
-@@ -9019,10 +8961,6 @@
- #do not treat warnings as errors if we are linking agaist other libc
- #this is to work around gcc not being permissive on non-system includes
- #with respect to ANSI C++
--if test "$ac_cv_prog_gxx" = "yes" -a "$with_other_libc" = "no"
--then
-- CXXFLAGS="$CXXFLAGS -Werror"
--fi
- cat > conftest.$ac_ext <<EOF
- #line 9028 "configure"
- #include "confdefs.h"
-@@ -9087,10 +9025,6 @@
- ac_link='${CXX-g++} -o conftest${ac_exeext} $CXXFLAGS $CPPFLAGS $LDFLAGS conftest.$ac_ext $LIBS 1>&5'
- cross_compiling=$ac_cv_prog_cxx_cross
-
--if test "$ac_cv_prog_gxx" = "yes" -a "$with_other_libc" = "no"
--then
-- CXXFLAGS="$CXXFLAGS -Werror"
--fi
- cat > conftest.$ac_ext <<EOF
- #line 9096 "configure"
- #include "confdefs.h"
-@@ -9154,10 +9088,6 @@
- ac_link='${CXX-g++} -o conftest${ac_exeext} $CXXFLAGS $CPPFLAGS $LDFLAGS conftest.$ac_ext $LIBS 1>&5'
- cross_compiling=$ac_cv_prog_cxx_cross
-
--if test "$ac_cv_prog_gxx" = "yes" -a "$with_other_libc" = "no"
--then
-- CXXFLAGS="$CXXFLAGS -Werror"
--fi
- cat > conftest.$ac_ext <<EOF
- #line 9163 "configure"
- #include "confdefs.h"
diff --git a/databases/mysql54-server/files/patch-include::Makefile.in b/databases/mysql54-server/files/patch-include::Makefile.in
deleted file mode 100644
index eb2d5e52e794..000000000000
--- a/databases/mysql54-server/files/patch-include::Makefile.in
+++ /dev/null
@@ -1,14 +0,0 @@
---- include/Makefile.in.orig Mon Jan 22 14:43:55 2001
-+++ include/Makefile.in Mon Jan 22 23:14:48 2001
-@@ -284,7 +284,11 @@
-
- install-am: all-am
- @$(MAKE) $(AM_MAKEFLAGS) install-exec-am install-data-am
-+.if defined(CLIENT_ONLY)
- install: install-am
-+.else
-+install:
-+.endif
- uninstall-am: uninstall-pkgincludeHEADERS
- uninstall: uninstall-am
- all-am: Makefile $(HEADERS) all-local