aboutsummaryrefslogtreecommitdiff
path: root/databases/p5-DBD-LDAP/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'databases/p5-DBD-LDAP/Makefile')
-rw-r--r--databases/p5-DBD-LDAP/Makefile15
1 files changed, 12 insertions, 3 deletions
diff --git a/databases/p5-DBD-LDAP/Makefile b/databases/p5-DBD-LDAP/Makefile
index 31a2ee441b4c..36dd1941d855 100644
--- a/databases/p5-DBD-LDAP/Makefile
+++ b/databases/p5-DBD-LDAP/Makefile
@@ -15,8 +15,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= svenasse@polaris.ca
COMMENT= DBI interface for accessing LDAP servers
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI \
- ${SITE_PERL}/Net/LDAP.pm:${PORTSDIR}/net/p5-perl-ldap
+BUILD_DEPENDS= ${SITE_PERL}/Net/LDAP.pm:${PORTSDIR}/net/p5-perl-ldap
RUN_DEPENDS= ${BUILD_DEPENDS}
SITE_PERL= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}
@@ -25,4 +24,14 @@ PERL_CONFIGURE= yes
MAN3= DBD::LDAP.3
MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI-137
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI-137
+.else
+BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
+.endif
+
+.include <bsd.port.post.mk>