aboutsummaryrefslogtreecommitdiff
path: root/databases/p5-DBD-mysql
diff options
context:
space:
mode:
Diffstat (limited to 'databases/p5-DBD-mysql')
-rw-r--r--databases/p5-DBD-mysql/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/databases/p5-DBD-mysql/Makefile b/databases/p5-DBD-mysql/Makefile
index 15a4b17527c1..6c5b4b05387b 100644
--- a/databases/p5-DBD-mysql/Makefile
+++ b/databases/p5-DBD-mysql/Makefile
@@ -33,4 +33,10 @@ BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
.endif
+post-patch:
+.if ${PERL_LEVEL} < 500600
+ @${PERL} -pi -e 's/(?:use|no) warnings;?//; s/our (%\w+)/use vars qw(\1);\n\1/' \
+ ${WRKSRC}/lib/DBD/mysql/GetInfo.pm
+.endif
+
.include <bsd.port.post.mk>