aboutsummaryrefslogtreecommitdiff
path: root/databases/p5-DBIx-Recordset/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'databases/p5-DBIx-Recordset/Makefile')
-rw-r--r--databases/p5-DBIx-Recordset/Makefile15
1 files changed, 11 insertions, 4 deletions
diff --git a/databases/p5-DBIx-Recordset/Makefile b/databases/p5-DBIx-Recordset/Makefile
index 97aa9a321f0f..430548be5239 100644
--- a/databases/p5-DBIx-Recordset/Makefile
+++ b/databases/p5-DBIx-Recordset/Makefile
@@ -15,9 +15,6 @@ PKGNAMEPREFIX= p5-
MAINTAINER= skv@FreeBSD.org
COMMENT= Perl module for abstraction and simplification of database access
-BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
-RUN_DEPENDS= ${BUILD_DEPENDS}
-
PERL_CONFIGURE= yes
MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
@@ -30,4 +27,14 @@ post-configure:
@${PERL} -pi -e 's/^(POD2MAN_EXE.*)$$/\1 -lax/;' \
${WRKSRC}/Makefile
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI-137
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI-137
+.else
+BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
+.endif
+
+.include <bsd.port.post.mk>