aboutsummaryrefslogtreecommitdiff
path: root/databases/pg_filedump/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'databases/pg_filedump/Makefile')
-rw-r--r--databases/pg_filedump/Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/databases/pg_filedump/Makefile b/databases/pg_filedump/Makefile
new file mode 100644
index 000000000000..6c8a53583921
--- /dev/null
+++ b/databases/pg_filedump/Makefile
@@ -0,0 +1,23 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+
+PORTNAME= pg_filedump
+PORTVERSION= 14.0
+CATEGORIES= databases
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Display formatted contents of a PostgreSQL heap, index, or control file
+
+LICENSE= GPLv2+
+
+USES= gmake pgsql
+
+MAKE_ARGS= PG_LDFLAGS=-lintl
+WANT_PGSQL= lib server
+
+PLIST_FILES= bin/pg_filedump
+
+GH_ACCOUNT= df7cb
+GH_TAGNAME= REL_${PORTVERSION:R}_${PORTVERSION:E}
+USE_GITHUB= yes
+
+.include <bsd.port.mk>