aboutsummaryrefslogtreecommitdiff
path: root/databases/postgresql-libpqxx3/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'databases/postgresql-libpqxx3/Makefile')
-rw-r--r--databases/postgresql-libpqxx3/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/databases/postgresql-libpqxx3/Makefile b/databases/postgresql-libpqxx3/Makefile
new file mode 100644
index 000000000000..5b6442355736
--- /dev/null
+++ b/databases/postgresql-libpqxx3/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: PostgreSQL Pgaccess
+# Date created: December 1st, 2002
+# Whom: Palle Girgensohn <girgen@pingpong.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libpqxx
+PORTVERSION= 1.1.4
+CATEGORIES= databases
+MASTER_SITES= ftp://gborg.postgresql.org/pub/libpqxx/stable/
+DIST_SUBDIR= postgresql
+
+MAINTAINER= girgen@pingpong.net
+
+POSTGRESQL_PORT?= databases/postgresql7
+LIB_DEPENDS= pq.3:${PORTSDIR}/${POSTGRESQL_PORT}
+
+USE_GMAKE= YES
+GNU_CONFIGURE= YES
+USE_REINPLACE= YES
+INSTALLS_SHLIB= YES
+
+CONFIGURE_ARGS= --with-postgres=${LOCALBASE} \
+ --with-postgres-include=${LOCALBASE}/include/postgresql
+
+.include <bsd.port.mk>