aboutsummaryrefslogtreecommitdiff
path: root/databases/postgresql-libpqxx30
diff options
context:
space:
mode:
Diffstat (limited to 'databases/postgresql-libpqxx30')
-rw-r--r--databases/postgresql-libpqxx30/Makefile39
-rw-r--r--databases/postgresql-libpqxx30/distinfo3
-rw-r--r--databases/postgresql-libpqxx30/files/patch-Makefile.in11
-rw-r--r--databases/postgresql-libpqxx30/pkg-descr18
-rw-r--r--databases/postgresql-libpqxx30/pkg-plist63
5 files changed, 0 insertions, 134 deletions
diff --git a/databases/postgresql-libpqxx30/Makefile b/databases/postgresql-libpqxx30/Makefile
deleted file mode 100644
index 23d048acc0af..000000000000
--- a/databases/postgresql-libpqxx30/Makefile
+++ /dev/null
@@ -1,39 +0,0 @@
-# New ports collection makefile for: PostgreSQL Pgaccess
-# Date created: December 1st, 2002
-# Whom: Palle Girgensohn <girgen@pingpong.net>
-#
-# $FreeBSD$
-#
-
-PORTNAME= libpqxx
-PORTVERSION= 2.6.9
-CATEGORIES= databases
-MASTER_SITES= ftp://thaiopensource.org/%SUBDIR%/
-MASTER_SITE_SUBDIR= software/libpqxx
-PKGNAMEPREFIX= postgresql-
-DIST_SUBDIR= postgresql
-
-MAINTAINER= girgen@FreeBSD.org
-COMMENT= A new C++ interface for PostgreSQL
-
-USE_PGSQL= yes
-USE_GMAKE= yes
-GNU_CONFIGURE= yes
-INSTALLS_SHLIB= yes
-PLIST_SUB= PORTVERSION=${PORTVERSION}
-
-CONFIGURE_ARGS= --with-postgres=${LOCALBASE} \
- --enable-shared \
- --with-postgres-include=${LOCALBASE}/include/postgresql
-
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500035
-BUILD_DEPENDS+= ${LOCALBASE}/lib/libstlport_gcc.so:${PORTSDIR}/devel/stlport
-RUN_DEPENDS+= ${LOCALBASE}/lib/libstlport_gcc.so:${PORTSDIR}/devel/stlport
-CPPFLAGS+= -I${LOCALBASE}/include/stlport
-LDFLAGS+= -L${LOCALBASE}/lib -lstlport_gcc ${PTHREAD_LIBS}
-CONFIGURE_ENV+= LDFLAGS="${LDFLAGS}" CPPFLAGS="${CPPFLAGS}"
-.endif
-
-.include <bsd.port.post.mk>
diff --git a/databases/postgresql-libpqxx30/distinfo b/databases/postgresql-libpqxx30/distinfo
deleted file mode 100644
index a2317f085c51..000000000000
--- a/databases/postgresql-libpqxx30/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 (postgresql/libpqxx-2.6.9.tar.gz) = 0b0c64af41dfdeea8556dc359994e1cb
-SHA256 (postgresql/libpqxx-2.6.9.tar.gz) = 2b2ef5dfb852667299e50727419075cf333bbbeffadaa398d96dc93bac6f7b6a
-SIZE (postgresql/libpqxx-2.6.9.tar.gz) = 1639557
diff --git a/databases/postgresql-libpqxx30/files/patch-Makefile.in b/databases/postgresql-libpqxx30/files/patch-Makefile.in
deleted file mode 100644
index d1dd4d32ceef..000000000000
--- a/databases/postgresql-libpqxx30/files/patch-Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- Makefile.in~ Sat May 27 12:46:50 2006
-+++ Makefile.in Sun May 28 17:51:23 2006
-@@ -212,7 +212,7 @@
-
-
- #includedir=$(prefix)/include
--pkgconfigdir = $(libdir)/pkgconfig
-+pkgconfigdir = $(prefix)/libdata/pkgconfig
- pkgconfig_DATA = libpqxx.pc
- bin_SCRIPTS = pqxx-config
- all: all-recursive
diff --git a/databases/postgresql-libpqxx30/pkg-descr b/databases/postgresql-libpqxx30/pkg-descr
deleted file mode 100644
index 5697d09a3e4d..000000000000
--- a/databases/postgresql-libpqxx30/pkg-descr
+++ /dev/null
@@ -1,18 +0,0 @@
-Welcome to libpqxx, the official C++ API to the PostgreSQL database
-management system.
-
-There are many similar libraries for PostgreSQL and for other
-databases, some of them database-independent. Most of these, however,
-are fairly C-like in their programming style, and fail to take
-advantage of the full power of the C++ language as it has matured
-since the acceptance of the Standard in 1996. What libpqxx brings you
-is effective use of templates to reduce the inconvenience of dealing
-with type conversions; of standard C++ strings to keep you from having
-to worry about buffer allocation and overflow attacks; of exceptions
-to take the tedious and error-prone plumbing around error handling out
-of your hands; of constructors and destructors to bring resource
-management under control; and even basic object-orientation to give
-you some extra reliability features that would be hard to get with
-most other database interfaces.
-
-WWW: http://pqxx.org/
diff --git a/databases/postgresql-libpqxx30/pkg-plist b/databases/postgresql-libpqxx30/pkg-plist
deleted file mode 100644
index 9ae9e250a3eb..000000000000
--- a/databases/postgresql-libpqxx30/pkg-plist
+++ /dev/null
@@ -1,63 +0,0 @@
-bin/pqxx-config
-include/pqxx/basic_connection
-include/pqxx/basic_connection.hxx
-include/pqxx/binarystring
-include/pqxx/binarystring.hxx
-include/pqxx/cachedresult.h
-include/pqxx/compiler-internal-post.hxx
-include/pqxx/compiler-internal-pre.hxx
-include/pqxx/compiler-public.hxx
-include/pqxx/config-public-compiler.h
-include/pqxx/connection
-include/pqxx/connection.hxx
-include/pqxx/connection_base
-include/pqxx/connection_base.hxx
-include/pqxx/connectionpolicy
-include/pqxx/connectionpolicy.hxx
-include/pqxx/cursor
-include/pqxx/cursor.h
-include/pqxx/cursor.hxx
-include/pqxx/dbtransaction
-include/pqxx/dbtransaction.hxx
-include/pqxx/except
-include/pqxx/except.hxx
-include/pqxx/isolation
-include/pqxx/isolation.hxx
-include/pqxx/largeobject
-include/pqxx/largeobject.hxx
-include/pqxx/libpq-forward.hxx
-include/pqxx/nontransaction
-include/pqxx/nontransaction.hxx
-include/pqxx/pipeline
-include/pqxx/pipeline.hxx
-include/pqxx/pqxx
-include/pqxx/prepared_statement
-include/pqxx/prepared_statement.hxx
-include/pqxx/result
-include/pqxx/result.hxx
-include/pqxx/robusttransaction
-include/pqxx/robusttransaction.hxx
-include/pqxx/subtransaction
-include/pqxx/subtransaction.hxx
-include/pqxx/tablereader
-include/pqxx/tablereader.hxx
-include/pqxx/tablestream
-include/pqxx/tablestream.hxx
-include/pqxx/tablewriter
-include/pqxx/tablewriter.hxx
-include/pqxx/transaction
-include/pqxx/transaction.hxx
-include/pqxx/transaction_base
-include/pqxx/transaction_base.hxx
-include/pqxx/transactor
-include/pqxx/transactor.hxx
-include/pqxx/trigger
-include/pqxx/trigger.hxx
-include/pqxx/util
-include/pqxx/util.hxx
-lib/libpqxx-%%PORTVERSION%%.so
-lib/libpqxx.a
-lib/libpqxx.la
-lib/libpqxx.so
-libdata/pkgconfig/libpqxx.pc
-@dirrm include/pqxx