aboutsummaryrefslogtreecommitdiff
path: root/databases/postgresql-plproxy/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'databases/postgresql-plproxy/Makefile')
-rw-r--r--databases/postgresql-plproxy/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/databases/postgresql-plproxy/Makefile b/databases/postgresql-plproxy/Makefile
new file mode 100644
index 000000000000..742000543b02
--- /dev/null
+++ b/databases/postgresql-plproxy/Makefile
@@ -0,0 +1,26 @@
+# Ports collection makefile for: postgresql-plproxy
+# Date created: 27 July 2007
+# Whom: Sergey Skvortsov <skv@protey.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= plproxy
+PORTVERSION= 2.0.2
+CATEGORIES= databases
+MASTER_SITES= http://pgfoundry.org/frs/download.php/1355/
+PKGNAMEPREFIX= postgresql-
+
+MAINTAINER= skv@FreeBSD.org
+COMMENT= PL/Proxy is database partitioning system
+
+BUILD_DEPENDS= ${LOCALBASE}/bin/flex:${PORTSDIR}/textproc/flex
+
+USE_PGSQL= yes
+USE_GMAKE= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e 's= flex= ${LOCALBASE}/bin/flex=g' \
+ ${WRKSRC}/Makefile
+
+.include <bsd.port.mk>