aboutsummaryrefslogtreecommitdiff
path: root/databases/postgresql83-server
diff options
context:
space:
mode:
Diffstat (limited to 'databases/postgresql83-server')
-rw-r--r--databases/postgresql83-server/Makefile130
-rw-r--r--databases/postgresql83-server/distinfo1
-rw-r--r--databases/postgresql83-server/files/patch-aj69
-rw-r--r--databases/postgresql83-server/files/patch-ar16
-rw-r--r--databases/postgresql83-server/files/pgsql.sh.tmpl25
-rw-r--r--databases/postgresql83-server/files/post-install-notes13
-rw-r--r--databases/postgresql83-server/pkg-comment1
-rw-r--r--databases/postgresql83-server/pkg-descr24
-rw-r--r--databases/postgresql83-server/pkg-plist352
-rw-r--r--databases/postgresql83-server/scripts/createuser50
10 files changed, 0 insertions, 681 deletions
diff --git a/databases/postgresql83-server/Makefile b/databases/postgresql83-server/Makefile
deleted file mode 100644
index dfcb47f46fe7..000000000000
--- a/databases/postgresql83-server/Makefile
+++ /dev/null
@@ -1,130 +0,0 @@
-# New ports collection makefile for: PostgreSQL
-# Version required: 6.4
-# Date created: November 13, 1998
-# Whom: Marc G. Fournier <scrappy@FreeBSD.ORG>
-#
-# $Id: Makefile,v 1.32 1999/01/12 18:17:42 scrappy Exp $
-#
-
-DISTNAME= postgresql-6.4.2
-CATEGORIES= databases
-MASTER_SITES= ftp://ftp.postgresql.org/pub/
-
-MAINTAINER= andreas@FreeBSD.ORG
-
-Y2K= http://www.postgresql.org/y2k.html
-
-# if you want to use the tcl/tk frontend pgaccess, then you need to build
-# postgresql with tcl support by typing: make USE_TCL=yes
-.if defined(USE_TCL)
-TCL_INCDIR= ${PREFIX}/include/tcl8.0
-TK_INCDIR= ${PREFIX}/include/tk8.0
-MAKE_ENV= USE_TCL=true TCL_INCDIR=${TCL_INCDIR}
-LIB_DEPENDS= tcl80.1:${PORTSDIR}/lang/tcl80 tk80.1:${PORTSDIR}/x11-toolkits/tk80
-WITH_TCL= --with-tcl --with-tclconfig="${PREFIX}/lib/tcl8.0 ${PREFIX}/lib/tk8.0"
-.endif
-
-NO_PACKAGE= "Requires pgsql uid"
-WRKSRC= ${WRKDIR}/${DISTNAME}/src
-
-USE_GMAKE= YES
-MAKEFILE= GNUmakefile
-HAS_CONFIGURE= YES
-CONFIGURE_ARGS= --prefix=${PREFIX}/pgsql \
- --enable-locale \
- --with-template=`uname -s | ${TR} '[A-Z]' '[a-z]'` \
- --with-includes="/usr/local/include ${TCL_INCDIR} ${TK_INCDIR}" ${WITH_TCL} \
- --with-libraries=/usr/local/lib
-
-INSTALL_TARGET= install install-man
-
-MAN1= cleardbdir.1 createdb.1 createuser.1 destroydb.1 \
- destroyuser.1 ecpg.1 initdb.1 initlocation.1 \
- ipcclean.1 pg_dump.1 pg_dumpall.1 pg_passwd.1 \
- pg_upgrade.1 postgres.1 postmaster.1 psql.1
-MAN3= catalogs.3 libpq.3
-MAN5= pg_hba.conf.5
-MANL= abort.l alter_table.l alter_user.l begin.l close.l cluster.l \
- commit.l copy.l create_aggregate.l create_database.l \
- create_function.l create_index.l create_language.l \
- create_operator.l create_rule.l create_sequence.l \
- create_table.l create_trigger.l create_type.l create_user.l \
- create_version.l create_view.l declare.l delete.l drop.l \
- drop_aggregate.l drop_database.l drop_function.l drop_index.l \
- drop_language.l drop_operator.l drop_rule.l drop_sequence.l \
- drop_table.l drop_trigger.l drop_type.l drop_user.l \
- drop_view.l end.l explain.l fetch.l grant.l insert.l listen.l \
- load.l lock.l move.l notify.l reset.l revoke.l rollback.l \
- select.l set.l show.l sql.l update.l vacuum.l
-
-MANPREFIX= ${PREFIX}/pgsql
-
-pre-fetch:
-.if !defined(USE_TCL)
- @${ECHO_MSG} "To build the \"PostgreSQL to Tcl interface library\", libpgtcl, type:"
- @${ECHO_MSG} " make USE_TCL=yes"
-.else
- @${ECHO_MSG} "Building PostgreSQL with \"libpgtcl\"."
-.endif
-
-post-patch:
-
- @ ${MV} ${WRKSRC}/template/freebsd ${WRKSRC}/template/freebsd.orig
- @ ${SED} -e 's#CFLAGS:-O2 -m486 -pipe#CFLAGS:${CFLAGS}#' \
- -e 's#USE_LOCALE:no#USE_LOCALE:yes#' \
- ${WRKSRC}/template/freebsd.orig >> ${WRKSRC}/template/freebsd
-
-post-build:
- @ ${ECHO} "------------------------------------------------------------"
- @ ${ECHO} "Dump existing databases, before installing new db version !!"
- @ ${ECHO} "Detailed instructions, see INSTALL file under ${WRKDIR}... "
- @ ${ECHO} "------------------------------------------------------------"
-
-pre-install:
-.if defined(PACKAGE_BUILDING)
- /bin/rm -rf ${PREFIX}/pgsql
-.endif
- @ ${MKDIR} ${PREFIX}/pgsql
- @ ${SETENV} ${MAKE_ENV} perl ${SCRIPTDIR}/createuser
-
-post-install:
- @ if [ ! -f ${PREFIX}/pgsql/.profile ]; then \
- ${ECHO} "PATH=${PATH}:${PREFIX}/pgsql/bin" \
- > ${PREFIX}/pgsql/.profile; \
- ${ECHO} "MANPATH=${MANPATH}:${PREFIX}/pgsql/bin" \
- >> ${PREFIX}/pgsql/.profile; \
- ${ECHO} "PGLIB=${PREFIX}/pgsql/lib" \
- >> ${PREFIX}/pgsql/.profile; \
- ${ECHO} "# note: PGDATA overwrites the -D startup option" \
- >> ${PREFIX}/pgsql/.profile; \
- ${ECHO} "PGDATA=${PREFIX}/pgsql/data" \
- >> ${PREFIX}/pgsql/.profile; \
- ${ECHO} "DISPLAY=:0" \
- >> ${PREFIX}/pgsql/.profile; \
- ${ECHO} "export PATH MANPATH PGLIB PGDATA DISPLAY" \
- >> ${PREFIX}/pgsql/.profile; \
- ${ECHO} "# if you want to make regression tests use this TZ" \
- >> ${PREFIX}/pgsql/.profile; \
- ${ECHO} "#TZ=PST8PDT" \
- >> ${PREFIX}/pgsql/.profile; \
- ${ECHO} "#export TZ" \
- >> ${PREFIX}/pgsql/.profile; \
- fi
- @ chown -R pgsql:pgsql ${PREFIX}/pgsql
- @ ${ECHO} 'Initializing PostgreSQL Databases - this may take a few minutes...'
- @ ${SETENV} OBJFORMAT=${PORTOBJFORMAT} ${LDCONFIG} -m ${PREFIX}/pgsql/lib
- @ su -l pgsql -c '${PREFIX}/pgsql/bin/initdb --pglib=${PREFIX}/pgsql/lib --pgdata=${PREFIX}/pgsql/data'
- @ ${SED} -e "s=!!PREFIX!!=${PREFIX}=g" < ${FILESDIR}/pgsql.sh.tmpl \
- > ${PREFIX}/etc/rc.d/pgsql.sh
- @ chmod 554 ${PREFIX}/etc/rc.d/pgsql.sh
- @ chown root.pgsql ${PREFIX}/etc/rc.d/pgsql.sh
- @ ${INSTALL_DATA} ${FILESDIR}/post-install-notes ${PREFIX}/pgsql
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${PREFIX}/share/doc/pgsql
- ${CP} -r ${WRKDIR}/${DISTNAME}/doc/* ${PREFIX}/share/doc/pgsql
-.endif
-.if !defined(BATCH)
- @ more -e ${FILESDIR}/post-install-notes
-.endif
-
-.include <bsd.port.mk>
diff --git a/databases/postgresql83-server/distinfo b/databases/postgresql83-server/distinfo
deleted file mode 100644
index 3431e4c195e1..000000000000
--- a/databases/postgresql83-server/distinfo
+++ /dev/null
@@ -1 +0,0 @@
-MD5 (postgresql-6.4.2.tar.gz) = 4f5e0409921892ca08fff2d8c099b3d7
diff --git a/databases/postgresql83-server/files/patch-aj b/databases/postgresql83-server/files/patch-aj
deleted file mode 100644
index 0f7dc20db53d..000000000000
--- a/databases/postgresql83-server/files/patch-aj
+++ /dev/null
@@ -1,69 +0,0 @@
---- bin/pg_passwd/pg_passwd.c.orig Sat Jan 31 19:09:26 1998
-+++ bin/pg_passwd/pg_passwd.c Sat Jan 31 19:15:43 1998
-@@ -23,12 +23,16 @@
-
- #endif
-
-+#ifndef _POSIX_SOURCE
-+# define _PASSWORD_LEN 128 /* max length, not containing NULL */
-+#endif
-+
- char *comname;
- void usage(FILE *stream);
- void read_pwd_file(char *filename);
- void write_pwd_file(char *filename, char *bkname);
--void encrypt_pwd(char key[9], char salt[3], char passwd[14]);
--int check_pwd(char key[9], char passwd[14]);
-+void encrypt_pwd(char key[9], char salt[3], char passwd[_PASSWORD_LEN+1]);
-+int check_pwd(char key[9], char passwd[_PASSWORD_LEN+1]);
- void prompt_for_username(char *username);
- void prompt_for_password(char *prompt, char *password);
-
-@@ -148,7 +152,7 @@
-
- if (q != NULL)
- *(q++) = '\0';
-- if (strlen(p) != 13)
-+ if (strlen(p) > _PASSWORD_LEN)
- {
- fprintf(stderr, "WARNING: %s: line %d: illegal password length.\n",
- filename, npwds + 1);
-@@ -208,7 +212,7 @@
- }
-
- void
--encrypt_pwd(char key[9], char salt[3], char passwd[14])
-+encrypt_pwd(char key[9], char salt[3], char passwd[_PASSWORD_LEN+1])
- {
- int n;
-
-@@ -242,9 +246,9 @@
- }
-
- int
--check_pwd(char key[9], char passwd[14])
-+check_pwd(char key[9], char passwd[_PASSWORD_LEN+1])
- {
-- char shouldbe[14];
-+ char shouldbe[_PASSWORD_LEN+1];
- char salt[3];
-
- salt[0] = passwd[0];
-@@ -252,7 +256,7 @@
- salt[2] = '\0';
- encrypt_pwd(key, salt, shouldbe);
-
-- return strncmp(shouldbe, passwd, 13) == 0 ? 1 : 0;
-+ return strncmp(shouldbe, passwd, _PASSWORD_LEN) == 0 ? 1 : 0;
- }
-
- void
-@@ -326,7 +330,7 @@
- char salt[3];
- char key[9],
- key2[9];
-- char e_passwd[14];
-+ char e_passwd[_PASSWORD_LEN+1];
- int i;
-
- comname = argv[0];
diff --git a/databases/postgresql83-server/files/patch-ar b/databases/postgresql83-server/files/patch-ar
deleted file mode 100644
index a1fd3d50d464..000000000000
--- a/databases/postgresql83-server/files/patch-ar
+++ /dev/null
@@ -1,16 +0,0 @@
---- Makefile.shlib.orig Wed Feb 3 19:16:02 1999
-+++ Makefile.shlib Wed Feb 3 19:18:28 1999
-@@ -59,10 +59,11 @@
- ifeq ($(PORTNAME), freebsd)
- ifdef BSD_SHLIB
- install-shlib-dep := install-shlib
-- shlib := lib$(NAME)$(DLSUFFIX).$(SO_MAJOR_VERSION).$(SO_MINOR_VERSION)
- ifdef ELF_SYSTEM
-- LDFLAGS_SL := -x -Bshareable
-+ shlib := lib$(NAME)$(DLSUFFIX).$(SO_MAJOR_VERSION)
-+ LDFLAGS_SL := -x -shared -soname $(shlib)
- else
-+ shlib := lib$(NAME)$(DLSUFFIX).$(SO_MAJOR_VERSION).$(SO_MINOR_VERSION)
- LDFLAGS_SL := -x -Bshareable -Bforcearchive
- endif
- CFLAGS += $(CFLAGS_SL)
diff --git a/databases/postgresql83-server/files/pgsql.sh.tmpl b/databases/postgresql83-server/files/pgsql.sh.tmpl
deleted file mode 100644
index ed6c54d18839..000000000000
--- a/databases/postgresql83-server/files/pgsql.sh.tmpl
+++ /dev/null
@@ -1,25 +0,0 @@
-#!/bin/sh
-
-# $Id: pgsql.sh.tmpl,v 1.3 1997/10/05 21:00:49 andreas Exp $
-
-# pgsql.sh - postgresql startup file for FreeBSD and possibly *BSD (untested)
-
-# Changes:
-# - renamed startup script to be in sync with INSTALL file
-# - merged ldconfig start sequence from former postgrsql.sh script (andreas)
-# - modified the postmaster startup sequence as suggested in the
-# INSTALL file which was given as example for FreeBSD 2.2 (andreas)
-# - removed the commandline option
-# -D!!PREFIX!!/pgsql/data \
-# because the postmaster process, which starts up under the
-# environment of the pgsql user, sets this with the PGDATA
-# environment variable in !!PREFIX!!/pgsql/.profile
-#
-
-[ -d !!PREFIX!!/pgsql/lib ] && /sbin/ldconfig -m !!PREFIX!!/pgsql/lib
-
-[ -x !!PREFIX!!/pgsql/bin/postmaster ] && {
- su -l pgsql -c 'exec !!PREFIX!!/pgsql/bin/postmaster -i -S -o -F \
- -D!!PREFIX!!/pgsql/data > !!PREFIX!!/pgsql/errlog'
- echo -n ' pgsql'
-}
diff --git a/databases/postgresql83-server/files/post-install-notes b/databases/postgresql83-server/files/post-install-notes
deleted file mode 100644
index a57562fe871e..000000000000
--- a/databases/postgresql83-server/files/post-install-notes
+++ /dev/null
@@ -1,13 +0,0 @@
-
-Now that PostgreSQL is installed, you should read the documentation and
-implementation guides. These can be found at:
-
- http://www.PostgreSQL.org/docs
-
-You may wish to subscribe to the PostgreSQL user-support mailing list.
-Send an e-mail to pgsql-questions-request@postgresql.org with the
-text "subscribe" in the message body.
-
-If you build PostgreSQL with TCL support, then you can use the
-TCL/TK based database frontend "pgaccess" for database operations.
-
diff --git a/databases/postgresql83-server/pkg-comment b/databases/postgresql83-server/pkg-comment
deleted file mode 100644
index 85dbe3e67c4c..000000000000
--- a/databases/postgresql83-server/pkg-comment
+++ /dev/null
@@ -1 +0,0 @@
-a robust, next generation, object-relational DBMS
diff --git a/databases/postgresql83-server/pkg-descr b/databases/postgresql83-server/pkg-descr
deleted file mode 100644
index f0283be0cd64..000000000000
--- a/databases/postgresql83-server/pkg-descr
+++ /dev/null
@@ -1,24 +0,0 @@
-PostgreSQL is a robust, next-generation, Object-Relational DBMS (ORDBMS),
-derived from the Berkeley Postgres database management system. While
-PostgreSQL retains the powerful object-relational data model, rich data types
-and easy extensibility of Postgres, it replaces the PostQuel query language
-with an extended subset of SQL.
-
-The original Postgres code was the effort of many graduate students,
-undergraduate students, and staff programmers working under the direction of
-Professor Michael Stonebraker at the University of California, Berkeley. In
-1995, Andrew Yu and Jolly Chen took on the task of converting the DBMS query
-language to SQL and created a new database system which came to known as
-Postgres95. Many others contributed to the porting, testing, debugging and
-enhancement of the Postgres95 code. As the code improved, and 1995 faded into
-memory, PostgreSQL was born.
-
-PostgreSQL development is presently being performed by a team of Internet
-developers who are now responsible for all current and future development. The
-development team coordinator is Marc G. Fournier (scrappy@PostgreSQL.ORG).
-Support is available from the PostgreSQL developer/user community through the
-support mailing list (questions@PostgreSQL.ORG).
-
-PostgreSQL is free and the complete source is available.
-
-More information and documentation, visit: http://www.PostgreSQL.ORG/
diff --git a/databases/postgresql83-server/pkg-plist b/databases/postgresql83-server/pkg-plist
deleted file mode 100644
index f0ddecf29ce0..000000000000
--- a/databases/postgresql83-server/pkg-plist
+++ /dev/null
@@ -1,352 +0,0 @@
-etc/rc.d/pgsql.sh
-pgsql/.profile
-pgsql/bin/cleardbdir
-pgsql/bin/createdb
-pgsql/bin/createuser
-pgsql/bin/destroydb
-pgsql/bin/destroyuser
-pgsql/bin/ecpg
-pgsql/bin/initdb
-pgsql/bin/initlocation
-pgsql/bin/ipcclean
-pgsql/bin/pg_dump
-pgsql/bin/pg_dumpall
-pgsql/bin/pg_id
-pgsql/bin/pg_passwd
-pgsql/bin/pg_upgrade
-pgsql/bin/pg_version
-pgsql/bin/postgres
-pgsql/bin/postmaster
-pgsql/bin/psql
-pgsql/data/PG_VERSION
-pgsql/data/base/template1/PG_VERSION
-pgsql/data/base/template1/pg_aggregate
-pgsql/data/base/template1/pg_am
-pgsql/data/base/template1/pg_amop
-pgsql/data/base/template1/pg_amproc
-pgsql/data/base/template1/pg_attrdef
-pgsql/data/base/template1/pg_attrdef_adrelid_index
-pgsql/data/base/template1/pg_attribute
-pgsql/data/base/template1/pg_attribute_attrelid_index
-pgsql/data/base/template1/pg_attribute_relid_attnam_index
-pgsql/data/base/template1/pg_attribute_relid_attnum_index
-pgsql/data/base/template1/pg_class
-pgsql/data/base/template1/pg_class_oid_index
-pgsql/data/base/template1/pg_class_relname_index
-pgsql/data/base/template1/pg_description
-pgsql/data/base/template1/pg_description_objoid_index
-pgsql/data/base/template1/pg_index
-pgsql/data/base/template1/pg_indexes
-pgsql/data/base/template1/pg_inheritproc
-pgsql/data/base/template1/pg_inherits
-pgsql/data/base/template1/pg_internal.init
-pgsql/data/base/template1/pg_ipl
-pgsql/data/base/template1/pg_language
-pgsql/data/base/template1/pg_listener
-pgsql/data/base/template1/pg_opclass
-pgsql/data/base/template1/pg_operator
-pgsql/data/base/template1/pg_parg
-pgsql/data/base/template1/pg_proc
-pgsql/data/base/template1/pg_proc_oid_index
-pgsql/data/base/template1/pg_proc_proname_narg_type_index
-pgsql/data/base/template1/pg_proc_prosrc_index
-pgsql/data/base/template1/pg_relcheck
-pgsql/data/base/template1/pg_relcheck_rcrelid_index
-pgsql/data/base/template1/pg_rewrite
-pgsql/data/base/template1/pg_rules
-pgsql/data/base/template1/pg_statistic
-pgsql/data/base/template1/pg_tables
-pgsql/data/base/template1/pg_trigger
-pgsql/data/base/template1/pg_trigger_tgrelid_index
-pgsql/data/base/template1/pg_type
-pgsql/data/base/template1/pg_type_oid_index
-pgsql/data/base/template1/pg_type_typname_index
-pgsql/data/base/template1/pg_user
-pgsql/data/base/template1/pg_views
-pgsql/data/pg_database
-pgsql/data/pg_geqo.sample
-pgsql/data/pg_group
-pgsql/data/pg_hba.conf
-pgsql/data/pg_log
-pgsql/data/pg_pwd
-pgsql/data/pg_shadow
-pgsql/data/pg_variable
-pgsql/include/access/attnum.h
-pgsql/include/c.h
-pgsql/include/commands/trigger.h
-pgsql/include/config.h
-pgsql/include/ecpgerrno.h
-pgsql/include/ecpglib.h
-pgsql/include/ecpgtype.h
-pgsql/include/executor/spi.h
-pgsql/include/fmgr.h
-pgsql/include/lib/dllist.h
-pgsql/include/libpq++.h
-pgsql/include/libpq++/pgconnection.h
-pgsql/include/libpq++/pgcursordb.h
-pgsql/include/libpq++/pgdatabase.h
-pgsql/include/libpq++/pgenv.h
-pgsql/include/libpq++/pglobject.h
-pgsql/include/libpq++/pgtransdb.h
-pgsql/include/libpq-fe.h
-pgsql/include/libpq-int.h
-pgsql/include/libpq/libpq-fs.h
-pgsql/include/libpq/pqcomm.h
-pgsql/include/os.h
-pgsql/include/postgres.h
-pgsql/include/postgres_ext.h
-pgsql/include/sqlca.h
-pgsql/include/utils/elog.h
-pgsql/include/utils/geo_decls.h
-pgsql/include/utils/palloc.h
-pgsql/lib/global1.bki.source
-pgsql/lib/global1.description
-pgsql/lib/libecpg.a
-pgsql/lib/libecpg.so
-pgsql/lib/libecpg.so.2
-pgsql/lib/libpq++.a
-pgsql/lib/libpq++.so
-pgsql/lib/libpq++.so.2
-pgsql/lib/libpq.a
-pgsql/lib/libpq.so
-pgsql/lib/libpq.so.2
-pgsql/lib/local1_template1.bki.source
-pgsql/lib/local1_template1.description
-pgsql/lib/pg_geqo.sample
-pgsql/lib/pg_hba.conf.sample
-pgsql/lib/plpgsql.so
-@exec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -m %B
-@unexec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -R
-pgsql/post-install-notes
-share/doc/pgsql/CVS/Entries
-share/doc/pgsql/CVS/Repository
-share/doc/pgsql/CVS/Root
-share/doc/pgsql/CVS/Tag
-share/doc/pgsql/FAQ
-share/doc/pgsql/FAQ_CVS
-share/doc/pgsql/FAQ_DEV
-share/doc/pgsql/FAQ_FreeBSD
-share/doc/pgsql/FAQ_HPUX
-share/doc/pgsql/FAQ_Irix
-share/doc/pgsql/FAQ_Linux
-share/doc/pgsql/Makefile
-share/doc/pgsql/README.fsync
-share/doc/pgsql/README.inet
-share/doc/pgsql/README.locale
-share/doc/pgsql/README.mb
-share/doc/pgsql/README.mb.jp
-share/doc/pgsql/TODO
-share/doc/pgsql/admin.ps.gz
-share/doc/pgsql/admin.tar.gz
-share/doc/pgsql/bug.template
-share/doc/pgsql/postgres.tar.gz
-share/doc/pgsql/programmer.ps.gz
-share/doc/pgsql/programmer.tar.gz
-share/doc/pgsql/src/CVS/Entries
-share/doc/pgsql/src/CVS/Repository
-share/doc/pgsql/src/CVS/Root
-share/doc/pgsql/src/CVS/Tag
-share/doc/pgsql/src/Makefile
-share/doc/pgsql/src/graphics/CVS/Entries
-share/doc/pgsql/src/graphics/CVS/Repository
-share/doc/pgsql/src/graphics/CVS/Root
-share/doc/pgsql/src/graphics/CVS/Tag
-share/doc/pgsql/src/graphics/catalogs.gif
-share/doc/pgsql/src/graphics/catalogs.ps
-share/doc/pgsql/src/graphics/clientserver.ag
-share/doc/pgsql/src/graphics/clientserver.gif
-share/doc/pgsql/src/graphics/connections.ag
-share/doc/pgsql/src/graphics/connections.gif
-share/doc/pgsql/src/graphics/layout.ag
-share/doc/pgsql/src/graphics/layout.gif
-share/doc/pgsql/src/sgml/CVS/Entries
-share/doc/pgsql/src/sgml/CVS/Repository
-share/doc/pgsql/src/sgml/CVS/Root
-share/doc/pgsql/src/sgml/CVS/Tag
-share/doc/pgsql/src/sgml/Makefile
-share/doc/pgsql/src/sgml/about.sgml
-share/doc/pgsql/src/sgml/admin.sgml
-share/doc/pgsql/src/sgml/advanced.sgml
-share/doc/pgsql/src/sgml/arch-dev.sgml
-share/doc/pgsql/src/sgml/arch-pg.sgml
-share/doc/pgsql/src/sgml/arch.sgml
-share/doc/pgsql/src/sgml/array.sgml
-share/doc/pgsql/src/sgml/biblio.sgml
-share/doc/pgsql/src/sgml/bki.sgml
-share/doc/pgsql/src/sgml/compiler.sgml
-share/doc/pgsql/src/sgml/config.sgml
-share/doc/pgsql/src/sgml/contacts.sgml
-share/doc/pgsql/src/sgml/current.sgml
-share/doc/pgsql/src/sgml/datatype.sgml
-share/doc/pgsql/src/sgml/dfunc.sgml
-share/doc/pgsql/src/sgml/docguide.sgml
-share/doc/pgsql/src/sgml/ecpg.sgml
-share/doc/pgsql/src/sgml/environ.sgml
-share/doc/pgsql/src/sgml/extend.sgml
-share/doc/pgsql/src/sgml/func-ref.sgml
-share/doc/pgsql/src/sgml/func.sgml
-share/doc/pgsql/src/sgml/geqo.sgml
-share/doc/pgsql/src/sgml/gist.sgml
-share/doc/pgsql/src/sgml/history.sgml
-share/doc/pgsql/src/sgml/indices.sgml
-share/doc/pgsql/src/sgml/info.sgml
-share/doc/pgsql/src/sgml/inherit.sgml
-share/doc/pgsql/src/sgml/install.sgml
-share/doc/pgsql/src/sgml/installation.sgml
-share/doc/pgsql/src/sgml/intro-ag.sgml
-share/doc/pgsql/src/sgml/intro-pg.sgml
-share/doc/pgsql/src/sgml/intro.sgml
-share/doc/pgsql/src/sgml/jdbc.sgml
-share/doc/pgsql/src/sgml/keys.sgml
-share/doc/pgsql/src/sgml/legal.sgml
-share/doc/pgsql/src/sgml/libpgtcl.sgml
-share/doc/pgsql/src/sgml/libpq++.sgml
-share/doc/pgsql/src/sgml/libpq.sgml
-share/doc/pgsql/src/sgml/lobj.sgml
-share/doc/pgsql/src/sgml/manage.sgml
-share/doc/pgsql/src/sgml/notation.sgml
-share/doc/pgsql/src/sgml/odbc.sgml
-share/doc/pgsql/src/sgml/oper.sgml
-share/doc/pgsql/src/sgml/page.sgml
-share/doc/pgsql/src/sgml/pg_options.sgml
-share/doc/pgsql/src/sgml/pgaccess.sgml
-share/doc/pgsql/src/sgml/ports.sgml
-share/doc/pgsql/src/sgml/postgres.sgml
-share/doc/pgsql/src/sgml/programmer.sgml
-share/doc/pgsql/src/sgml/protocol.sgml
-share/doc/pgsql/src/sgml/psql.sgml
-share/doc/pgsql/src/sgml/query-ug.sgml
-share/doc/pgsql/src/sgml/query.sgml
-share/doc/pgsql/src/sgml/recovery.sgml
-share/doc/pgsql/src/sgml/ref/CVS/Entries
-share/doc/pgsql/src/sgml/ref/CVS/Repository
-share/doc/pgsql/src/sgml/ref/CVS/Root
-share/doc/pgsql/src/sgml/ref/CVS/Tag
-share/doc/pgsql/src/sgml/ref/abort.sgml
-share/doc/pgsql/src/sgml/ref/allfiles.sgml
-share/doc/pgsql/src/sgml/ref/alter_table.sgml
-share/doc/pgsql/src/sgml/ref/alter_user.sgml
-share/doc/pgsql/src/sgml/ref/begin.sgml
-share/doc/pgsql/src/sgml/ref/close.sgml
-share/doc/pgsql/src/sgml/ref/cluster.sgml
-share/doc/pgsql/src/sgml/ref/commands.sgml
-share/doc/pgsql/src/sgml/ref/commit.sgml
-share/doc/pgsql/src/sgml/ref/copy.sgml
-share/doc/pgsql/src/sgml/ref/create_aggregate.sgml
-share/doc/pgsql/src/sgml/ref/create_database.sgml
-share/doc/pgsql/src/sgml/ref/create_function.sgml
-share/doc/pgsql/src/sgml/ref/create_index.sgml
-share/doc/pgsql/src/sgml/ref/create_language.sgml
-share/doc/pgsql/src/sgml/ref/create_operator.sgml
-share/doc/pgsql/src/sgml/ref/create_rule.sgml
-share/doc/pgsql/src/sgml/ref/create_sequence.sgml
-share/doc/pgsql/src/sgml/ref/create_table.sgml
-share/doc/pgsql/src/sgml/ref/create_trigger.sgml
-share/doc/pgsql/src/sgml/ref/create_type.sgml
-share/doc/pgsql/src/sgml/ref/create_user.sgml
-share/doc/pgsql/src/sgml/ref/create_view.sgml
-share/doc/pgsql/src/sgml/ref/createdb.sgml
-share/doc/pgsql/src/sgml/ref/createuser.sgml
-share/doc/pgsql/src/sgml/ref/current_date.sgml
-share/doc/pgsql/src/sgml/ref/current_time.sgml
-share/doc/pgsql/src/sgml/ref/current_timestamp.sgml
-share/doc/pgsql/src/sgml/ref/current_user.sgml
-share/doc/pgsql/src/sgml/ref/declare.sgml
-share/doc/pgsql/src/sgml/ref/delete.sgml
-share/doc/pgsql/src/sgml/ref/destroydb.sgml
-share/doc/pgsql/src/sgml/ref/destroyuser.sgml
-share/doc/pgsql/src/sgml/ref/drop_aggregate.sgml
-share/doc/pgsql/src/sgml/ref/drop_database.sgml
-share/doc/pgsql/src/sgml/ref/drop_function.sgml
-share/doc/pgsql/src/sgml/ref/drop_index.sgml
-share/doc/pgsql/src/sgml/ref/drop_language.sgml
-share/doc/pgsql/src/sgml/ref/drop_operator.sgml
-share/doc/pgsql/src/sgml/ref/drop_rule.sgml
-share/doc/pgsql/src/sgml/ref/drop_sequence.sgml
-share/doc/pgsql/src/sgml/ref/drop_table.sgml
-share/doc/pgsql/src/sgml/ref/drop_trigger.sgml
-share/doc/pgsql/src/sgml/ref/drop_type.sgml
-share/doc/pgsql/src/sgml/ref/drop_user.sgml
-share/doc/pgsql/src/sgml/ref/drop_view.sgml
-share/doc/pgsql/src/sgml/ref/explain.sgml
-share/doc/pgsql/src/sgml/ref/fetch.sgml
-share/doc/pgsql/src/sgml/ref/grant.sgml
-share/doc/pgsql/src/sgml/ref/initdb.sgml
-share/doc/pgsql/src/sgml/ref/initlocation.sgml
-share/doc/pgsql/src/sgml/ref/insert.sgml
-share/doc/pgsql/src/sgml/ref/listen.sgml
-share/doc/pgsql/src/sgml/ref/load.sgml
-share/doc/pgsql/src/sgml/ref/lock.sgml
-share/doc/pgsql/src/sgml/ref/move.sgml
-share/doc/pgsql/src/sgml/ref/notify.sgml
-share/doc/pgsql/src/sgml/ref/pg_dump.sgml
-share/doc/pgsql/src/sgml/ref/pg_dumpall.sgml
-share/doc/pgsql/src/sgml/ref/pg_upgrade.sgml
-share/doc/pgsql/src/sgml/ref/psql-ref.sgml
-share/doc/pgsql/src/sgml/ref/reset.sgml
-share/doc/pgsql/src/sgml/ref/revoke.sgml
-share/doc/pgsql/src/sgml/ref/rollback.sgml
-share/doc/pgsql/src/sgml/ref/select.sgml
-share/doc/pgsql/src/sgml/ref/set.sgml
-share/doc/pgsql/src/sgml/ref/show.sgml
-share/doc/pgsql/src/sgml/ref/unlisten.sgml
-share/doc/pgsql/src/sgml/ref/update.sgml
-share/doc/pgsql/src/sgml/ref/vacuum.sgml
-share/doc/pgsql/src/sgml/reference.sgml
-share/doc/pgsql/src/sgml/regress.sgml
-share/doc/pgsql/src/sgml/release.sgml
-share/doc/pgsql/src/sgml/rules.sgml
-share/doc/pgsql/src/sgml/runtime.sgml
-share/doc/pgsql/src/sgml/security.sgml
-share/doc/pgsql/src/sgml/signals.sgml
-share/doc/pgsql/src/sgml/spi.sgml
-share/doc/pgsql/src/sgml/start-ag.sgml
-share/doc/pgsql/src/sgml/start.sgml
-share/doc/pgsql/src/sgml/storage.sgml
-share/doc/pgsql/src/sgml/syntax.sgml
-share/doc/pgsql/src/sgml/trigger.sgml
-share/doc/pgsql/src/sgml/tutorial.sgml
-share/doc/pgsql/src/sgml/typeconv.sgml
-share/doc/pgsql/src/sgml/user.sgml
-share/doc/pgsql/src/sgml/xaggr.sgml
-share/doc/pgsql/src/sgml/xfunc.sgml
-share/doc/pgsql/src/sgml/xindex.sgml
-share/doc/pgsql/src/sgml/xoper.sgml
-share/doc/pgsql/src/sgml/xplang.sgml
-share/doc/pgsql/src/sgml/xtypes.sgml
-share/doc/pgsql/src/sgml/y2k.sgml
-share/doc/pgsql/tutorial.ps.gz
-share/doc/pgsql/tutorial.tar.gz
-share/doc/pgsql/user.ps.gz
-share/doc/pgsql/user.tar.gz
-@dirrm share/doc/pgsql/src/sgml/ref/CVS
-@dirrm share/doc/pgsql/src/sgml/ref
-@dirrm share/doc/pgsql/src/sgml/CVS
-@dirrm share/doc/pgsql/src/sgml
-@dirrm share/doc/pgsql/src/graphics/CVS
-@dirrm share/doc/pgsql/src/graphics
-@dirrm share/doc/pgsql/src/CVS
-@dirrm share/doc/pgsql/src
-@dirrm share/doc/pgsql/CVS
-@dirrm share/doc/pgsql
-@dirrm pgsql/man/manl
-@dirrm pgsql/man/man5
-@dirrm pgsql/man/man3
-@dirrm pgsql/man/man1
-@dirrm pgsql/man
-@dirrm pgsql/lib
-@dirrm pgsql/include/utils
-@dirrm pgsql/include/port/freebsd
-@dirrm pgsql/include/port
-@dirrm pgsql/include/libpq++
-@dirrm pgsql/include/libpq
-@dirrm pgsql/include/lib
-@dirrm pgsql/include/executor
-@dirrm pgsql/include/commands
-@dirrm pgsql/include/access
-@dirrm pgsql/include
-@dirrm pgsql/data/base/template1
-@dirrm pgsql/data/base
-@dirrm pgsql/data
-@dirrm pgsql/bin
-@dirrm pgsql
diff --git a/databases/postgresql83-server/scripts/createuser b/databases/postgresql83-server/scripts/createuser
deleted file mode 100644
index 2abe201e7a4b..000000000000
--- a/databases/postgresql83-server/scripts/createuser
+++ /dev/null
@@ -1,50 +0,0 @@
-#!/usr/bin/perl
-#
-
-eval '(exit $?0)' && eval 'exec /usr/bin/perl -S $0 ${1+"$@"}'
-& eval 'exec /usr/bin/perl -S $0 $argv:q'
-if 0;
-
-if( $> ) {
- print "\nYou must be root to run this step!\n\n";
- exit 1;
-}
-
-if( getpwnam( "pgsql" ) ) {
- ( $null, $null, $pgUID ) = getpwnam( "pgsql" );
-} else {
- $pgUID = 70;
- while( getpwuid( $pgUID ) ) {
- $pgUID++;
- }
-}
-
-if( getgrnam( "pgsql" ) ) {
- ( $null, $null, $pgGID ) = getgrnam( "pgsql" );
-} else {
- $pgGID = 70;
- while( getgrgid( $pgGID ) ) {
- $pgGID++;
- }
- &append_file( "/etc/group", "pgsql:*:$pgGID:" );
-}
-
-print "pgsql user using uid $pgUID\n";
-print "pgsql user using gid $pgGID\n";
-
-system( "/usr/bin/chpass -a \"pgsql:*:$pgUID:$pgGID\:\:0:0:PostgreSQL pseudo-user:$ENV{'PREFIX'}/pgsql:/bin/sh\"" );
-
-sub append_file {
- local($file,@list) = @_;
- local($LOCK_EX) = 2;
- local($LOCK_NB) = 4;
- local($LOCK_UN) = 8;
-
- open(F, ">> $file") || die "$file: $!\n";
- while( ! flock( F, $LOCK_EX | $LOCK_NB ) ) {
- exit 1;
- }
- print F join( "\n", @list) . "\n";
- close F;
- flock( F, $LOCK_UN );
-}