aboutsummaryrefslogtreecommitdiff
path: root/databases/postgresql84-server/files
diff options
context:
space:
mode:
Diffstat (limited to 'databases/postgresql84-server/files')
-rw-r--r--databases/postgresql84-server/files/502.pgsql97
-rw-r--r--databases/postgresql84-server/files/dot.cshrc.in11
-rw-r--r--databases/postgresql84-server/files/dot.profile.in22
-rw-r--r--databases/postgresql84-server/files/patch-plpython-Makefile11
-rw-r--r--databases/postgresql84-server/files/patch-src-makefiles-Makefile.freebsd8
-rw-r--r--databases/postgresql84-server/files/patch-src:backend:utils:misc:postgresql.conf.sample18
-rw-r--r--databases/postgresql84-server/files/pgsql.sh.tmpl59
-rw-r--r--databases/postgresql84-server/files/pkgIndex.tcl.in4
-rw-r--r--databases/postgresql84-server/files/regresspatch-src-test-regress-pgregress-sh12
9 files changed, 0 insertions, 242 deletions
diff --git a/databases/postgresql84-server/files/502.pgsql b/databases/postgresql84-server/files/502.pgsql
deleted file mode 100644
index 09591559c317..000000000000
--- a/databases/postgresql84-server/files/502.pgsql
+++ /dev/null
@@ -1,97 +0,0 @@
-#!/bin/sh
-#
-# $FreeBSD$
-#
-# Maintenance shell script to vacuum and backup database
-# Put this in /usr/local/etc/periodic/daily, and it will be run
-# every night
-#
-# Written by Palle Girgensohn <girgen@pingpong.net>
-#
-# In public domain, do what you like with it,
-# and use it at your own risk... :)
-#
-
-# Define these variables in either /etc/periodic.conf or
-# /etc/periodic.conf.local to override the default values.
-#
-# daily_pgsql_backup_enable="YES" # do backup
-# daily_pgsql_vacuum_enable="YES" # do vacuum
-
-daily_pgsql_vacuum_enable="YES"
-daily_pgsql_backup_enable="NO"
-
-daily_pgsql_vacuum_args="-z"
-daily_pgsql_pgdump_args="-b -F c"
-# backupdir is relative to ~pgsql home directory unless it begins with a slash:
-daily_pgsql_backupdir="~pgsql/backups"
-daily_pgsql_savedays="7"
-
-# If there is a global system configuration file, suck it in.
-#
-if [ -r /etc/defaults/periodic.conf ]
-then
- . /etc/defaults/periodic.conf
- source_periodic_confs
-fi
-
-# allow '~´ in dir name
-eval backupdir=${daily_pgsql_backupdir}
-
-rc=0
-
-case "$daily_pgsql_backup_enable" in
- [Yy][Ee][Ss])
-
- # daily_pgsql_backupdir must be writeable by user pgsql
- # ~pgsql is just that under normal circumstances,
- # but this might not be where you want the backups...
- if [ ! -d ${backupdir} ] ; then
- echo Creating ${backupdir}
- mkdir ${backupdir}; chmod 700 ${backupdir}; chown pgsql ${backupdir}
- fi
-
- echo
- echo "PostgreSQL maintenance"
-
- # Protect the data
- umask 077
- dbnames=`su -l pgsql -c "psql -q -t -A -d template1 -c SELECT\ datname\ FROM\ pg_database\ WHERE\ datname!=\'template0\'"`
- rc=$?
- now=`date "+%Y-%m-%dT%H:%M:%S"`
- file=${daily_pgsql_backupdir}/pgglobals_${now}
- su -l pgsql -c "pg_dumpall -g | gzip -9 > ${file}.gz"
- for db in ${dbnames}; do
- echo -n " $db"
- file=${backupdir}/pgdump_${db}_${now}
- su -l pgsql -c "pg_dump ${daily_pgsql_pgdump_args} -f ${file} ${db}"
- [ $? -gt 0 ] && rc=3
- done
-
- if [ $rc -gt 0 ]; then
- echo
- echo "Errors were reported during backup."
- fi
-
- # cleaning up old data
- find ${backupdir} \( -name 'pgdump_*' -o -name 'pgglobals_*' \) \
- -a -mtime +${daily_pgsql_savedays} -delete
- ;;
-esac
-
-case "$daily_pgsql_vacuum_enable" in
- [Yy][Ee][Ss])
-
- echo
- echo "vacuuming..."
- su -l pgsql -c "vacuumdb -a -q ${daily_pgsql_vacuum_args}"
- if [ $? -gt 0 ]
- then
- echo
- echo "Errors were reported during vacuum."
- rc=3
- fi
- ;;
-esac
-
-exit $rc
diff --git a/databases/postgresql84-server/files/dot.cshrc.in b/databases/postgresql84-server/files/dot.cshrc.in
deleted file mode 100644
index 4069398b376e..000000000000
--- a/databases/postgresql84-server/files/dot.cshrc.in
+++ /dev/null
@@ -1,11 +0,0 @@
-setenv PGLIB %%PREFIX%%/lib
-
-# note: PGDATA can be overridden by the -D startup option
-setenv PGDATA $HOME/data
-
-#You might want to set some locale stuff here
-#setenv PGDATESTYLE ISO
-#setenv LC_ALL sv_SE.ISO_8859-1
-
-# if you want to make regression tests use this TZ
-#setenv TZ PST8PDT
diff --git a/databases/postgresql84-server/files/dot.profile.in b/databases/postgresql84-server/files/dot.profile.in
deleted file mode 100644
index 954e22eae8f8..000000000000
--- a/databases/postgresql84-server/files/dot.profile.in
+++ /dev/null
@@ -1,22 +0,0 @@
-PGLIB=%%PREFIX%%/lib
-
-# note: PGDATA can be overridden by the -D startup option
-PGDATA=${HOME}/data
-
-export PATH PGLIB PGDATA
-
-# if you use the periodic script from share/postgresql/502.pgsql, you
-# can set these
-#PGDUMP_ARGS="-b -F c"
-#PGBACKUPDIR=${HOME}/backups
-#PGBACKUP_SAVE_DAYS=7
-#export PGBACKUPDIR PGDUMP_ARGS PGBACKUP_SAVE_DAYS
-
-#You might want to set some locale stuff here
-#PGDATESTYLE=ISO
-#LC_ALL=sv_SE.ISO_8859-1
-#export PGDATESTYLE LC_ALL
-
-# if you want to make regression tests use this TZ
-#TZ=PST8PDT
-#export TZ
diff --git a/databases/postgresql84-server/files/patch-plpython-Makefile b/databases/postgresql84-server/files/patch-plpython-Makefile
deleted file mode 100644
index 3357b699da8a..000000000000
--- a/databases/postgresql84-server/files/patch-plpython-Makefile
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/pl/plpython/Makefile.orig Fri Nov 19 20:23:01 2004
-+++ src/pl/plpython/Makefile Tue Dec 28 23:32:16 2004
-@@ -9,7 +9,7 @@
- # shared library. Since there is no official way to determine this
- # (at least not in pre-2.3 Python), we see if there is a file that is
- # named like a shared library.
--ifneq (,$(wildcard $(python_libdir)/libpython*$(DLSUFFIX)*))
-+ifneq (,$(wildcard $(python_libdir)/../../libpython*$(DLSUFFIX)*))
- shared_libpython = yes
- endif
-
diff --git a/databases/postgresql84-server/files/patch-src-makefiles-Makefile.freebsd b/databases/postgresql84-server/files/patch-src-makefiles-Makefile.freebsd
deleted file mode 100644
index 81339e98e8db..000000000000
--- a/databases/postgresql84-server/files/patch-src-makefiles-Makefile.freebsd
+++ /dev/null
@@ -1,8 +0,0 @@
---- src/makefiles/Makefile.freebsd.orig Fri Nov 19 01:41:39 2004
-+++ src/makefiles/Makefile.freebsd Tue Dec 21 02:44:09 2004
-@@ -29,3 +29,5 @@
- endif
-
- sqlmansect = 7
-+
-+allow_nonpic_in_shlib = yes
diff --git a/databases/postgresql84-server/files/patch-src:backend:utils:misc:postgresql.conf.sample b/databases/postgresql84-server/files/patch-src:backend:utils:misc:postgresql.conf.sample
deleted file mode 100644
index da57f46e3552..000000000000
--- a/databases/postgresql84-server/files/patch-src:backend:utils:misc:postgresql.conf.sample
+++ /dev/null
@@ -1,18 +0,0 @@
---- src/backend/utils/misc/postgresql.conf.sample~ Tue Nov 8 00:45:49 2005
-+++ src/backend/utils/misc/postgresql.conf.sample Tue Nov 8 00:47:16 2005
-@@ -206,6 +206,7 @@
-
- # - Where to Log -
-
-+log_destination = 'syslog'
- #log_destination = 'stderr' # Valid values are combinations of
- # stderr, syslog and eventlog,
- # depending on platform.
-@@ -283,6 +284,7 @@
- #log_min_duration_statement = -1 # -1 is disabled, 0 logs all statements
- # and their durations, in milliseconds.
-
-+silent_mode = on
- #silent_mode = off # DO NOT USE without syslog or
- # redirect_stderr
-
diff --git a/databases/postgresql84-server/files/pgsql.sh.tmpl b/databases/postgresql84-server/files/pgsql.sh.tmpl
deleted file mode 100644
index e6a538b409a2..000000000000
--- a/databases/postgresql84-server/files/pgsql.sh.tmpl
+++ /dev/null
@@ -1,59 +0,0 @@
-#!/bin/sh
-
-# $FreeBSD$
-#
-# PROVIDE: postgresql
-# REQUIRE: LOGIN
-# KEYWORD: shutdown
-#
-# Add the following line to /etc/rc.conf to enable PostgreSQL:
-#
-# postgresql_enable="YES"
-# # optional
-# postgresql_data="%%PREFIX%%/pgsql/data"
-# postgresql_flags="-w -s -m fast"
-#
-# This scripts takes one of the following commands:
-#
-# start stop restart reload status initdb
-#
-# For postmaster startup options, edit ${postgresql_data}/postgresql.conf
-
-prefix=%%PREFIX%%
-
-. %%RC_SUBR%%
-
-load_rc_config postgresql
-
-# set defaults
-postgresql_enable=${postgresql_enable:-"NO"}
-postgresql_flags=${postgresql_flags:-"-w -s -m fast"}
-postgresql_user=pgsql
-eval postgresql_data=${postgresql_data:-"~${postgresql_user}/data"}
-postgresql_class=${postgresql_class:-"default"}
-
-name=postgresql
-rcvar=`set_rcvar`
-command=${prefix}/bin/pg_ctl
-command_args="-D ${postgresql_data} ${postgresql_flags}"
-extra_commands="reload initdb"
-
-start_cmd="postgresql_command start"
-stop_cmd="postgresql_command stop"
-restart_cmd="postgresql_command restart"
-reload_cmd="postgresql_command reload"
-status_cmd="postgresql_command status"
-
-initdb_cmd="postgresql_initdb"
-
-postgresql_command()
-{
- su -l ${postgresql_user} -c "exec ${command} ${command_args} ${rc_arg}"
-}
-
-postgresql_initdb()
-{
- su -l -c ${postgresql_class} ${postgresql_user} -c "exec ${prefix}/bin/initdb -D ${postgresql_data}"
-}
-
-run_rc_command "$1"
diff --git a/databases/postgresql84-server/files/pkgIndex.tcl.in b/databases/postgresql84-server/files/pkgIndex.tcl.in
deleted file mode 100644
index bd8329b15c69..000000000000
--- a/databases/postgresql84-server/files/pkgIndex.tcl.in
+++ /dev/null
@@ -1,4 +0,0 @@
-# Package-index file for Pgtcl-package. Enables you to load PostgreSQL
-# interface functions right into you TCL-interpreter as simply as
-# package require Pgtcl
-package ifneeded Pgtcl 1.3 "load %%PREFIX%%/lib/libpgtcl.so"
diff --git a/databases/postgresql84-server/files/regresspatch-src-test-regress-pgregress-sh b/databases/postgresql84-server/files/regresspatch-src-test-regress-pgregress-sh
deleted file mode 100644
index f2ebbf5cb96e..000000000000
--- a/databases/postgresql84-server/files/regresspatch-src-test-regress-pgregress-sh
+++ /dev/null
@@ -1,12 +0,0 @@
---- src/test/regress/pg_regress.sh~ Sun Dec 12 16:34:15 2004
-+++ src/test/regress/pg_regress.sh Sat Jan 8 05:12:46 2005
-@@ -410,6 +410,9 @@
- (exit 2); exit
- fi
-
-+ # make rest of this script happy
-+ echo "log_destination = 'stderr'" >> $PGDATA/postgresql.conf
-+ echo "silent_mode = false" >> $PGDATA/postgresql.conf
-
- # ----------
- # Start postmaster